summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/dovecot/dovecot/0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/dovecot/dovecot/0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch')
-rw-r--r--meta-networking/recipes-support/dovecot/dovecot/0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch91
1 files changed, 91 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/dovecot/dovecot/0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch b/meta-networking/recipes-support/dovecot/dovecot/0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch
new file mode 100644
index 000000000..6f5c279be
--- /dev/null
+++ b/meta-networking/recipes-support/dovecot/dovecot/0001-configure.ac-convert-AC_TRY_RUN-to-AC_TRY_LINK-state.patch
@@ -0,0 +1,91 @@
1From 483f120603ada8db680085e3f462396da937e036 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Wed, 8 Jan 2014 09:30:36 +0100
4Subject: [PATCH] configure.ac: convert AC_TRY_RUN to AC_TRY_LINK statements
5
6This is not completely safe, but it's the least invasive fix.
7
8Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
9Upstream-status: Inappropriate
10---
11 configure.ac | 23 +++++++----------------
12 1 file changed, 7 insertions(+), 16 deletions(-)
13
14diff --git a/configure.ac b/configure.ac
15index 95984bb..dff1f87 100644
16--- a/configure.ac
17+++ b/configure.ac
18@@ -499,13 +499,10 @@ have_ioloop=no
19
20 if test "$ioloop" = "best" || test "$ioloop" = "epoll"; then
21 AC_CACHE_CHECK([whether we can use epoll],i_cv_epoll_works,[
22- AC_TRY_RUN([
23+ AC_TRY_LINK([
24 #include <sys/epoll.h>
25-
26- int main()
27- {
28- return epoll_create(5) < 1;
29- }
30+ ], [
31+ epoll_create(5) < 1;
32 ], [
33 i_cv_epoll_works=yes
34 ], [
35@@ -551,15 +548,13 @@ have_notify=none
36 if test "$notify" = "" || test "$notify" = "inotify" ; then
37 dnl * inotify?
38 AC_CACHE_CHECK([whether we can use inotify],i_cv_inotify_works,[
39- AC_TRY_RUN([
40+ AC_TRY_LINK([
41 #define _GNU_SOURCE
42 #include <sys/ioctl.h>
43 #include <fcntl.h>
44 #include <sys/inotify.h>
45 #include <stdio.h>
46-
47- int main()
48- {
49+ ], [
50 int wd, fd;
51 char * fn = "/tmp";
52
53@@ -581,8 +576,6 @@ if test "$notify" = "" || test "$notify" = "inotify" ; then
54 inotify_rm_watch (fd, wd);
55
56 close (fd);
57- return 0;
58- }
59 ], [
60 i_cv_inotify_works=yes
61 ], [
62@@ -670,7 +663,7 @@ fi
63 dnl * Old glibcs have broken posix_fallocate(). Make sure not to use it.
64 dnl * It may also be broken in AIX.
65 AC_CACHE_CHECK([whether posix_fallocate() works],i_cv_posix_fallocate_works,[
66- AC_TRY_RUN([
67+ AC_TRY_LINK([
68 #define _XOPEN_SOURCE 600
69 #include <stdio.h>
70 #include <stdlib.h>
71@@ -679,7 +672,7 @@ AC_CACHE_CHECK([whether posix_fallocate() works],i_cv_posix_fallocate_works,[
72 #if defined(__GLIBC__) && (__GLIBC__ < 2 || __GLIBC_MINOR__ < 7)
73 possibly broken posix_fallocate
74 #endif
75- int main() {
76+ ], [
77 int fd = creat("conftest.temp", 0600);
78 int ret;
79 if (fd == -1) {
80@@ -688,8 +681,6 @@ AC_CACHE_CHECK([whether posix_fallocate() works],i_cv_posix_fallocate_works,[
81 }
82 ret = posix_fallocate(fd, 1024, 1024) < 0 ? 1 : 0;
83 unlink("conftest.temp");
84- return ret;
85- }
86 ], [
87 i_cv_posix_fallocate_works=yes
88 ], [
89--
901.8.4.2
91