diff options
Diffstat (limited to 'meta-networking/recipes-support/curlpp')
-rw-r--r-- | meta-networking/recipes-support/curlpp/curlpp/example21.cpp-remove-deprecated-code.patch | 47 | ||||
-rw-r--r-- | meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb | 3 |
2 files changed, 48 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/curlpp/curlpp/example21.cpp-remove-deprecated-code.patch b/meta-networking/recipes-support/curlpp/curlpp/example21.cpp-remove-deprecated-code.patch new file mode 100644 index 0000000000..dae583d854 --- /dev/null +++ b/meta-networking/recipes-support/curlpp/curlpp/example21.cpp-remove-deprecated-code.patch | |||
@@ -0,0 +1,47 @@ | |||
1 | example21.cpp: remove deprecated code | ||
2 | |||
3 | The deprecated code was no longer used, so remove it to avoid | ||
4 | compiling failure with -Werror=unused-function | ||
5 | ... | ||
6 | | example21.cpp:51:8: error: 'size_t {anonymous}::readData(char*, | ||
7 | size_t, size_t)' defined but not used [-Werror=unused-function] | ||
8 | | size_t readData(char *buffer, size_t size, size_t nitems) | ||
9 | ... | ||
10 | |||
11 | Upstream-Status: Pending | ||
12 | |||
13 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
14 | --- | ||
15 | examples/example21.cpp | 17 ----------------- | ||
16 | 1 file changed, 17 deletions(-) | ||
17 | |||
18 | diff --git a/examples/example21.cpp b/examples/example21.cpp | ||
19 | --- a/examples/example21.cpp | ||
20 | +++ b/examples/example21.cpp | ||
21 | @@ -39,23 +39,6 @@ | ||
22 | #include <curlpp/Options.hpp> | ||
23 | #include <curlpp/Exception.hpp> | ||
24 | |||
25 | -/* | ||
26 | - anonymous namespace to prevent name clash in case other examples using the same global entities | ||
27 | - would be compiled in the same project | ||
28 | -*/ | ||
29 | -namespace | ||
30 | -{ | ||
31 | - | ||
32 | -char *data = NULL; | ||
33 | - | ||
34 | -size_t readData(char *buffer, size_t size, size_t nitems) | ||
35 | -{ | ||
36 | - strncpy(buffer, data, size * nitems); | ||
37 | - return size * nitems; | ||
38 | -} | ||
39 | - | ||
40 | -} // namespace | ||
41 | - | ||
42 | int main(int argc, char *argv[]) | ||
43 | { | ||
44 | if(argc != 3) { | ||
45 | -- | ||
46 | 1.9.1 | ||
47 | |||
diff --git a/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb b/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb index d24c958736..48f5178b52 100644 --- a/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb +++ b/meta-networking/recipes-support/curlpp/curlpp_0.7.3.bb | |||
@@ -4,12 +4,11 @@ SECTION = "console/network" | |||
4 | LICENSE = "MIT" | 4 | LICENSE = "MIT" |
5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" | 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
6 | 6 | ||
7 | PNBLACKLIST[curlpp] = "BROKEN: since gcc upgrade to 4.9, error: 'size_t {anonymous}::readData(char*, size_t, size_t)' defined but not used [-Werror=unused-function]" | ||
8 | |||
9 | DEPENDS = "curl boost" | 7 | DEPENDS = "curl boost" |
10 | DEPENDS_class-native = "curl-native" | 8 | DEPENDS_class-native = "curl-native" |
11 | 9 | ||
12 | SRC_URI = "http://curlpp.googlecode.com/files/curlpp-${PV}.tar.gz \ | 10 | SRC_URI = "http://curlpp.googlecode.com/files/curlpp-${PV}.tar.gz \ |
11 | file://example21.cpp-remove-deprecated-code.patch \ | ||
13 | " | 12 | " |
14 | 13 | ||
15 | SRC_URI[md5sum] = "ccc3d30d4b3b5d2cdbed635898c29485" | 14 | SRC_URI[md5sum] = "ccc3d30d4b3b5d2cdbed635898c29485" |