diff options
Diffstat (limited to 'meta-networking/recipes-protocols')
10 files changed, 435 insertions, 0 deletions
diff --git a/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/configure_in_cross.patch b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/configure_in_cross.patch new file mode 100644 index 000000000..189675942 --- /dev/null +++ b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/configure_in_cross.patch | |||
@@ -0,0 +1,142 @@ | |||
1 | Update the configure script to cross-compiling with OE. This hard-codes | ||
2 | a few target paths, reworks a few tests to be more friendly for cross | ||
3 | and drops other tests. | ||
4 | |||
5 | Upstream-Status: Inappropriate [build system specific changes] | ||
6 | |||
7 | Index: src/configure.in | ||
8 | =================================================================== | ||
9 | --- rp-pppoe-3.8.orig/src/configure.in 2006-04-03 00:29:42.000000000 +1000 | ||
10 | +++ rp-pppoe-3.8/src/configure.in 2007-06-07 22:19:36.000000000 +1000 | ||
11 | @@ -5,6 +5,13 @@ | ||
12 | dnl pppd directory for kernel-mode PPPoE | ||
13 | PPPD_DIR=ppp-2.4.1.pppoe2 | ||
14 | |||
15 | +dnl hard code some paths | ||
16 | +PPPD=/usr/sbin/pppd | ||
17 | +ID=/usr/bin/id | ||
18 | +ECHO=/bin/echo | ||
19 | +AC_ARG_VAR(PPPD) | ||
20 | +AC_ARG_VAR(ID) | ||
21 | + | ||
22 | AC_CONFIG_HEADER(config.h) | ||
23 | |||
24 | AC_PREFIX_DEFAULT(/usr) | ||
25 | @@ -44,7 +51,7 @@ | ||
26 | AC_MSG_RESULT($ac_cv_struct_sockaddr_ll) | ||
27 | |||
28 | if test "$ac_cv_struct_sockaddr_ll" = yes ; then | ||
29 | -AC_DEFINE(HAVE_STRUCT_SOCKADDR_LL) | ||
30 | +AC_DEFINE([HAVE_STRUCT_SOCKADDR_LL], [], [Have struct SOCKADDR_LL]) | ||
31 | fi | ||
32 | |||
33 | dnl Check for N_HDLC line discipline | ||
34 | @@ -55,7 +62,7 @@ | ||
35 | ac_cv_n_hdlc=no) | ||
36 | AC_MSG_RESULT($ac_cv_n_hdlc) | ||
37 | if test "$ac_cv_n_hdlc" = yes ; then | ||
38 | -AC_DEFINE(HAVE_N_HDLC) | ||
39 | +AC_DEFINE([HAVE_N_HDLC], [], [Have N_HDLC]) | ||
40 | fi | ||
41 | |||
42 | AC_ARG_ENABLE(plugin, [ --enable-plugin=pppd_src_path build pppd plugin], ac_cv_pluginpath=$enableval, ac_cv_pluginpath=no) | ||
43 | @@ -100,13 +107,13 @@ | ||
44 | if test "$ac_cv_header_linux_if_pppox_h" = yes ; then | ||
45 | if test "$ac_cv_pluginpath" != no ; then | ||
46 | LINUX_KERNELMODE_PLUGIN=rp-pppoe.so | ||
47 | - AC_DEFINE(HAVE_LINUX_KERNEL_PPPOE) | ||
48 | + AC_DEFINE([HAVE_LINUX_KERNEL_PPPOE], [], [Have kernel PPPoE]) | ||
49 | PPPD_INCDIR=$ac_cv_pluginpath | ||
50 | fi | ||
51 | fi | ||
52 | |||
53 | if test "$ac_cv_debugging" = "yes" ; then | ||
54 | - AC_DEFINE(DEBUGGING_ENABLED) | ||
55 | + AC_DEFINE([DEBUGGING_ENABLED], [], [Debugging enabled]) | ||
56 | fi | ||
57 | |||
58 | AC_SUBST(LINUX_KERNELMODE_PLUGIN) | ||
59 | @@ -131,15 +138,8 @@ | ||
60 | AC_CHECK_SIZEOF(unsigned int) | ||
61 | AC_CHECK_SIZEOF(unsigned long) | ||
62 | |||
63 | -dnl Check for location of pppd | ||
64 | -AC_PATH_PROG(PPPD, pppd, NOTFOUND, $PATH:/sbin:/usr/sbin:/usr/local/sbin) | ||
65 | -AC_PATH_PROG(ECHO, echo, echo) | ||
66 | - | ||
67 | -dnl Check for setsid (probably Linux-specific) | ||
68 | -AC_PATH_PROG(SETSID, setsid, "", $PATH:/sbin:/usr/sbin:/usr/local/sbin) | ||
69 | - | ||
70 | dnl Check for an "id" which accepts "-u" option -- hack for Solaris. | ||
71 | -AC_PATH_PROG(ID, id, "", /usr/xpg4/bin:$PATH) | ||
72 | +dnl AC_PATH_PROG(ID, id, "", /usr/xpg4/bin:$PATH) | ||
73 | |||
74 | dnl Check for Linux-specific kernel support for PPPoE | ||
75 | AC_MSG_CHECKING(for Linux 2.4.X kernel-mode PPPoE support) | ||
76 | @@ -183,44 +183,8 @@ | ||
77 | CFLAGS="$CFLAGS -Wall -Wstrict-prototypes -ansi" | ||
78 | fi | ||
79 | |||
80 | -dnl If we couldn't find pppd, die | ||
81 | -if test "$PPPD" = "NOTFOUND"; then | ||
82 | - AC_MSG_WARN([*** Oops! I couldn't find pppd, the PPP daemon anywhere.]) | ||
83 | - AC_MSG_WARN([*** You must install pppd, version 2.3.10 or later.]) | ||
84 | - AC_MSG_WARN([*** I will keep going, but it may not work.]) | ||
85 | - PPPD=pppd | ||
86 | -fi | ||
87 | - | ||
88 | -dnl Figure out pppd version. 2.3.7 to 2.3.9 -- issue warning. Less than | ||
89 | -dnl 2.3.7 -- stop | ||
90 | - | ||
91 | -PPPD_VERSION=`$PPPD --version 2>&1 | awk ' /version/ {print $NF}'` | ||
92 | - | ||
93 | -case "$PPPD_VERSION" in | ||
94 | -1.*|2.0.*|2.1.*|2.2.*|2.3.0|2.3.1|2.3.2|2.3.3|2.3.4|2.3.5|2.3.6) | ||
95 | - AC_MSG_WARN([*** Oops! Your version of pppd is $PPPD_VERSION, which is too old.]) | ||
96 | - AC_MSG_WARN([*** You need at least 2.3.7 (2.3.10 or newer recommended.]) | ||
97 | - AC_MSG_WARN([*** I will keep going, but it may not work.]) | ||
98 | - ;; | ||
99 | - | ||
100 | -2.3.7|2.3.8|2.3.9) | ||
101 | - AC_MSG_WARN([*** Warning. Your version of pppd is $PPPD_VERSION. You will]) | ||
102 | - AC_MSG_WARN([*** not be able to use connect-on-demand. Upgrade to pppd]) | ||
103 | - AC_MSG_WARN([*** 2.3.10 or newer if you need connect-on-demand.]) | ||
104 | - ;; | ||
105 | - | ||
106 | -2*|3*|4*|5*|6*|7*|8*|9*) | ||
107 | - ;; | ||
108 | - | ||
109 | -*) | ||
110 | - AC_MSG_WARN([*** Oops. I cannot figure out what version of pppd you have.]) | ||
111 | - AC_MSG_WARN([*** All I got back was '$PPPD_VERSION']) | ||
112 | - AC_MSG_WARN([*** I will keep going, but it may not work.]) | ||
113 | - ;; | ||
114 | -esac | ||
115 | - | ||
116 | dnl Figure out packing order of structures | ||
117 | -AC_MSG_CHECKING([packing order of bit fields]) | ||
118 | +AC_CACHE_CHECK([packing order of bit fields],rpppoe_cv_pack_bitfields,[ | ||
119 | AC_TRY_RUN([ | ||
120 | union foo { | ||
121 | struct bar { | ||
122 | @@ -245,10 +209,11 @@ | ||
123 | } | ||
124 | }], rpppoe_cv_pack_bitfields=normal, rpppoe_cv_pack_bitfields=rev, | ||
125 | $ECHO "no defaults for cross-compiling"; exit 0) | ||
126 | +]) | ||
127 | |||
128 | if test "$rpppoe_cv_pack_bitfields" = "rev" ; then | ||
129 | AC_MSG_RESULT(reversed) | ||
130 | - AC_DEFINE(PACK_BITFIELDS_REVERSED) | ||
131 | + AC_DEFINE([PACK_BITFIELDS_REVERSED], [], [Reversed bitfields]) | ||
132 | else | ||
133 | AC_MSG_RESULT(normal) | ||
134 | fi | ||
135 | @@ -312,6 +277,7 @@ | ||
136 | AC_SUBST(RDYNAMIC) | ||
137 | AC_SUBST(LIBEVENT) | ||
138 | AC_SUBST(ECHO) | ||
139 | +AC_SUBST(HAVE_STRUCT_SOCKADDR_LL) | ||
140 | |||
141 | datadir_evaluated=`eval echo $datadir` | ||
142 | AC_SUBST(datadir_evaluated) | ||
diff --git a/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/discard-use-of-dnl-in-Makefile.am.patch b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/discard-use-of-dnl-in-Makefile.am.patch new file mode 100644 index 000000000..8b7886485 --- /dev/null +++ b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/discard-use-of-dnl-in-Makefile.am.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | From 611c9fe719c5aa264a2ad2eb920cf4522ae2ddec Mon Sep 17 00:00:00 2001 | ||
2 | From: Ting Liu <b28495@freescale.com> | ||
3 | Date: Tue, 12 Jun 2012 14:26:16 -0400 | ||
4 | Subject: [PATCH] discard use of dnl in Makefile.am | ||
5 | |||
6 | Since Makefile.am is not processed by m4, but by automake, 'dnl' does | ||
7 | not introduce a comment. | ||
8 | |||
9 | Signed-off-by: Ting Liu <b28495@freescale.com> | ||
10 | --- | ||
11 | Makefile.am | 2 +- | ||
12 | 1 files changed, 1 insertions(+), 1 deletions(-) | ||
13 | |||
14 | diff --git a/Makefile.am b/Makefile.am | ||
15 | index eff6977..3091c33 100644 | ||
16 | --- a/Makefile.am | ||
17 | +++ b/Makefile.am | ||
18 | @@ -1,5 +1,5 @@ | ||
19 | PACKAGE = rp-pppoe | ||
20 | VERSION = 3.8 | ||
21 | |||
22 | -dnl AM_CFLAGS = -Wall -DDEBUG | ||
23 | +##dnl AM_CFLAGS = -Wall -DDEBUG | ||
24 | SUBDIRS = src | ||
25 | -- | ||
26 | 1.7.6.5 | ||
27 | |||
diff --git a/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/dont-swallow-errors.patch b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/dont-swallow-errors.patch new file mode 100644 index 000000000..c7fc9cfac --- /dev/null +++ b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/dont-swallow-errors.patch | |||
@@ -0,0 +1,15 @@ | |||
1 | Further fixup to the configure scripts to not swallow errors | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | |||
5 | --- a/src/configure.in.org 2008-01-14 21:08:38.000000000 +0200 | ||
6 | +++ a/src/configure.in 2008-01-14 21:20:09.000000000 +0200 | ||
7 | @@ -208,7 +208,7 @@ | ||
8 | return 2; | ||
9 | } | ||
10 | }], rpppoe_cv_pack_bitfields=normal, rpppoe_cv_pack_bitfields=rev, | ||
11 | -$ECHO "no defaults for cross-compiling"; exit 0) | ||
12 | +$ECHO "no defaults for cross-compiling"; exit 1) | ||
13 | ]) | ||
14 | |||
15 | if test "$rpppoe_cv_pack_bitfields" = "rev" ; then | ||
diff --git a/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/pppoe-server.default b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/pppoe-server.default new file mode 100644 index 000000000..996d57f3c --- /dev/null +++ b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/pppoe-server.default | |||
@@ -0,0 +1,22 @@ | |||
1 | # PPPoE Server options | ||
2 | |||
3 | # Maximum segment size, not used for in kernel PPPoE | ||
4 | #MSS=1412 | ||
5 | |||
6 | # Device(s) - Space seperated list of devices to listen on | ||
7 | #DEVICES="eth1" | ||
8 | |||
9 | # Local IP | ||
10 | #LOCAL_IP=10.0.0.1 | ||
11 | |||
12 | # Starting remote IP | ||
13 | #REMOTE_IP=10.67.15.1 | ||
14 | |||
15 | # Service name | ||
16 | #SERVICE_NAME="acme" | ||
17 | |||
18 | # Maximum number of sessions, default is 16 | ||
19 | #MAX_SESSIONS=64 | ||
20 | |||
21 | # Access concentrator name, default is the hostname | ||
22 | #ACCESS_CONCENTRATOR_NAME="pppoe-rtr-1" | ||
diff --git a/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/pppoe-server.init b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/pppoe-server.init new file mode 100755 index 000000000..21afe0be3 --- /dev/null +++ b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/pppoe-server.init | |||
@@ -0,0 +1,59 @@ | |||
1 | #! /bin/sh | ||
2 | |||
3 | test -f /usr/sbin/pppoe-server || exit 0 | ||
4 | test -f /etc/default/pppoe-server && . /etc/default/pppoe-server | ||
5 | |||
6 | case $1 in | ||
7 | start) | ||
8 | OPTIONS="" | ||
9 | if [ -n "$MSS" ]; then | ||
10 | OPTIONS="$OPTIONS -m $MSS" | ||
11 | fi | ||
12 | if [ -n "$DEVICES" ]; then | ||
13 | for i in $DEVICES; do | ||
14 | OPTIONS="$OPTIONS -I $i" | ||
15 | done | ||
16 | fi | ||
17 | if [ -n "$LOCAL_IP" ]; then | ||
18 | OPTIONS="$OPTIONS -L $LOCAL_IP" | ||
19 | fi | ||
20 | if [ -n "$REMOTE_IP" ]; then | ||
21 | OPTIONS="$OPTIONS -R $REMOTE_IP" | ||
22 | fi | ||
23 | if [ -n "$SERVICE_NAME" ]; then | ||
24 | OPTIONS="$OPTIONS -S $SERVICE_NAME" | ||
25 | fi | ||
26 | if [ -n "$MAX_SESSIONS" ]; then | ||
27 | OPTIONS="$OPTIONS -N $MAX_SESSIONS" | ||
28 | fi | ||
29 | if [ -n "$ACCESS_CONCENTRATOR_NAME" ]; then | ||
30 | OPTIONS="$OPTIONS -C $ACCESS_CONCENTRATOR_NAME" | ||
31 | fi | ||
32 | echo -n "Starting PPPoE server: pppoe-server" | ||
33 | start-stop-daemon --start --quiet --exec /usr/sbin/pppoe-server -- $OPTIONS | ||
34 | echo "." | ||
35 | ;; | ||
36 | stop) | ||
37 | echo -n "Stopping PPPoE server: pppoe-server" | ||
38 | start-stop-daemon --stop --quiet --exec /usr/sbin/pppoe-server -- $OPTIONS | ||
39 | echo "." | ||
40 | ;; | ||
41 | status) | ||
42 | pid=$(pidof pppoe-server) | ||
43 | if [ -n "$pid" ] ; then | ||
44 | echo "Running with pid $pid" | ||
45 | else | ||
46 | echo "Not running" | ||
47 | fi | ||
48 | ;; | ||
49 | restart|force-reload) | ||
50 | $0 stop | ||
51 | $0 start | ||
52 | ;; | ||
53 | *) | ||
54 | echo "Usage: /etc/init.d/pppoe-server {start|stop|restart|force-reload}" | ||
55 | exit 1 | ||
56 | ;; | ||
57 | esac | ||
58 | |||
59 | exit 0 | ||
diff --git a/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/pppoe-src-restrictions.patch b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/pppoe-src-restrictions.patch new file mode 100644 index 000000000..bcf4d1164 --- /dev/null +++ b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/pppoe-src-restrictions.patch | |||
@@ -0,0 +1,20 @@ | |||
1 | Relax restrictions on the PPPoE src address, as per debian bug | ||
2 | 293811: | ||
3 | |||
4 | http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=293811 | ||
5 | |||
6 | Upstream-Status: Inappropriate [Backport from Debian] | ||
7 | |||
8 | --- rp-pppoe-3.8.orig/src/discovery.c | ||
9 | +++ rp-pppoe-3.8/src/discovery.c | ||
10 | @@ -376,8 +376,8 @@ | ||
11 | if (!packetIsForMe(conn, &packet)) continue; | ||
12 | |||
13 | if (packet.code == CODE_PADO) { | ||
14 | - if (NOT_UNICAST(packet.ethHdr.h_source)) { | ||
15 | - printErr("Ignoring PADO packet from non-unicast MAC address"); | ||
16 | + if (BROADCAST(packet.ethHdr.h_source)) { | ||
17 | + printErr("Ignoring broadcast PADO packet"); | ||
18 | continue; | ||
19 | } | ||
20 | parsePacket(&packet, parsePADOTags, &pc); | ||
diff --git a/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/top-autoconf.patch b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/top-autoconf.patch new file mode 100644 index 000000000..4fe73d017 --- /dev/null +++ b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/top-autoconf.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | The autoconf stuff is all in a subdirectory, which is rather annoying | ||
2 | as OE expects patches to be applied and autoconf stuff to be done in | ||
3 | S. This adds enough autoconf at the top level to allow it to be | ||
4 | called there - all it does is run a sub autoconf stuff in the src | ||
5 | directory. | ||
6 | |||
7 | Upstream-Status: Inappropriate [build system specific change] | ||
8 | |||
9 | Index: rp-pppoe-3.8/Makefile.am | ||
10 | =================================================================== | ||
11 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | ||
12 | +++ rp-pppoe-3.8/Makefile.am 2007-06-08 15:58:16.000000000 +1000 | ||
13 | @@ -0,0 +1,5 @@ | ||
14 | +PACKAGE = rp-pppoe | ||
15 | +VERSION = 3.8 | ||
16 | + | ||
17 | +dnl AM_CFLAGS = -Wall -DDEBUG | ||
18 | +SUBDIRS = src | ||
19 | Index: rp-pppoe-3.8/configure.in | ||
20 | =================================================================== | ||
21 | --- /dev/null 1970-01-01 00:00:00.000000000 +0000 | ||
22 | +++ rp-pppoe-3.8/configure.in 2007-06-08 15:58:16.000000000 +1000 | ||
23 | @@ -0,0 +1,4 @@ | ||
24 | +AC_INIT(src/pppoe.c) | ||
25 | +AM_INIT_AUTOMAKE([rp-pppoe], [3.8]) | ||
26 | +AC_CONFIG_SUBDIRS(src) | ||
27 | +AC_OUTPUT(Makefile) | ||
diff --git a/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/update-config.patch b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/update-config.patch new file mode 100644 index 000000000..42a3bc62c --- /dev/null +++ b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/update-config.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | Set the timeout to 0 since we don't want pppoe to try reconnecting, | ||
2 | we want whatever is calling it to reconnect. Lots of odd things | ||
3 | happen when you have pppoe retrying itself. | ||
4 | |||
5 | The path for the plugin is wrong, it's now part of ppp and is in a | ||
6 | ppp's plugin lib directory. If no path is specified then that's where | ||
7 | ppp looks, so that's what we do here. | ||
8 | |||
9 | Upstream-Status: Inappropriate [configuration] | ||
10 | |||
11 | Index: rp-pppoe-3.8/configs/pppoe.conf | ||
12 | =================================================================== | ||
13 | --- rp-pppoe-3.8.orig/configs/pppoe.conf 2006-04-03 00:29:41.000000000 +1000 | ||
14 | +++ rp-pppoe-3.8/configs/pppoe.conf 2007-06-08 16:02:47.000000000 +1000 | ||
15 | @@ -66,7 +66,7 @@ | ||
16 | # to connect forever after pppoe-start is called. Otherwise, it will | ||
17 | # give out after CONNECT_TIMEOUT seconds and will not attempt to | ||
18 | # connect again, making it impossible to reach. | ||
19 | -CONNECT_TIMEOUT=30 | ||
20 | +CONNECT_TIMEOUT=0 | ||
21 | |||
22 | # How often in seconds pppoe-start polls to check if link is up | ||
23 | CONNECT_POLL=2 | ||
24 | @@ -115,7 +115,7 @@ | ||
25 | FIREWALL=NONE | ||
26 | |||
27 | # Linux kernel-mode plugin for pppd. If you want to try the kernel-mode | ||
28 | -# plugin, use LINUX_PLUGIN=/etc/ppp/plugins/rp-pppoe.so | ||
29 | +# plugin, use LINUX_PLUGIN=rp-pppoe.so | ||
30 | LINUX_PLUGIN= | ||
31 | |||
32 | # Any extra arguments to pass to pppoe. Normally, use a blank string | ||
diff --git a/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/use-ldflags.patch b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/use-ldflags.patch new file mode 100644 index 000000000..95f629298 --- /dev/null +++ b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe-3.8/use-ldflags.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | Make the Makefile obey LDFLAGS. | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | |||
5 | --- a/src/Makefile.in 2006-04-02 18:29:42.000000000 +0400 | ||
6 | +++ b/src/Makefile.in 2010-04-16 17:51:31.000000000 +0400 | ||
7 | @@ -67,16 +67,16 @@ all: $(TARGETS) | ||
8 | @echo "Type 'make install' as root to install the software." | ||
9 | |||
10 | pppoe-sniff: pppoe-sniff.o if.o common.o debug.o | ||
11 | - @CC@ -o pppoe-sniff pppoe-sniff.o if.o common.o debug.o | ||
12 | + @CC@ -o pppoe-sniff pppoe-sniff.o if.o common.o debug.o $(LDFLAGS) | ||
13 | |||
14 | pppoe-server: pppoe-server.o if.o debug.o common.o md5.o libevent/libevent.a @PPPOE_SERVER_DEPS@ | ||
15 | - @CC@ -o pppoe-server @RDYNAMIC@ pppoe-server.o if.o debug.o common.o md5.o $(PPPOE_SERVER_LIBS) -Llibevent -levent | ||
16 | + @CC@ -o pppoe-server @RDYNAMIC@ pppoe-server.o if.o debug.o common.o md5.o $(PPPOE_SERVER_LIBS) -Llibevent -levent $(LDFLAGS) | ||
17 | |||
18 | pppoe: pppoe.o if.o debug.o common.o ppp.o discovery.o | ||
19 | - @CC@ -o pppoe pppoe.o if.o debug.o common.o ppp.o discovery.o | ||
20 | + @CC@ -o pppoe pppoe.o if.o debug.o common.o ppp.o discovery.o $(LDFLAGS) | ||
21 | |||
22 | pppoe-relay: relay.o if.o debug.o common.o | ||
23 | - @CC@ -o pppoe-relay relay.o if.o debug.o common.o | ||
24 | + @CC@ -o pppoe-relay relay.o if.o debug.o common.o $(LDFLAGS) | ||
25 | |||
26 | pppoe.o: pppoe.c pppoe.h | ||
27 | @CC@ $(CFLAGS) '-DVERSION="$(VERSION)"' -c -o pppoe.o pppoe.c | ||
diff --git a/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe_3.8.bb b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe_3.8.bb new file mode 100644 index 000000000..d4cc664e1 --- /dev/null +++ b/meta-networking/recipes-protocols/rp-pppoe/rp-pppoe_3.8.bb | |||
@@ -0,0 +1,64 @@ | |||
1 | SUMMARY = "A user-mode PPPoE client and server suite for Linux" | ||
2 | HOMEPAGE = "http://www.roaringpenguin.com/products/pppoe" | ||
3 | SECTION = "console/network" | ||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://doc/LICENSE;md5=a194eaefae2be54ee3221339b10d0581" | ||
6 | |||
7 | PR = "r9" | ||
8 | |||
9 | SRC_URI = "http://www.roaringpenguin.com/files/download/${P}.tar.gz \ | ||
10 | file://top-autoconf.patch \ | ||
11 | file://configure_in_cross.patch \ | ||
12 | file://pppoe-src-restrictions.patch \ | ||
13 | file://update-config.patch \ | ||
14 | file://dont-swallow-errors.patch \ | ||
15 | file://discard-use-of-dnl-in-Makefile.am.patch \ | ||
16 | file://use-ldflags.patch \ | ||
17 | file://pppoe-server.default \ | ||
18 | file://pppoe-server.init" | ||
19 | |||
20 | SRC_URI[md5sum] = "0e32760f498f9cde44081ee6aafc823b" | ||
21 | SRC_URI[sha256sum] = "d916e9cfe1e62395f63a5361936fa855f6d0f0a37dc7227b394cdb725f553479" | ||
22 | |||
23 | inherit autotools update-rc.d | ||
24 | |||
25 | do_install() { | ||
26 | # Install init script and default settings | ||
27 | install -m 0755 -d ${D}${sysconfdir}/default ${D}${sysconfdir}/init.d | ||
28 | install -m 0644 ${WORKDIR}/pppoe-server.default ${D}${sysconfdir}/default/pppoe-server | ||
29 | install -m 0755 ${WORKDIR}/pppoe-server.init ${D}${sysconfdir}/init.d/pppoe-server | ||
30 | # Install | ||
31 | oe_runmake -C ${S} RPM_INSTALL_ROOT=${D} docdir=${docdir} install | ||
32 | } | ||
33 | |||
34 | # Insert server package before main package | ||
35 | PACKAGES = "${PN}-dbg ${PN}-server ${PN}-relay ${PN}-sniff ${PN} ${PN}-doc" | ||
36 | |||
37 | FILES_${PN}-server = "${sysconfdir}/default/pppoe-server \ | ||
38 | ${sysconfdir}/init.d/pppoe-server \ | ||
39 | ${sbindir}/pppoe-server \ | ||
40 | ${sysconfdir}/ppp/pppoe-server-options" | ||
41 | FILES_${PN}-relay = "${sbindir}/pppoe-relay" | ||
42 | FILES_${PN}-sniff = "${sbindir}/pppoe-sniff" | ||
43 | |||
44 | pkg_postinst_${PN} () { | ||
45 | if [ x"$D" != "x" ]; then | ||
46 | exit 1 | ||
47 | fi | ||
48 | chmod 4755 ${sbindir}/pppoe | ||
49 | } | ||
50 | |||
51 | CONFFILES_${PN} = "${sysconfdir}/ppp/pppoe.conf \ | ||
52 | ${sysconfdir}/ppp/firewall-standalone \ | ||
53 | ${sysconfdir}/ppp/firewall-masq" | ||
54 | CONFFILES_${PN}-server = "${sysconfdir}/ppp/pppoe-server-options \ | ||
55 | ${sysconfdir}/default/pppoe-server" | ||
56 | |||
57 | INITSCRIPT_PACKAGES = "${PN}-server" | ||
58 | INITSCRIPT_NAME_${PN}-server = "pppoe-server" | ||
59 | INITSCRIPT_PARAMS_${PN}-server = "defaults 92 8" | ||
60 | |||
61 | RDEPENDS_${PN} = "ppp" | ||
62 | RDEPENDS_${PN}-server = "${PN}" | ||
63 | RRECOMMENDS_${PN} = "ppp-oe" | ||
64 | |||