summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-protocols/openflow
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-protocols/openflow')
-rw-r--r--meta-networking/recipes-protocols/openflow/openflow.inc2
-rw-r--r--meta-networking/recipes-protocols/openflow/openflow/0001-Makefile.am-Specify-export-dynamic-directly-to-linke.patch30
-rw-r--r--meta-networking/recipes-protocols/openflow/openflow_git.bb3
3 files changed, 33 insertions, 2 deletions
diff --git a/meta-networking/recipes-protocols/openflow/openflow.inc b/meta-networking/recipes-protocols/openflow/openflow.inc
index 7062d2146..7b404f540 100644
--- a/meta-networking/recipes-protocols/openflow/openflow.inc
+++ b/meta-networking/recipes-protocols/openflow/openflow.inc
@@ -11,7 +11,7 @@ LICENSE = "GPL-2.0-only"
11 11
12LIC_FILES_CHKSUM = "file://COPYING;md5=e870c934e2c3d6ccf085fd7cf0a1e2e2" 12LIC_FILES_CHKSUM = "file://COPYING;md5=e870c934e2c3d6ccf085fd7cf0a1e2e2"
13 13
14SRC_URI = "git://gitosis.stanford.edu/openflow.git;protocol=git;branch=master" 14SRC_URI = "git://github.com/mininet/openflow;protocol=https;branch=master"
15 15
16CVE_STATUS[CVE-2015-1611] = "not-applicable-config: Not referred to our implementation of openflow" 16CVE_STATUS[CVE-2015-1611] = "not-applicable-config: Not referred to our implementation of openflow"
17CVE_STATUS[CVE-2015-1612] = "not-applicable-config: Not referred to our implementation of openflow" 17CVE_STATUS[CVE-2015-1612] = "not-applicable-config: Not referred to our implementation of openflow"
diff --git a/meta-networking/recipes-protocols/openflow/openflow/0001-Makefile.am-Specify-export-dynamic-directly-to-linke.patch b/meta-networking/recipes-protocols/openflow/openflow/0001-Makefile.am-Specify-export-dynamic-directly-to-linke.patch
new file mode 100644
index 000000000..27fc05f09
--- /dev/null
+++ b/meta-networking/recipes-protocols/openflow/openflow/0001-Makefile.am-Specify-export-dynamic-directly-to-linke.patch
@@ -0,0 +1,30 @@
1From 12bba388719c425d9b5cd970d4fabf01edf56aa4 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 7 Feb 2024 22:33:12 -0800
4Subject: [PATCH] Makefile.am: Specify export-dynamic directly to linker
5
6Fixes build with clang-18+
7| riscv64-yoe-linux-clang: error: unknown argument: '-export-dynamic'
8
9Upstream-Status: Pending
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 Makefile.am | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/Makefile.am b/Makefile.am
16index 97ac1f0..e557fe7 100644
17--- a/Makefile.am
18+++ b/Makefile.am
19@@ -23,7 +23,7 @@ if NDEBUG
20 AM_CPPFLAGS += -DNDEBUG
21 AM_CFLAGS += -fomit-frame-pointer
22 else
23-AM_LDFLAGS = -export-dynamic
24+AM_LDFLAGS = -Wl,--export-dynamic
25 endif
26
27 CLEANFILES =
28--
292.43.0
30
diff --git a/meta-networking/recipes-protocols/openflow/openflow_git.bb b/meta-networking/recipes-protocols/openflow/openflow_git.bb
index f39888e8f..c86c811cc 100644
--- a/meta-networking/recipes-protocols/openflow/openflow_git.bb
+++ b/meta-networking/recipes-protocols/openflow/openflow_git.bb
@@ -1,10 +1,11 @@
1include ${BPN}.inc 1include ${BPN}.inc
2 2
3SRCREV = "c84f33f09d5dbcfc9b489f64cb30475bf36f653a" 3SRCREV = "82ad07d997b0b2ee70e1b2c7e82fcc6d0ccf23ea"
4PV = "1.0+git" 4PV = "1.0+git"
5 5
6SRC_URI += "file://0001-Check-and-use-strlcpy-from-libc-before-defining-own.patch \ 6SRC_URI += "file://0001-Check-and-use-strlcpy-from-libc-before-defining-own.patch \
7 file://0002-lib-netdev-Adjust-header-include-sequence.patch \ 7 file://0002-lib-netdev-Adjust-header-include-sequence.patch \
8 file://0001-generate-not-static-get_dh-functions.patch \ 8 file://0001-generate-not-static-get_dh-functions.patch \
9 file://0001-socket-util-Include-sys-stat.h-for-fchmod.patch \ 9 file://0001-socket-util-Include-sys-stat.h-for-fchmod.patch \
10 file://0001-Makefile.am-Specify-export-dynamic-directly-to-linke.patch \
10 " 11 "