summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-protocols/mdns/mdns_1310.140.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-protocols/mdns/mdns_1310.140.1.bb')
-rw-r--r--meta-networking/recipes-protocols/mdns/mdns_1310.140.1.bb44
1 files changed, 28 insertions, 16 deletions
diff --git a/meta-networking/recipes-protocols/mdns/mdns_1310.140.1.bb b/meta-networking/recipes-protocols/mdns/mdns_1310.140.1.bb
index 205dc929b..65f4847d8 100644
--- a/meta-networking/recipes-protocols/mdns/mdns_1310.140.1.bb
+++ b/meta-networking/recipes-protocols/mdns/mdns_1310.140.1.bb
@@ -2,28 +2,31 @@ SUMMARY = "Publishes & browses available services on a link according to the Zer
2DESCRIPTION = "Bonjour, also known as zero-configuration networking, enables automatic discovery of computers, devices, and services on IP networks." 2DESCRIPTION = "Bonjour, also known as zero-configuration networking, enables automatic discovery of computers, devices, and services on IP networks."
3HOMEPAGE = "http://developer.apple.com/networking/bonjour/" 3HOMEPAGE = "http://developer.apple.com/networking/bonjour/"
4LICENSE = "Apache-2.0 & BSD-3-Clause" 4LICENSE = "Apache-2.0 & BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://../LICENSE;md5=31c50371921e0fb731003bbc665f29bf" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=31c50371921e0fb731003bbc665f29bf"
6 6
7DEPENDS:append:libc-musl = " musl-nscd" 7DEPENDS:append:libc-musl = " musl-nscd"
8 8
9RPROVIDES:${PN} += "libdns_sd.so" 9RPROVIDES:${PN} += "libdns_sd.so"
10 10
11SRC_URI = "https://opensource.apple.com/tarballs/mDNSResponder/mDNSResponder-${PV}.tar.gz \ 11# matches annotated tag mDNSResponder-1310.140.1
12SRCREV = "1d1de95b98fba2077d34c9d78b839a96aa0e1c77"
13BRANCH = "rel/mDNSResponder-1310"
14SRC_URI = "git://github.com/apple-oss-distributions/mDNSResponder;protocol=https;branch=${BRANCH} \
12 file://mdns.service \ 15 file://mdns.service \
13 file://0001-mdns-include-stddef.h-for-NULL.patch;patchdir=.. \ 16 file://0001-mdns-include-stddef.h-for-NULL.patch \
14 file://0002-mdns-cross-compilation-fixes-for-bitbake.patch;patchdir=.. \ 17 file://0002-mdns-cross-compilation-fixes-for-bitbake.patch \
15 file://0001-Create-subroutine-for-cleaning-recent-interfaces.patch;patchdir=.. \ 18 file://0001-Create-subroutine-for-cleaning-recent-interfaces.patch \
16 file://0002-Create-subroutine-for-tearing-down-an-interface.patch;patchdir=.. \ 19 file://0002-Create-subroutine-for-tearing-down-an-interface.patch \
17 file://0003-Track-interface-socket-family.patch;patchdir=.. \ 20 file://0003-Track-interface-socket-family.patch \
18 file://0004-Use-list-for-changed-interfaces.patch;patchdir=.. \ 21 file://0004-Use-list-for-changed-interfaces.patch \
19 file://0006-Remove-unneeded-function.patch;patchdir=.. \ 22 file://0006-Remove-unneeded-function.patch \
20 file://0008-Mark-deleted-interfaces-as-being-changed.patch;patchdir=.. \ 23 file://0008-Mark-deleted-interfaces-as-being-changed.patch \
21 file://0009-Fix-possible-NULL-dereference.patch;patchdir=.. \ 24 file://0009-Fix-possible-NULL-dereference.patch \
22 file://0010-Handle-errors-from-socket-calls.patch;patchdir=.. \ 25 file://0010-Handle-errors-from-socket-calls.patch \
23 file://0011-Change-a-dynamic-allocation-to-file-scope-variable.patch;patchdir=.. \ 26 file://0011-Change-a-dynamic-allocation-to-file-scope-variable.patch \
24 file://0001-dns-sd-Include-missing-headers.patch;patchdir=.. \ 27 file://0001-dns-sd-Include-missing-headers.patch \
28 file://0006-make-Add-top-level-Makefile.patch \
25 " 29 "
26SRC_URI[sha256sum] = "040f6495c18b9f0557bcf9e00cbcfc82b03405f5ba6963dc147730ca0ca90d6f"
27 30
28CVE_PRODUCT = "apple:mdnsresponder" 31CVE_PRODUCT = "apple:mdnsresponder"
29 32
@@ -42,13 +45,22 @@ CVE_CHECK_IGNORE += "CVE-2007-0613"
42 45
43PARALLEL_MAKE = "" 46PARALLEL_MAKE = ""
44 47
45S = "${WORKDIR}/mDNSResponder-${PV}/mDNSPosix" 48# We install a stub Makefile in the top directory so that the various checks
49# in base.bbclass pass their tests for a Makefile, this ensures (that amongst
50# other things) the sstate checks will clean the build directory when the
51# task hashes changes.
52#
53# We can't use the approach of setting ${S} to mDNSPosix as we need
54# DEBUG_PREFIX_MAP to cover files which come from the Clients directory too.
55S = "${WORKDIR}/git"
46 56
47EXTRA_OEMAKE += "os=linux DEBUG=0 'CC=${CC}' 'LD=${CCLD} ${LDFLAGS}'" 57EXTRA_OEMAKE += "os=linux DEBUG=0 'CC=${CC}' 'LD=${CCLD} ${LDFLAGS}'"
48 58
49TARGET_CC_ARCH += "${LDFLAGS}" 59TARGET_CC_ARCH += "${LDFLAGS}"
50 60
51do_install () { 61do_install () {
62 cd mDNSPosix
63
52 install -d ${D}${sbindir} 64 install -d ${D}${sbindir}
53 install -m 0755 build/prod/mdnsd ${D}${sbindir} 65 install -m 0755 build/prod/mdnsd ${D}${sbindir}
54 66