summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-kernel')
-rw-r--r--meta-networking/recipes-kernel/netmap/netmap-modules_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb b/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb
index e9eea56cd..82b9b059d 100644
--- a/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb
+++ b/meta-networking/recipes-kernel/netmap/netmap-modules_git.bb
@@ -33,8 +33,8 @@ NETMAP_DRIVERS ??= ""
33NETMAP_ALL_DRIVERS = "ixgbe igb e1000e e1000 veth.c forcedeth.c virtio_net.c r8169.c" 33NETMAP_ALL_DRIVERS = "ixgbe igb e1000e e1000 veth.c forcedeth.c virtio_net.c r8169.c"
34 34
35python __anonymous () { 35python __anonymous () {
36 drivers_list = d.getVar("NETMAP_DRIVERS", True).split() 36 drivers_list = d.getVar("NETMAP_DRIVERS").split()
37 all_drivers_list = d.getVar("NETMAP_ALL_DRIVERS", True).split() 37 all_drivers_list = d.getVar("NETMAP_ALL_DRIVERS").split()
38 config_drivers = "--drivers=" + ",".join(drivers_list) 38 config_drivers = "--drivers=" + ",".join(drivers_list)
39 39
40 extra_oeconf_drivers = bb.utils.contains_any('NETMAP_DRIVERS', all_drivers_list, config_drivers, '--no-drivers', d) 40 extra_oeconf_drivers = bb.utils.contains_any('NETMAP_DRIVERS', all_drivers_list, config_drivers, '--no-drivers', d)
@@ -70,7 +70,7 @@ do_configure_append () {
70#define NETMAP_LINUX_HAVE_E1000E_DOWN2 70#define NETMAP_LINUX_HAVE_E1000E_DOWN2
71EOF 71EOF
72 72
73if ${@ 'false' if (bb.utils.vercmp_string(d.getVar('KERNEL_VERSION', True) or "0", '3.17') < 0) else 'true' } ; then 73if ${@ 'false' if (bb.utils.vercmp_string(d.getVar('KERNEL_VERSION') or "0", '3.17') < 0) else 'true' } ; then
74 echo OK 74 echo OK
75 cat >> ${S}/LINUX/netmap_linux_config.h <<EOF 75 cat >> ${S}/LINUX/netmap_linux_config.h <<EOF
76#define NETMAP_LINUX_ALLOC_NETDEV_4ARGS 76#define NETMAP_LINUX_ALLOC_NETDEV_4ARGS