summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-kernel')
-rw-r--r--meta-networking/recipes-kernel/wireguard/wireguard-module_0.0.20170421.bb13
-rw-r--r--meta-networking/recipes-kernel/wireguard/wireguard-tools_0.0.20170421.bb27
-rw-r--r--meta-networking/recipes-kernel/wireguard/wireguard.inc18
3 files changed, 58 insertions, 0 deletions
diff --git a/meta-networking/recipes-kernel/wireguard/wireguard-module_0.0.20170421.bb b/meta-networking/recipes-kernel/wireguard/wireguard-module_0.0.20170421.bb
new file mode 100644
index 000000000..cb21bda93
--- /dev/null
+++ b/meta-networking/recipes-kernel/wireguard/wireguard-module_0.0.20170421.bb
@@ -0,0 +1,13 @@
1require wireguard.inc
2
3inherit module
4
5# This module requires Linux 3.10 higher and several networking related
6# configuration options. For exact kernel requirements visit:
7# https://www.wireguard.io/install/#kernel-requirements
8
9EXTRA_OEMAKE += "KERNELDIR=${STAGING_KERNEL_DIR}"
10MAKE_TARGETS = "module"
11MODULES_INSTALL_TARGET = "module-install"
12
13RRECOMMENDS_${PN} = "kernel-module-xt-hashlimit"
diff --git a/meta-networking/recipes-kernel/wireguard/wireguard-tools_0.0.20170421.bb b/meta-networking/recipes-kernel/wireguard/wireguard-tools_0.0.20170421.bb
new file mode 100644
index 000000000..79d420f1a
--- /dev/null
+++ b/meta-networking/recipes-kernel/wireguard/wireguard-tools_0.0.20170421.bb
@@ -0,0 +1,27 @@
1require wireguard.inc
2
3inherit bash-completion systemd pkgconfig
4
5DEPENDS = "wireguard-module libmnl"
6
7do_compile_prepend () {
8 cd ${S}/tools
9}
10
11do_install () {
12 cd ${S}/tools
13 oe_runmake DESTDIR="${D}" PREFIX="${prefix}" SYSCONFDIR="${sysconfdir}" \
14 SYSTEMDUNITDIR="${systemd_unitdir}" \
15 WITH_SYSTEMDUNITS=${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'yes', '', d)} \
16 WITH_BASHCOMPLETION=yes \
17 WITH_WGQUICK=yes \
18 install
19}
20
21FILES_${PN} = " \
22 ${sysconfdir} \
23 ${systemd_unitdir} \
24 ${bindir} \
25"
26
27RDEPENDS_${PN} = "wireguard-module"
diff --git a/meta-networking/recipes-kernel/wireguard/wireguard.inc b/meta-networking/recipes-kernel/wireguard/wireguard.inc
new file mode 100644
index 000000000..46a9971f8
--- /dev/null
+++ b/meta-networking/recipes-kernel/wireguard/wireguard.inc
@@ -0,0 +1,18 @@
1SUMMARY = "WireGuard is an extremely simple yet fast and modern VPN"
2DESCRIPTION="WireGuard is a secure network tunnel, operating at layer 3, \
3implemented as a kernel virtual network interface for Linux, which aims to \
4replace both IPsec for most use cases, as well as popular user space and/or \
5TLS-based solutions like OpenVPN, while being more secure, more performant, \
6and easier to use."
7SECTION = "networking"
8HOMEPAGE = "https://www.wireguard.io/"
9LICENSE = "GPLv2"
10
11LIC_FILES_CHKSUM = "file://../COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
12
13SRC_URI = "https://git.zx2c4.com/WireGuard/snapshot/WireGuard-${PV}.tar.xz"
14
15SRC_URI[md5sum] = "8e559f4fd672b15c38a15eb4d88cc84d"
16SRC_URI[sha256sum] = "03c82af774224cd171d000ee4a519b5e474cc6842ac04967773cf77b26750000"
17
18S = "${WORKDIR}/WireGuard-${PV}/src/"