summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-kernel')
-rw-r--r--meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20210219.bb6
1 files changed, 1 insertions, 5 deletions
diff --git a/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20210219.bb b/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20210219.bb
index 0525b4135..01e3b74c6 100644
--- a/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20210219.bb
+++ b/meta-networking/recipes-kernel/wireguard/wireguard-module_1.0.20210219.bb
@@ -17,15 +17,11 @@ EXTRA_OEMAKE_append = " \
17 " 17 "
18 18
19MAKE_TARGETS = "module" 19MAKE_TARGETS = "module"
20MODULES_INSTALL_TARGET = "module-install"
20 21
21RRECOMMENDS_${PN} = "kernel-module-xt-hashlimit" 22RRECOMMENDS_${PN} = "kernel-module-xt-hashlimit"
22MODULE_NAME = "wireguard" 23MODULE_NAME = "wireguard"
23 24
24module_do_install() {
25 install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}
26 install -m 0644 ${MODULE_NAME}.ko \
27 ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}/${MODULE_NAME}.ko
28}
29 25
30# WireGuard has been merged into Linux kernel >= 5.6 and therefore this compatibility module is no longer required. 26# WireGuard has been merged into Linux kernel >= 5.6 and therefore this compatibility module is no longer required.
31# OE-core post dunfell has moved to use kernel 5.8 which now means we cant build this module in world builds 27# OE-core post dunfell has moved to use kernel 5.8 which now means we cant build this module in world builds