summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-irc/weechat/weechat_2.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-irc/weechat/weechat_2.9.bb')
-rw-r--r--meta-networking/recipes-irc/weechat/weechat_2.9.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-networking/recipes-irc/weechat/weechat_2.9.bb b/meta-networking/recipes-irc/weechat/weechat_2.9.bb
new file mode 100644
index 000000000..512ed0e49
--- /dev/null
+++ b/meta-networking/recipes-irc/weechat/weechat_2.9.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Full-featured IRC plugin: multi-servers, proxy support, IPv6, SASL authentication, nicklist, DCC, and many other features"
2HOMEPAE = "https://weechat.org/"
3SECTION = "net"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=c678957b0c8e964aa6c70fd77641a71e"
6
7DEPENDS = "openssl zlib icu libgcrypt gnutls curl aspell"
8
9SRC_URI = "https://weechat.org/files/src/weechat-${PV}.tar.xz \
10 file://0001-use-pkg-config-for-gcrypt-instead.patch \
11 "
12
13SRC_URI[sha256sum] = "eab406c385c3a10d0107ddc3aac6596ae8c59af99e9158c6d769e90ec9adfa0e"
14
15inherit cmake pkgconfig
16
17PACKAGECONFIG ??= " ncurses python"
18PACKAGECONFIG[ncurses] = "-DENABLE_NCURSES=ON,-DENABLE_NCURSES=OFF,ncurses"
19PACKAGECONFIG[python] = "-DENABLE_PYTHON=ON,-DENABLE_PYTHON=OFF,python3,python3"
20
21EXTRA_OECMAKE_append = " -DENABLE_PHP=OFF -DENABLE_TCL=OFF -DENABLE_LUA=OFF -DENABLE_JAVASCRIPT=OFF -DENABLE_RUBY=OFF -DENABLE_GUILE=OFF -DENABLE_PERL=OFF -DENABLE_ASPELL=ON"
22
23do_configure_prepend(){
24 # Make sure we get dependencies from recipe-sysroot
25 sed -i -e 's# /usr/bin# ${RECIPE_SYSROOT}/${bindir}/#g' ${S}/cmake/FindPerl.cmake
26 sed -i -e 's# /usr/local/bin##g' ${S}/cmake/FindPerl.cmake
27 sed -i -e 's# /usr/pkg/bin##g' ${S}/cmake/FindPerl.cmake
28}
29
30do_install_append(){
31 rm -rf ${D}/${datadir}
32}
33