summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-extended')
-rw-r--r--meta-networking/recipes-extended/corosync/corosync/corosync.conf58
-rw-r--r--meta-networking/recipes-extended/corosync/corosync_2.4.4.bb5
2 files changed, 62 insertions, 1 deletions
diff --git a/meta-networking/recipes-extended/corosync/corosync/corosync.conf b/meta-networking/recipes-extended/corosync/corosync/corosync.conf
new file mode 100644
index 000000000..6aef9de95
--- /dev/null
+++ b/meta-networking/recipes-extended/corosync/corosync/corosync.conf
@@ -0,0 +1,58 @@
1# Starting point for cluster with pacemaker/openais
2compatibility: none
3
4corosync {
5 user: root
6 group: root
7}
8
9aisexec {
10 with Pacemaker
11 user: root
12 group: root
13}
14
15service {
16 name: pacemaker
17 ver: 1
18}
19
20totem {
21 version: 2
22 secauth: off
23 threads: 0
24 interface {
25 ringnumber: 0
26 # Cluster network address
27 bindnetaddr: 192.168.10.0
28 # Should be fine in most cases, don't forget to allow
29 # packets for this address/port in netfilter if there
30 # is restrictive policy set for cluster network
31 mcastaddr: 226.94.1.1
32 mcastport: 5405
33 }
34}
35
36logging {
37 fileline: off
38 to_stderr: no
39 to_logfile: yes
40 to_syslog: yes
41 logfile: /var/log/cluster/corosync.log
42 debug: off
43 timestamp: on
44 logger_subsys {
45 subsys: AMF
46 debug: off
47 }
48}
49
50amf {
51 mode: disabled
52}
53
54quorum {
55 # Quorum for the Pacemaker Cluster Resource Manager
56 provider: corosync_votequorum
57 expected_votes: 1
58}
diff --git a/meta-networking/recipes-extended/corosync/corosync_2.4.4.bb b/meta-networking/recipes-extended/corosync/corosync_2.4.4.bb
index b760c117c..5ebec08b9 100644
--- a/meta-networking/recipes-extended/corosync/corosync_2.4.4.bb
+++ b/meta-networking/recipes-extended/corosync/corosync_2.4.4.bb
@@ -7,7 +7,9 @@ SECTION = "base"
7 7
8inherit autotools pkgconfig systemd useradd 8inherit autotools pkgconfig systemd useradd
9 9
10SRC_URI = "http://build.clusterlabs.org/corosync/releases/${BP}.tar.gz" 10SRC_URI = "http://build.clusterlabs.org/corosync/releases/${BP}.tar.gz \
11 file://corosync.conf \
12 "
11 13
12SRC_URI[md5sum] = "69db29ff4bc035936946be44fc8be5cd" 14SRC_URI[md5sum] = "69db29ff4bc035936946be44fc8be5cd"
13SRC_URI[sha256sum] = "9bd4707bb271df16f8d543ec782eb4c35ec0330b7be696b797da4bd8f058a25d" 15SRC_URI[sha256sum] = "9bd4707bb271df16f8d543ec782eb4c35ec0330b7be696b797da4bd8f058a25d"
@@ -47,6 +49,7 @@ do_configure_prepend() {
47} 49}
48 50
49do_install_append() { 51do_install_append() {
52 install -D -m 0644 ${WORKDIR}/corosync.conf ${D}/${sysconfdir}/corosync/corosync.conf.example
50 install -d ${D}${sysconfdir}/sysconfig/ 53 install -d ${D}${sysconfdir}/sysconfig/
51 install -m 0644 ${S}/init/corosync.sysconfig.example ${D}${sysconfdir}/sysconfig/corosync 54 install -m 0644 ${S}/init/corosync.sysconfig.example ${D}${sysconfdir}/sysconfig/corosync
52 install -m 0644 ${S}/tools/corosync-notifyd.sysconfig.example ${D}${sysconfdir}/sysconfig/corosync-notifyd 55 install -m 0644 ${S}/tools/corosync-notifyd.sysconfig.example ${D}${sysconfdir}/sysconfig/corosync-notifyd