summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-extended/corosync/corosync_2.4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-extended/corosync/corosync_2.4.2.bb')
-rw-r--r--meta-networking/recipes-extended/corosync/corosync_2.4.2.bb80
1 files changed, 80 insertions, 0 deletions
diff --git a/meta-networking/recipes-extended/corosync/corosync_2.4.2.bb b/meta-networking/recipes-extended/corosync/corosync_2.4.2.bb
new file mode 100644
index 000000000..33e74e2ff
--- /dev/null
+++ b/meta-networking/recipes-extended/corosync/corosync_2.4.2.bb
@@ -0,0 +1,80 @@
1SUMMARY = "The Corosync Cluster Engine and Application Programming Interfaces"
2DESCRIPTION = "This package contains the Corosync Cluster Engine Executive, several default \
3APIs and libraries, default configuration files, and an init script."
4HOMEPAGE = "http://corosync.github.io/corosync/"
5
6SECTION = "base"
7
8inherit autotools pkgconfig systemd useradd
9
10SRC_URI = "http://build.clusterlabs.org/corosync/releases/${BP}.tar.gz \
11 file://0001-Include-fcntl.h-for-F_-and-O_-defines.patch \
12 "
13SRC_URI[md5sum] = "547fa78704da53aa35912be58d31035f"
14SRC_URI[sha256sum] = "f26e3011309fe4bcce94b1dc20ea8c462f19483a73f3ca62f13b925d011a4ba9"
15
16LICENSE = "BSD"
17LIC_FILES_CHKSUM = "file://LICENSE;md5=a85eb4ce24033adb6088dd1d6ffc5e5d"
18
19DEPENDS = "groff-native nss libqb"
20
21SYSTEMD_SERVICE_${PN} = "corosync.service corosync-notifyd.service \
22 ${@bb.utils.contains('PACKAGECONFIG', 'qdevice', 'corosync-qdevice.service', '', d)} \
23 ${@bb.utils.contains('PACKAGECONFIG', 'qnetd', 'corosync-qnetd.service', '', d)} \
24"
25SYSTEMD_AUTO_ENABLE = "enable"
26
27INITSCRIPT_NAME = "corosync-daemon"
28
29PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
30 dbus qdevice qnetd snmp \
31"
32
33PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus"
34PACKAGECONFIG[qdevice] = "--enable-qdevices,--disable-qdevices"
35PACKAGECONFIG[qnetd] = "--enable-qnetd,--disable-qnetd"
36PACKAGECONFIG[rdma] = "--enable-rdma,--disable-rdma"
37PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp,net-snmp"
38PACKAGECONFIG[systemd] = "--enable-systemd --with-systemddir=${systemd_system_unitdir},--disable-systemd --without-systemddir,systemd"
39
40EXTRA_OECONF = "ac_cv_path_BASHPATH=${base_bindir}/bash"
41EXTRA_OEMAKE = "tmpfilesdir_DATA="
42
43do_configure_prepend() {
44 ( cd ${S}
45 ${S}/autogen.sh )
46}
47
48do_install_append() {
49 install -d ${D}${sysconfdir}/sysconfig/
50 install -m 0644 ${S}/init/corosync.sysconfig.example ${D}${sysconfdir}/sysconfig/corosync
51 install -m 0644 ${S}/tools/corosync-notifyd.sysconfig.example ${D}${sysconfdir}/sysconfig/corosync-notifyd
52
53 rm -rf "${D}${localstatedir}/run"
54
55 install -d ${D}${sysconfdir}/default/volatiles
56 echo "d root root 0755 ${localstatedir}/log/cluster none" > ${D}${sysconfdir}/default/volatiles/05_corosync
57
58 if ${@bb.utils.contains('PACKAGECONFIG', 'qnetd', 'true', 'false', d)}; then
59 chown -R coroqnetd:coroqnetd ${D}${sysconfdir}/${BPN}/qnetd
60 echo "d coroqnetd coroqnetd 0770 /var/run/corosync-qnetd none" >> ${D}${sysconfdir}/default/volatiles/05_corosync
61 fi
62
63 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
64 install -d ${D}${sysconfdir}/tmpfiles.d
65 echo "d ${localstatedir}/log/cluster - - - -" > ${D}${sysconfdir}/tmpfiles.d/corosync.conf
66
67 if ${@bb.utils.contains('PACKAGECONFIG', 'qnetd', 'true', 'false', d)}; then
68 install -m 0644 ${S}/conf/tmpfiles.d/corosync-qnetd.conf ${D}${sysconfdir}/tmpfiles.d
69 fi
70 fi
71}
72
73RDEPENDS_${PN} += "bash"
74
75FILES_${PN}-dbg += "${libexecdir}/lcrso/.debug"
76FILES_${PN}-doc += "${datadir}/snmp/mibs/COROSYNC-MIB.txt"
77
78USERADD_PACKAGES = "${PN}"
79GROUPADD_PARAM_${PN} = "--system coroqnetd"
80USERADD_PARAM_${PN} = "--system -d / -M -s /bin/nologin -c 'User for corosync-qnetd' -g coroqnetd coroqnetd"