diff options
Diffstat (limited to 'meta-networking/recipes-daemons')
-rw-r--r-- | meta-networking/recipes-daemons/ncftp/ncftp/unistd.patch | 32 | ||||
-rw-r--r-- | meta-networking/recipes-daemons/ncftp/ncftp_3.2.6.bb (renamed from meta-networking/recipes-daemons/ncftp/ncftp_3.2.5.bb) | 16 |
2 files changed, 44 insertions, 4 deletions
diff --git a/meta-networking/recipes-daemons/ncftp/ncftp/unistd.patch b/meta-networking/recipes-daemons/ncftp/ncftp/unistd.patch new file mode 100644 index 000000000..1c8146eda --- /dev/null +++ b/meta-networking/recipes-daemons/ncftp/ncftp/unistd.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | This patch is needed to avoid double definitions of functions | ||
2 | especially when building with security flags turned on. The double | ||
3 | definitions causes the sed.sh script in configure to fail since it | ||
4 | starts to spit out double outputs e.g. | ||
5 | |||
6 | wi_cv_gethostname_size_t size_t size_t | ||
7 | |||
8 | which then caused almost all subsequent compile time tests to fail since | ||
9 | this gets into confdefs.h file | ||
10 | |||
11 | removing this include causes only one definitions to be emitted into | ||
12 | the genrated protos.h file and thus avoiding the above failure. | ||
13 | |||
14 | Other solution would to fix sed.sh to ignore double definitions | ||
15 | |||
16 | Upstream-Status: Pending | ||
17 | |||
18 | Signed-of-by: Khem Raj <raj.khem@gmail.com> | ||
19 | |||
20 | |||
21 | Index: ncftp-3.2.6/configure | ||
22 | =================================================================== | ||
23 | --- ncftp-3.2.6.orig/configure | ||
24 | +++ ncftp-3.2.6/configure | ||
25 | @@ -7859,7 +7859,6 @@ chmod 755 "$wi_tmpdir/prpp.pl" | ||
26 | cat << 'EOF' > "$wi_tmpdir/unistd.c" | ||
27 | #include <confdefs.h> | ||
28 | |||
29 | -#include <unistd.h> | ||
30 | #include <sys/types.h> | ||
31 | #include <sys/socket.h> | ||
32 | #include <netinet/in.h> | ||
diff --git a/meta-networking/recipes-daemons/ncftp/ncftp_3.2.5.bb b/meta-networking/recipes-daemons/ncftp/ncftp_3.2.6.bb index 893eacb99..5f92f27fd 100644 --- a/meta-networking/recipes-daemons/ncftp/ncftp_3.2.5.bb +++ b/meta-networking/recipes-daemons/ncftp/ncftp_3.2.6.bb | |||
@@ -2,21 +2,29 @@ DESCRIPTION = "A sophisticated console ftp client" | |||
2 | HOMEPAGE = "http://ncftp.com/" | 2 | HOMEPAGE = "http://ncftp.com/" |
3 | SECTION = "net" | 3 | SECTION = "net" |
4 | LICENSE = "ClArtistic" | 4 | LICENSE = "ClArtistic" |
5 | LIC_FILES_CHKSUM = "file://ncftp/cmds.c;beginline=3;endline=4;md5=9de76faeaedc4f908082e3f8142715f4" | 5 | LIC_FILES_CHKSUM = "file://ncftp/cmds.c;beginline=3;endline=4;md5=9c2390809f71465aa7ff76e03dc14d91" |
6 | DEPENDS = "ncurses" | 6 | DEPENDS = "ncurses" |
7 | 7 | ||
8 | SRC_URI = "${DEBIAN_MIRROR}/main/n/${BPN}/${BPN}_${PV}.orig.tar.gz \ | 8 | SRC_URI = "ftp://ftp.ncftp.com/${BPN}/${BP}-src.tar.xz \ |
9 | file://ncftp-configure-use-BUILD_CC-for-ccdv.patch \ | 9 | file://ncftp-configure-use-BUILD_CC-for-ccdv.patch \ |
10 | file://unistd.patch \ | ||
10 | " | 11 | " |
11 | SRC_URI[md5sum] = "685e45f60ac11c89442c572c28af4228" | 12 | SRC_URI[md5sum] = "42d0f896d69a4d603ec097546444245f" |
12 | SRC_URI[sha256sum] = "ac111b71112382853b2835c42ebe7bd59acb7f85dd00d44b2c19fbd074a436c4" | 13 | SRC_URI[sha256sum] = "5f200687c05d0807690d9fb770327b226f02dd86155b49e750853fce4e31098d" |
13 | 14 | ||
14 | inherit autotools-brokensep pkgconfig | 15 | inherit autotools-brokensep pkgconfig |
15 | 16 | ||
17 | CFLAGS += "-DNO_SSLv2 -D_FILE_OFFSET_BITS=64 -Wall" | ||
18 | |||
16 | PACKAGECONFIG ??= "" | 19 | PACKAGECONFIG ??= "" |
17 | PACKAGECONFIG[ccdv] = "--enable-ccdv,--disable-ccdv,," | 20 | PACKAGECONFIG[ccdv] = "--enable-ccdv,--disable-ccdv,," |
18 | 21 | ||
22 | EXTRA_OECONF = "--disable-precomp" | ||
23 | TARGET_CC_ARCH_append = " ${SELECTED_OPTIMIZATION}" | ||
24 | |||
19 | do_configure() { | 25 | do_configure() { |
26 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S} | ||
27 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S} | ||
20 | oe_runconf | 28 | oe_runconf |
21 | } | 29 | } |
22 | do_install () { | 30 | do_install () { |