summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/vsftpd/vsftpd_2.3.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-daemons/vsftpd/vsftpd_2.3.5.bb')
-rw-r--r--meta-networking/recipes-daemons/vsftpd/vsftpd_2.3.5.bb51
1 files changed, 0 insertions, 51 deletions
diff --git a/meta-networking/recipes-daemons/vsftpd/vsftpd_2.3.5.bb b/meta-networking/recipes-daemons/vsftpd/vsftpd_2.3.5.bb
deleted file mode 100644
index f14691034..000000000
--- a/meta-networking/recipes-daemons/vsftpd/vsftpd_2.3.5.bb
+++ /dev/null
@@ -1,51 +0,0 @@
1SUMMARY = "Very Secure FTP server"
2HOMEPAGE = "https://security.appspot.com/vsftpd.html"
3SECTION = "network"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=a6067ad950b28336613aed9dd47b1271"
6
7DEPENDS = "libcap openssl"
8
9SRC_URI = "https://security.appspot.com/downloads/vsftpd-${PV}.tar.gz \
10 file://makefile-destdir.patch \
11 file://makefile-libs.patch \
12 file://makefile-strip.patch \
13 file://nopam.patch \
14 file://init \
15 file://vsftpd.conf"
16
17SRC_URI[md5sum] = "01398a5bef8e85b6cf2c213a4b011eca"
18SRC_URI[sha256sum] = "d87ee2987df8f03e1dbe294905f7907b2798deb89c67ca965f6e2f60879e54f1"
19
20inherit update-rc.d useradd
21
22CONFFILES_${PN} = "${sysconfdir}/vsftpd.conf"
23LDFLAGS_append =" -lcrypt -lcap"
24
25do_configure() {
26 # Fix hardcoded /usr, /etc, /var mess.
27 cat tunables.c|sed s:\"/usr:\"${prefix}:g|sed s:\"/var:\"${localstatedir}:g \
28 |sed s:\"${prefix}/share/empty:\"${localstatedir}/share/empty:g |sed s:\"/etc:\"${sysconfdir}:g > tunables.c.new
29 mv tunables.c.new tunables.c
30}
31
32do_install() {
33 install -d ${D}${sbindir}
34 install -d ${D}${mandir}/man8
35 install -d ${D}${mandir}/man5
36 oe_runmake 'DESTDIR=${D}' install
37 install -d ${D}${sysconfdir}
38 install -m 0755 ${WORKDIR}/vsftpd.conf ${D}${sysconfdir}/vsftpd.conf
39 install -d ${D}${sysconfdir}/init.d/
40 install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/vsftpd
41}
42
43INITSCRIPT_PACKAGES = "${PN}"
44INITSCRIPT_NAME_${PN} = "vsftpd"
45INITSCRIPT_PARAMS_${PN} = "defaults 80"
46
47USERADD_PACKAGES = "${PN}"
48USERADD_PARAM_${PN} = "--system --home-dir /var/lib/ftp --no-create-home -g ftp \
49 --shell /bin/false ftp "
50GROUPADD_PARAM_${PN} = "-r ftp"
51