summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/vblade
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-daemons/vblade')
-rw-r--r--meta-networking/recipes-daemons/vblade/files/cross.patch16
-rw-r--r--meta-networking/recipes-daemons/vblade/vblade_20.bb20
2 files changed, 36 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/vblade/files/cross.patch b/meta-networking/recipes-daemons/vblade/files/cross.patch
new file mode 100644
index 000000000..d2eb15614
--- /dev/null
+++ b/meta-networking/recipes-daemons/vblade/files/cross.patch
@@ -0,0 +1,16 @@
1Remove CC and CFLAGS values, we set these ourselves
2
3Upstream-Status: Inappropriate [config]
4
5diff -urN vblade-19.old//makefile vblade-19//makefile
6--- vblade-19.old//makefile 2008-10-08 22:07:40.000000000 +0100
7+++ vblade-19//makefile 2008-11-18 19:07:51.700365029 +0000
8@@ -9,8 +9,6 @@
9 mandir = ${sharedir}/man
10
11 O=aoe.o bpf.o ${PLATFORM}.o ata.o
12-CFLAGS += -Wall -g -O2
13-CC = gcc
14
15 vblade: $O
16 ${CC} -o vblade $O
diff --git a/meta-networking/recipes-daemons/vblade/vblade_20.bb b/meta-networking/recipes-daemons/vblade/vblade_20.bb
new file mode 100644
index 000000000..a2ebb5a48
--- /dev/null
+++ b/meta-networking/recipes-daemons/vblade/vblade_20.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Virtual EtherDrive blade AoE target"
2SECTION = "console/network"
3
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/aoetools/${BPN}-${PV}.tgz \
8 file://cross.patch"
9
10SRC_URI[md5sum] = "3c80e4a6bc7d66ae0c235b88cb44bd59"
11SRC_URI[sha256sum] = "c8fe2fc4f2fba8e07e5cfdf17335982584eef2cd5c78bf8b1db93f2b56e7121d"
12
13inherit autotools-brokensep
14
15do_install() {
16 install -D -m 0755 ${S}/vblade ${D}/${sbindir}/vblade
17 install -D -m 0755 ${S}/vbladed ${D}/${sbindir}/vbladed
18 install -D -m 0644 ${S}/vblade.8 ${D}/${mandir}/man8/vblade.8
19}
20