summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/pure-ftpd
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-daemons/pure-ftpd')
-rw-r--r--meta-networking/recipes-daemons/pure-ftpd/pure-ftpd/0001-Remove-hardcoded-usr-local-includes-from-configure.a.patch38
-rw-r--r--meta-networking/recipes-daemons/pure-ftpd/pure-ftpd/nostrip.patch30
-rw-r--r--meta-networking/recipes-daemons/pure-ftpd/pure-ftpd_1.0.36.bb19
3 files changed, 87 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/pure-ftpd/pure-ftpd/0001-Remove-hardcoded-usr-local-includes-from-configure.a.patch b/meta-networking/recipes-daemons/pure-ftpd/pure-ftpd/0001-Remove-hardcoded-usr-local-includes-from-configure.a.patch
new file mode 100644
index 000000000..54088b044
--- /dev/null
+++ b/meta-networking/recipes-daemons/pure-ftpd/pure-ftpd/0001-Remove-hardcoded-usr-local-includes-from-configure.a.patch
@@ -0,0 +1,38 @@
1From cffca7cb7c055f82ced316ddee90bb701b85b92d Mon Sep 17 00:00:00 2001
2From: Yauhen Kharuzhy <yauhen.kharuzhy@promwad.com>
3Date: Tue, 10 Jan 2012 19:15:25 +0300
4Subject: [PATCH] Remove hardcoded /usr/local includes from configure.ac
5
6Upstream-Status: Inappropriate [config]
7
8Signed-off-by: Yauhen Kharuzhy <yauhen.kharuzhy@promwad.com>
9---
10 configure.ac | 12 ------------
11 1 files changed, 0 insertions(+), 12 deletions(-)
12
13diff --git a/configure.ac b/configure.ac
14index ae00c08..9ba6d8d 100644
15--- a/configure.ac
16+++ b/configure.ac
17@@ -67,18 +67,6 @@ AC_ARG_VAR(PYTHON,local path to the python interpreter)
18 python_possible_path="/usr/bin:/usr/local/bin:/bin:/opt/python/bin:/opt/python/usr/bin:/opt/python/usr/local/bin"
19 AC_PATH_PROG(PYTHON,python,/usr/bin/env python,$python_possible_path)
20
21-if test -d /usr/local/include; then
22- CPPFLAGS="$CPPFLAGS -I/usr/local/include"
23-fi
24-
25-if test -d /usr/kerberos/include; then
26- CPPFLAGS="$CPPFLAGS -I/usr/kerberos/include"
27-fi
28-
29-if test -d /usr/local/lib; then
30- LDFLAGS="$LDFLAGS -L/usr/local/lib"
31-fi
32-
33 if uname | fgrep SunOS > /dev/null 2> /dev/null ; then
34 CPPFLAGS="$CPPFLAGS -D_XPG4_2=1"
35 fi
36--
371.7.7.3
38
diff --git a/meta-networking/recipes-daemons/pure-ftpd/pure-ftpd/nostrip.patch b/meta-networking/recipes-daemons/pure-ftpd/pure-ftpd/nostrip.patch
new file mode 100644
index 000000000..5cbbc5fa7
--- /dev/null
+++ b/meta-networking/recipes-daemons/pure-ftpd/pure-ftpd/nostrip.patch
@@ -0,0 +1,30 @@
1From 45eb89d1a6fde65caaf2d6e1a5d527f1ae7beb9c Mon Sep 17 00:00:00 2001
2From: Paul Eggleton <paul.eggleton@linux.intel.com>
3Date: Mon, 3 Dec 2012 17:12:11 +0000
4Subject: [PATCH] Don't mess with CFLAGS and LDFLAGS when --with-minimal is specified
5
6We especially don't want stripping enabled.
7
8Upstream-Status: Inappropriate [config]
9
10Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
11---
12 configure.ac | 2 --
13 1 files changed, 0 insertions(+), 2 deletions(-)
14
15diff --git a/configure.ac b/configure.ac
16index 3d59409..6836c0e 100644
17--- a/configure.ac
18+++ b/configure.ac
19@@ -413,8 +413,6 @@ AC_ARG_WITH(minimal,
20 AC_DEFINE(NO_FTP_USERS)
21 AC_DEFINE(WITHOUT_ASCII)
22 AC_DEFINE(BORING_MODE)
23- CFLAGS="$CFLAGS -Os -fomit-frame-pointer -fgcse -falign-functions=2 -falign-jumps=2 -fno-unroll-loops "
24- LDFLAGS="$LDFLAGS -s "
25 fi ])
26
27 AC_ARG_WITH(paranoidmsg,
28--
291.7.1
30
diff --git a/meta-networking/recipes-daemons/pure-ftpd/pure-ftpd_1.0.36.bb b/meta-networking/recipes-daemons/pure-ftpd/pure-ftpd_1.0.36.bb
new file mode 100644
index 000000000..974e6b74b
--- /dev/null
+++ b/meta-networking/recipes-daemons/pure-ftpd/pure-ftpd_1.0.36.bb
@@ -0,0 +1,19 @@
1SUMMARY = "FTP Server with a strong focus on software security"
2DESCRIPTION = "Pure-FTPd is a free (BSD license), secure, production-quality and standard-conformant FTP server."
3HOMEPAGE = "http://www.pureftpd.org/project/pure-ftpd"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=ae9e161311a5a0768c333b537a40e332"
6
7DEPENDS = "libcap"
8
9
10SRC_URI = "http://download.pureftpd.org/pub/pure-ftpd/releases/pure-ftpd-${PV}.tar.gz \
11 file://0001-Remove-hardcoded-usr-local-includes-from-configure.a.patch \
12 file://nostrip.patch \
13"
14SRC_URI[md5sum] = "bbcb48e8aa6ec1abff9775b89f84af91"
15SRC_URI[sha256sum] = "90fb63b1a9d448076aa9f3e3c74b298965f98e03c824e9a4d241fffe8eb3a130"
16
17inherit autotools
18
19EXTRA_OECONF = "--with-minimal"