summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/opensaf/opensaf_5.19.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-daemons/opensaf/opensaf_5.19.07.bb')
-rw-r--r--meta-networking/recipes-daemons/opensaf/opensaf_5.19.07.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf_5.19.07.bb b/meta-networking/recipes-daemons/opensaf/opensaf_5.19.07.bb
index 3df6824ff..efa2bf5eb 100644
--- a/meta-networking/recipes-daemons/opensaf/opensaf_5.19.07.bb
+++ b/meta-networking/recipes-daemons/opensaf/opensaf_5.19.07.bb
@@ -25,6 +25,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/releases/${BPN}-${PV}.tar.gz \
25 file://0001-src-Add-missing-header-limits.h-for-_POSIX_HOST_NAME.patch \ 25 file://0001-src-Add-missing-header-limits.h-for-_POSIX_HOST_NAME.patch \
26 file://0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch \ 26 file://0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch \
27 file://0001-Add-configure-time-check-for-gettid-API.patch \ 27 file://0001-Add-configure-time-check-for-gettid-API.patch \
28 file://0001-create_empty_library-Use-CC-variable-intead-of-hardc.patch \
28 " 29 "
29SRC_URI[md5sum] = "e9ae9de803a99b7ab33757a49858542f" 30SRC_URI[md5sum] = "e9ae9de803a99b7ab33757a49858542f"
30SRC_URI[sha256sum] = "caed672d03ab1fe3f27d333429c7ca03022714e7c6350500208b7bd7349f03ce" 31SRC_URI[sha256sum] = "caed672d03ab1fe3f27d333429c7ca03022714e7c6350500208b7bd7349f03ce"
@@ -44,13 +45,11 @@ PACKAGECONFIG[plm] = "--enable-ais-plm,--disable-ais-plm,libvirt openhpi"
44 45
45PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}" 46PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}"
46 47
47PKGLIBDIR="${libdir}"
48CPPFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation" 48CPPFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation"
49CXXFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation -Wno-error=format-truncation=" 49CXXFLAGS += "-Wno-error=stringop-overflow= -Wno-error=stringop-truncation -Wno-error=format-truncation="
50LDFLAGS += "-Wl,--as-needed -latomic -Wl,--no-as-needed" 50LDFLAGS += "-Wl,--as-needed -latomic -Wl,--no-as-needed"
51 51
52do_install_append() { 52do_install_append() {
53 cp -av --no-preserve=ownership ${B}/lib/.libs/*.so* ${D}${libdir}
54 rm -fr "${D}${localstatedir}/lock" 53 rm -fr "${D}${localstatedir}/lock"
55 rm -fr "${D}${localstatedir}/run" 54 rm -fr "${D}${localstatedir}/run"
56 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}" 55 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
@@ -61,7 +60,8 @@ do_install_append() {
61 fi 60 fi
62} 61}
63 62
64FILES_${PN} += "${systemd_unitdir}/system/*.service" 63FILES_${PN} += "${libdir}/libSa*.so ${systemd_unitdir}/system/*.service"
64FILES_${PN}-dev += "${libdir}/libopensaf_core.so"
65FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a" 65FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a"
66 66
67INSANE_SKIP_${PN} = "dev-so" 67INSANE_SKIP_${PN} = "dev-so"
@@ -70,3 +70,5 @@ RDEPENDS_${PN} += "bash python"
70 70
71# http://errors.yoctoproject.org/Errors/Details/186970/ 71# http://errors.yoctoproject.org/Errors/Details/186970/
72COMPATIBLE_HOST_libc-musl = 'null' 72COMPATIBLE_HOST_libc-musl = 'null'
73
74FILES_SOLIBSDEV = ""