summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/opensaf/opensaf_5.17.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-daemons/opensaf/opensaf_5.17.07.bb')
-rw-r--r--meta-networking/recipes-daemons/opensaf/opensaf_5.17.07.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/opensaf/opensaf_5.17.07.bb b/meta-networking/recipes-daemons/opensaf/opensaf_5.17.07.bb
new file mode 100644
index 000000000..74483d778
--- /dev/null
+++ b/meta-networking/recipes-daemons/opensaf/opensaf_5.17.07.bb
@@ -0,0 +1,67 @@
1SUMMARY = "OpenSAF is an open source implementation of the SAF AIS specification"
2DESCRIPTION = "OpenSAF is an open source project established to develop a base platform \
3middleware consistent with Service Availability Forum (SA Forum) \
4specifications, under the LGPLv2.1 license. The OpenSAF Foundation was \
5established by leading Communications and Enterprise Computing Companies to \
6facilitate the OpenSAF Project and to accelerate the adoption of the OpenSAF \
7code base in commercial products. \
8The OpenSAF project was launched in mid 2007 and has been under development by \
9an informal group of supporters of the OpenSAF initiative. The OpenSAF \
10Foundation was founded on January 22nd 2008 with Emerson Network Power, \
11Ericsson, Nokia Siemens Networks, HP and Sun Microsystems as founding members."
12HOMEPAGE = "http://www.opensaf.org"
13SECTION = "admin"
14LICENSE = "LGPLv2.1"
15LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7"
16
17DEPENDS = "libxml2 python"
18TOOLCHAIN = "gcc"
19
20SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"
21
22SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/releases/${BPN}-${PV}.tar.gz \
23 file://0001-configure-Pass-linker-specific-options-with-Wl.patch \
24 file://0001-configure-Disable-format-overflow-if-supported-by-gc.patch \
25 file://0001-src-Add-missing-header-limits.h-for-_POSIX_HOST_NAME.patch \
26 file://0001-immpbe_dump.cc-Use-sys-wait.h-instead-of-wait.h.patch \
27"
28SRC_URI[md5sum] = "125bcd9aabd7412aedcbfbf73f4e6196"
29SRC_URI[sha256sum] = "3fb2239bb2c9328c8b45368ff8d8de979ea286a27edc9871d218200e88bb91cc"
30
31inherit autotools useradd systemd pkgconfig
32
33USERADD_PACKAGES = "${PN}"
34GROUPADD_PARAM_${PN} = "-f -r opensaf"
35USERADD_PARAM_${PN} = "-r -g opensaf -d ${datadir}/opensaf/ -s ${sbindir}/nologin -c \"OpenSAF\" opensaf"
36
37SYSTEMD_SERVICE_${PN} += "opensafd.service"
38SYSTEMD_AUTO_ENABLE = "disable"
39
40PACKAGECONFIG[systemd] = ",,systemd"
41PACKAGECONFIG[openhpi] = "--with-hpi-interface=B03 --enable-ais-plm,,openhpi"
42
43PACKAGECONFIG_append = "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', ' systemd', '', d)}"
44
45PKGLIBDIR="${libdir}"
46
47LDFLAGS += "-Wl,--as-needed -latomic -Wl,--no-as-needed"
48
49do_install_append() {
50 cp -av --no-preserve=ownership ${B}/lib/.libs/*.so* ${D}${libdir}
51 rm -fr "${D}${localstatedir}/lock"
52 rm -fr "${D}${localstatedir}/run"
53 rmdir --ignore-fail-on-non-empty "${D}${localstatedir}"
54 rmdir --ignore-fail-on-non-empty "${D}${datadir}/java"
55 if [ ! -d "${D}${sysconfdir}/init.d" ]; then
56 install -d ${D}${sysconfdir}/init.d
57 install -m 0755 ${B}/osaf/services/infrastructure/nid/scripts/opensafd ${D}${sysconfdir}/init.d/
58 fi
59}
60
61FILES_${PN} += "${systemd_unitdir}/system/*.service"
62FILES_${PN}-staticdev += "${PKGLIBDIR}/*.a"
63
64INSANE_SKIP_${PN} = "dev-so"
65
66RDEPENDS_${PN} += "bash python"
67