summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb')
-rw-r--r--meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
new file mode 100644
index 000000000..44336f059
--- /dev/null
+++ b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
@@ -0,0 +1,42 @@
1DESCRIPTION = "Generic client/server library for SASL authentication."
2SECTION = "console/network"
3DEPENDS = "openssl virtual/db"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=3f55e0974e3d6db00ca6f57f2d206396"
6
7SRC_URI = "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-${PV}.tar.gz "
8
9inherit autotools pkgconfig
10
11EXTRA_OECONF += "--with-dblib=berkeley \
12 --with-bdb-libdir=${STAGING_LIBDIR} \
13 --with-bdb-incdir=${STAGING_INCDIR} \
14 --without-pam --without-opie --without-des"
15
16do_configure_prepend () {
17 rm -f acinclude.m4 config/libtool.m4
18}
19
20do_compile_prepend () {
21 cd include
22 ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} makemd5.c -o makemd5
23 touch makemd5.o makemd5.lo makemd5
24 cd ..
25}
26
27pkg_postinst_${PN}-bin () {
28 grep cyrus /etc/passwd || adduser --disabled-password --home=/var/spool/mail --ingroup mail -g "Cyrus sasl" cyrus
29 echo "cyrus" | saslpasswd2 -p -c cyrus
30 chgrp mail /etc/sasldb2
31}
32
33SRC_URI[md5sum] = "a7f4e5e559a0e37b3ffc438c9456e425"
34SRC_URI[sha256sum] = "8fbc5136512b59bb793657f36fadda6359cae3b08f01fd16b3d406f1345b7bc3"
35
36PACKAGES =+ "${PN}-bin"
37
38FILES_${PN} += "${libdir}/sasl2/*.so.*"
39FILES_${PN}-bin += "${bindir}"
40FILES_${PN}-dev += "${libdir}/sasl2/*.so ${libdir}/sasl2/*.la"
41FILES_${PN}-dbg += "${libdir}/sasl2/.debug"
42FILES_${PN}-staticdev += "${libdir}/sasl2/*.a"