summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/autofs
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-daemons/autofs')
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs-5.1.0/0001-systemd-allow-with-systemd-to-take-a-path-arg.patch47
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs-5.1.0/Makefile.rules-cross.patch23
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs-5.1.0/add-the-needed-stdarg.h.patch24
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs-5.1.0/autofs-5.0.7-do-not-check-for-modprobe.patch75
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs-5.1.0/autofs-5.0.7-fix-lib-deps.patch28
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs-5.1.0/autofs-5.0.7-include-linux-nfs.h-directly-in-rpc_sub.patch32
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs-5.1.0/autofs-additional-distros.patch12
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs-5.1.0/cross.patch44
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs-5.1.0/fix_disable_ldap.patch42
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs-5.1.0/force-STRIP-to-emtpy.patch25
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs-5.1.0/libtirpc-name-clash-backout.patch28
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs-5.1.0/libtirpc.patch26
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs-5.1.0/no-bash.patch20
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs-5.1.0/remove-bashism.patch120
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs-5.1.0/using-pkg-config-to-detect-libxml-2.0-and-krb5.patch39
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs_5.1.0.bb71
16 files changed, 656 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.1.0/0001-systemd-allow-with-systemd-to-take-a-path-arg.patch b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/0001-systemd-allow-with-systemd-to-take-a-path-arg.patch
new file mode 100644
index 000000000..742f25de1
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/0001-systemd-allow-with-systemd-to-take-a-path-arg.patch
@@ -0,0 +1,47 @@
1From 40971911d653bf53de295d7462c643e4073916b9 Mon Sep 17 00:00:00 2001
2From: Joe MacDonald <joe@deserted.net>
3Date: Fri, 1 Nov 2013 12:47:18 -0400
4Subject: [PATCH] systemd: allow --with-systemd to take a path arg
5
6If building for a cross-compile environment with systemd it is convenient
7to be able to specify a systemd path for the target that may not be the
8same as that on the host.
9
10Upstream-status: Submitted [http://www.spinics.net/lists/autofs/msg00740.html]
11
12Signed-off-by: Joe MacDonald <joe@deserted.net>
13---
14 aclocal.m4 | 10 ++++++++--
15 1 file changed, 8 insertions(+), 2 deletions(-)
16
17diff --git a/aclocal.m4 b/aclocal.m4
18index 3e6f223..105e3e9 100644
19--- a/aclocal.m4
20+++ b/aclocal.m4
21@@ -229,8 +229,10 @@ dnl Check the location of the systemd unit files directory
22 dnl --------------------------------------------------------------------------
23 AC_DEFUN([AF_WITH_SYSTEMD],
24 [AC_ARG_WITH(systemd,
25-[ --with-systemd install systemd unit file if systemd unit directory
26- is found on system],
27+[ --with-systemd@<:@=systemddir@:>@ install systemd unit file. If 'yes'
28+ probe the system for unit directory.
29+ If a path is specified, assume that
30+ is a valid install path.],
31 [if test "$withval" = yes; then
32 if test -z "$systemddir"; then
33 AC_MSG_CHECKING([location of the systemd unit files directory])
34@@ -247,6 +249,10 @@ AC_DEFUN([AF_WITH_SYSTEMD],
35 else
36 AC_MSG_RESULT(not found)
37 fi
38+else
39+ if test "$withval" != no; then
40+ systemddir=$withval
41+ fi
42 fi])
43 ])
44
45--
461.7.10.4
47
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.1.0/Makefile.rules-cross.patch b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/Makefile.rules-cross.patch
new file mode 100644
index 000000000..7dc7096c2
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/Makefile.rules-cross.patch
@@ -0,0 +1,23 @@
1Index: autofs-5.0.7/Makefile.rules
2===================================================================
3--- autofs-5.0.7.orig/Makefile.rules 2012-07-24 23:05:26.000000000 -0700
4+++ autofs-5.0.7/Makefile.rules 2012-10-26 09:23:40.270204270 -0700
5@@ -34,14 +34,14 @@
6 else
7 CFLAGS ?= -O2 -Wall
8 LDFLAGS = -s
9-STRIP = strip --strip-debug
10+STRIP = ${TARGET_PREFIX}strip --strip-debug
11 endif
12 endif
13
14-CC = gcc
15-CXX = g++
16+CC ?= ${TARGET_PREFIX}gcc
17+CXX ?= ${TARGET_PREFIX}g++
18 CXXFLAGS = $(CFLAGS)
19-LD = ld
20+LD ?= ${TARGET_PREFIX}ld
21 SOLDFLAGS = -shared
22
23 CFLAGS += -D_REENTRANT -D_FILE_OFFSET_BITS=64
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.1.0/add-the-needed-stdarg.h.patch b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/add-the-needed-stdarg.h.patch
new file mode 100644
index 000000000..fdb906b22
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/add-the-needed-stdarg.h.patch
@@ -0,0 +1,24 @@
1[PATCH] add the needed stdarg.h
2
3Upstream-status: Pending
4
5Signed-off-by: Roy Li <rongqing.li@windriver.com>
6---
7 lib/defaults.c | 1 +
8 1 file changed, 1 insertion(+)
9
10diff --git a/lib/defaults.c b/lib/defaults.c
11index 2b03ea2..5728e67 100644
12--- a/lib/defaults.c
13+++ b/lib/defaults.c
14@@ -16,6 +16,7 @@
15
16 #include <stdlib.h>
17 #include <stdio.h>
18+#include <stdarg.h>
19 #include <ctype.h>
20 #include <string.h>
21 #include <sys/utsname.h>
22--
231.7.10.4
24
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.1.0/autofs-5.0.7-do-not-check-for-modprobe.patch b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/autofs-5.0.7-do-not-check-for-modprobe.patch
new file mode 100644
index 000000000..af5be6a83
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/autofs-5.0.7-do-not-check-for-modprobe.patch
@@ -0,0 +1,75 @@
1Description: Loading autofs module is #ifdef'ed in the source, so
2 there is no need to check for /proc (which is only used
3 to load module) or modprobe. Both modprobe and /proc
4 are always in the fixed location so there's no need to
5 check for these to start with.
6
7Upstream-Status: Backport [1]
8[1] http://www.spinics.net/lists/autofs/msg00139.html
9
10diff -urpN a/configure.in b/configure.in
11--- a/configure.in 2013-01-15 11:30:22.000000000 +0800
12+++ b/configure.in 2013-01-15 11:31:45.000000000 +0800
13@@ -34,11 +34,6 @@ AC_MSG_CHECKING([for binaries in])
14 AC_MSG_RESULT([$searchpath])
15
16 #
17-# Make sure we have "/proc"
18-#
19-AF_LINUX_PROCFS()
20-
21-#
22 # Location of init.d directory?
23 #
24 AF_INIT_D()
25@@ -142,7 +137,6 @@ AF_PATH_INCLUDE(UMOUNT, umount, /bin/umo
26 AF_PATH_INCLUDE(E2FSCK, fsck.ext2 e2fsck, , $searchpath)
27 AF_PATH_INCLUDE(E3FSCK, fsck.ext3 e3fsck, , $searchpath)
28 AF_PATH_INCLUDE(E4FSCK, fsck.ext4 e4fsck, , $searchpath)
29-AF_PATH_INCLUDE(MODPROBE, modprobe, , $searchpath)
30
31 AF_CHECK_PROG(LEX, flex lex, , $searchpath)
32 AF_CHECK_PROG(YACC, bison, , $searchpath)
33diff -urpN a/daemon/module.c b/daemon/module.c
34--- a/daemon/module.c 2013-01-15 11:30:49.000000000 +0800
35+++ b/daemon/module.c 2013-01-15 11:32:00.000000000 +0800
36@@ -18,6 +18,8 @@
37 #include <stdlib.h>
38 #include "automount.h"
39
40+#if 0
41+/* see comment in daemon/automount.c around load_autofs4_module() call */
42 int load_autofs4_module(void)
43 {
44 FILE *fp;
45@@ -52,6 +54,7 @@ int load_autofs4_module(void)
46
47 return 1;
48 }
49+#endif
50
51 struct lookup_mod *open_lookup(const char *name, const char *err_prefix,
52 const char *mapfmt, int argc, const char *const *argv)
53diff -urpN a/include/automount.h b/include/automount.h
54--- a/include/automount.h 2013-01-15 11:31:10.000000000 +0800
55+++ b/include/automount.h 2013-01-15 11:32:06.000000000 +0800
56@@ -50,16 +50,11 @@
57 #error Failed to locate umount(8)!
58 #endif
59
60-#ifndef HAVE_MODPROBE
61-#error Failed to locate modprobe(8)!
62-#endif
63-
64-#ifndef HAVE_LINUX_PROCFS
65-#error Failed to verify existence of procfs filesystem!
66-#endif
67-
68+#if 0
69+/* see comment in daemon/automount.c around load_autofs4_module() call */
70 #define FS_MODULE_NAME "autofs4"
71 int load_autofs4_module(void);
72+#endif
73
74 /* The -s (sloppy) option to mount is good, if we have it... */
75
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.1.0/autofs-5.0.7-fix-lib-deps.patch b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/autofs-5.0.7-fix-lib-deps.patch
new file mode 100644
index 000000000..09fea495d
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/autofs-5.0.7-fix-lib-deps.patch
@@ -0,0 +1,28 @@
1From 54a9bd28a307dd74df044d779ca85adcf36aa202 Mon Sep 17 00:00:00 2001
2From: Joe MacDonald <joe.macdonald@windriver.com>
3Date: Tue, 18 Jun 2013 10:05:21 -0400
4Subject: [PATCH] Fix the dependency issue
5
6Upstream-Status: Pending
7
8autofs's lib sources have a dependency on a number of files that are
9generated by rpcgen during buildtime
10
11Signed-off-by: Roy.Li <rongqing.li@windriver.com>
12Signed-off-by: Joe MacDonald <joe.macdonald@windriver.com>
13---
14 lib/Makefile | 1 +
15 1 file changed, 1 insertion(+)
16
17diff --git a/lib/Makefile b/lib/Makefile
18index 5418009..bff4e1d 100644
19--- a/lib/Makefile
20+++ b/lib/Makefile
21@@ -75,3 +75,4 @@ install: all
22 clean:
23 rm -f $(LIB) $(RPCS) $(OBJS) $(YACCSRC) *.output *~
24
25+$(OBJS): $(RPCS)
26--
271.7.10.4
28
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.1.0/autofs-5.0.7-include-linux-nfs.h-directly-in-rpc_sub.patch b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/autofs-5.0.7-include-linux-nfs.h-directly-in-rpc_sub.patch
new file mode 100644
index 000000000..3a878980a
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/autofs-5.0.7-include-linux-nfs.h-directly-in-rpc_sub.patch
@@ -0,0 +1,32 @@
1Upstream-Status: Pending
2
3From 44bdce8c6ed9b30c1643e5981172a4f9025f013c Mon Sep 17 00:00:00 2001
4From: Andreas Oberritter <obi@opendreambox.org>
5Date: Wed, 13 Mar 2013 16:17:08 +0100
6Subject: [PATCH] autofs-5.0.7: include linux/nfs.h directly in rpc_subs.h
7
8Fixes compile error with uclibc. Glibc's nfs/nfs.h contains
9nothing but "#include linux/nfs.h". rpc_subs.h already includes
10other linux/nfs*.h files directly.
11
12Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
13---
14 include/rpc_subs.h | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/include/rpc_subs.h b/include/rpc_subs.h
18index b6d59f9..a2d9648 100644
19--- a/include/rpc_subs.h
20+++ b/include/rpc_subs.h
21@@ -18,7 +18,7 @@
22
23 #include <rpc/rpc.h>
24 #include <rpc/pmap_prot.h>
25-#include <nfs/nfs.h>
26+#include <linux/nfs.h>
27 #include <linux/nfs2.h>
28 #include <linux/nfs3.h>
29
30--
311.7.10.4
32
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.1.0/autofs-additional-distros.patch b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/autofs-additional-distros.patch
new file mode 100644
index 000000000..6a35843ce
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/autofs-additional-distros.patch
@@ -0,0 +1,12 @@
1--- autofs-4.1.4/samples/rc.autofs.in~ 2005-04-11 06:30:54.000000000 -0500
2+++ autofs-4.1.4/samples/rc.autofs.in 2007-04-07 13:18:44.000000000 -0500
3@@ -43,6 +43,9 @@
4 system=debian
5 elif [ -f /etc/redhat-release ]; then
6 system=redhat
7+elif [ -f /etc/issue ] && grep -q "^SlugOS\|Yocto" /etc/issue ; then
8+ # SlugOS and Yocto behave like Debian, at least for autofs purposes.
9+ system=debian
10 else
11 echo "$0: Unknown system, please port and contact autofs@linux.kernel.org" 1>&2
12 exit 1
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.1.0/cross.patch b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/cross.patch
new file mode 100644
index 000000000..8f1af625f
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/cross.patch
@@ -0,0 +1,44 @@
1Index: autofs-5.0.7/aclocal.m4
2===================================================================
3--- autofs-5.0.7.orig/aclocal.m4 2012-10-28 04:45:07.000000000 -0700
4+++ autofs-5.0.7/aclocal.m4 2012-10-28 10:47:53.263996910 -0700
5@@ -7,6 +7,8 @@
6 AC_DEFUN(AF_PATH_INCLUDE,
7 [AC_PATH_PROGS($1,$2,$3,$4)
8 if test -n "$$1"; then
9+ AH_TEMPLATE([HAVE_$1], [Have $2])
10+ AH_TEMPLATE([PATH_$1], [Have $2])
11 AC_DEFINE(HAVE_$1,1,[define if you have $1])
12 AC_DEFINE_UNQUOTED(PATH_$1, "$$1", [define if you have $1])
13 HAVE_$1=1
14Index: autofs-5.0.7/configure.in
15===================================================================
16--- autofs-5.0.7.orig/configure.in 2012-10-28 04:45:06.000000000 -0700
17+++ autofs-5.0.7/configure.in 2012-10-28 10:50:07.580000628 -0700
18@@ -301,13 +301,15 @@
19 cat > pietest.c <<EOF
20 int main(void) { return 0; }
21 EOF
22+AF_tmp_ldflags="$LDFLAGS"
23+AF_tmp_cflags="$CFLAGS"
24 CFLAGS=-fPIE
25 LDFLAGS=-pie
26 DAEMON_CFLAGS=
27 DAEMON_LDFLAGS=
28 AC_MSG_CHECKING([whether gcc -fPIE works])
29-AC_RUN_IFELSE([AC_LANG_PROGRAM([[]], [[int main(void) {return 0;}]])],
30- [gcc_supports_pie=yes], [gcc_supports_pie=no], [gcc_supports_pie=no])
31+AC_LINK_IFELSE([AC_LANG_PROGRAM([[]], [[int main(void) {return 0;}]])],
32+ [gcc_supports_pie=yes], [gcc_supports_pie=no], [gcc_supports_pie=no])
33 AC_MSG_RESULT([$gcc_supports_pie])
34 if test $gcc_supports_pie = yes ; then
35 DAEMON_CFLAGS="-fPIE"
36@@ -316,6 +318,8 @@
37 rm -f pietest.c
38 AC_SUBST(DAEMON_CFLAGS)
39 AC_SUBST(DAEMON_LDFLAGS)
40+CFLAGS="${AF_tmp_cflags}"
41+LDFLAGS="${AF_tmp_ldflags}"
42
43 #
44 # Enable ability to access value in external env variable
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.1.0/fix_disable_ldap.patch b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/fix_disable_ldap.patch
new file mode 100644
index 000000000..31c8510a6
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/fix_disable_ldap.patch
@@ -0,0 +1,42 @@
1autofs: fails to compile with openldap disabled
2
3As of 5.0.6, it appears that changes were introduced so that
4if you compile with openldap disabled and openldap headers are not
5available, then autofs fails to build.
6
7Upstream-Status: Pending
8
9Signed-off-by: Amy Fong <amy.fong@windriver.com>
10--
11 lookup_ldap.h | 4 ++++
12 1 file changed, 4 insertions(+)
13
14---
15 include/lookup_ldap.h | 4 ++++
16 1 file changed, 4 insertions(+)
17
18--- a/include/lookup_ldap.h
19+++ b/include/lookup_ldap.h
20@@ -1,7 +1,9 @@
21 #ifndef LOOKUP_LDAP_H
22 #define LOOKUP_LDAP_H
23
24+#ifdef WITH_LDAP
25 #include <ldap.h>
26+#endif
27
28 #ifdef WITH_SASL
29 #include <openssl/ssl.h>
30@@ -109,10 +111,12 @@
31
32 #define LDAP_AUTH_USESIMPLE 0x0008
33
34+#ifdef WITH_LDAP
35 /* lookup_ldap.c */
36 LDAP *init_ldap_connection(unsigned logopt, const char *uri, struct lookup_context *ctxt);
37 int unbind_ldap_connection(unsigned logopt, LDAP *ldap, struct lookup_context *ctxt);
38 int authtype_requires_creds(const char *authtype);
39+#endif
40
41 #ifdef WITH_SASL
42 /* cyrus-sasl.c */
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.1.0/force-STRIP-to-emtpy.patch b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/force-STRIP-to-emtpy.patch
new file mode 100644
index 000000000..634005bd2
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/force-STRIP-to-emtpy.patch
@@ -0,0 +1,25 @@
1[PATCH] force STRIP to emtpy
2
3otherwise the generate file will be stripped
4
5Signed-off-by: Roy Li <rongqing.li@windriver.com>
6---
7 Makefile.rules | 2 +-
8 1 file changed, 1 insertion(+), 1 deletion(-)
9
10diff --git a/Makefile.rules b/Makefile.rules
11index 710a2c9..e4334db 100644
12--- a/Makefile.rules
13+++ b/Makefile.rules
14@@ -31,7 +31,7 @@ LDFLAGS ?= -s
15 endif
16
17 ifdef DONTSTRIP
18-STRIP ?= :
19+STRIP = :
20 else
21 STRIP ?= strip --strip-debug
22 endif
23--
241.7.10.4
25
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.1.0/libtirpc-name-clash-backout.patch b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/libtirpc-name-clash-backout.patch
new file mode 100644
index 000000000..e93021d56
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/libtirpc-name-clash-backout.patch
@@ -0,0 +1,28 @@
1---
2 lib/rpc_subs.c | 10 ----------
3 1 file changed, 10 deletions(-)
4
5diff --git a/lib/rpc_subs.c b/lib/rpc_subs.c
6index 5d6ead0..c7177f2 100644
7--- a/lib/rpc_subs.c
8+++ b/lib/rpc_subs.c
9@@ -34,16 +34,6 @@
10 #include <poll.h>
11
12 #ifdef WITH_LIBTIRPC
13-#undef auth_destroy
14-#define auth_destroy(auth) \
15- do { \
16- int refs; \
17- if ((refs = auth_put((auth))) == 0) \
18- ((*((auth)->ah_ops->ah_destroy))(auth));\
19- } while (0)
20-#endif
21-
22-#ifdef WITH_LIBTIRPC
23 const rpcprog_t rpcb_prog = RPCBPROG;
24 const rpcvers_t rpcb_version = RPCBVERS;
25 #else
26--
271.7.10.4
28
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.1.0/libtirpc.patch b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/libtirpc.patch
new file mode 100644
index 000000000..d68944b45
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/libtirpc.patch
@@ -0,0 +1,26 @@
1Index: autofs-5.0.7/aclocal.m4
2===================================================================
3--- autofs-5.0.7.orig/aclocal.m4 2012-10-28 13:17:45.504237027 -0700
4+++ autofs-5.0.7/aclocal.m4 2012-10-28 13:20:50.108242739 -0700
5@@ -403,7 +403,7 @@
6 # save current flags
7 af_check_libtirpc_save_cflags="$CFLAGS"
8 af_check_libtirpc_save_ldflags="$LDFLAGS"
9-CFLAGS="$CFLAGS -I/usr/include/tirpc"
10+CFLAGS="$CFLAGS -I=/usr/include/tirpc"
11 LDFLAGS="$LDFLAGS -ltirpc"
12
13 AC_TRY_LINK(
14Index: autofs-5.0.7/Makefile.rules
15===================================================================
16--- autofs-5.0.7.orig/Makefile.rules 2012-10-28 13:17:45.308237022 -0700
17+++ autofs-5.0.7/Makefile.rules 2012-10-28 13:21:25.720242803 -0700
18@@ -48,7 +48,7 @@
19 LIBS += -lpthread
20
21 ifdef TIRPCLIB
22-CFLAGS += -I/usr/include/tirpc
23+CFLAGS += -I=/usr/include/tirpc
24 LIBS += $(TIRPCLIB)
25 endif
26
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.1.0/no-bash.patch b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/no-bash.patch
new file mode 100644
index 000000000..cf0363527
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/no-bash.patch
@@ -0,0 +1,20 @@
1Index: autofs-5.0.7/samples/auto.net
2===================================================================
3--- autofs-5.0.7.orig/samples/auto.net 2012-07-24 23:05:26.000000000 -0700
4+++ autofs-5.0.7/samples/auto.net 2012-10-28 10:44:25.035991715 -0700
5@@ -1,4 +1,4 @@
6-#!/bin/bash
7+#!/bin/sh
8
9 # This file must be executable to work! chmod 755!
10
11Index: autofs-5.0.7/samples/auto.smb
12===================================================================
13--- autofs-5.0.7.orig/samples/auto.smb 2012-07-24 23:05:26.000000000 -0700
14+++ autofs-5.0.7/samples/auto.smb 2012-10-28 10:44:25.035991715 -0700
15@@ -1,4 +1,4 @@
16-#!/bin/bash
17+#!/bin/sh
18
19 # This file must be executable to work! chmod 755!
20
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.1.0/remove-bashism.patch b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/remove-bashism.patch
new file mode 100644
index 000000000..282d6f0ad
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/remove-bashism.patch
@@ -0,0 +1,120 @@
1From 79034f969bbd12215d65b4337dfd38a13d02d4ef Mon Sep 17 00:00:00 2001
2From: Robert Yang <liezhi.yang@windriver.com>
3Date: Sat, 13 Sep 2014 20:19:28 -0700
4Subject: [PATCH] autofs.init.in: remove bashism
5
6It can work without the bashism.
7
8Upstream-Status: Pending
9
10Signed-off-by: Mike Looijmans <mike.looijmans@topic.nl>
11Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
12---
13 redhat/autofs.init.in | 12 ++++++------
14 samples/rc.autofs.in | 10 +++++-----
15 2 files changed, 11 insertions(+), 11 deletions(-)
16
17diff --git a/redhat/autofs.init.in b/redhat/autofs.init.in
18index 9d008ff..4f1c0d8 100644
19--- a/redhat/autofs.init.in
20+++ b/redhat/autofs.init.in
21@@ -1,4 +1,4 @@
22-#!/bin/bash
23+#!/bin/sh
24 #
25 # rc file for automount using a Sun-style "master map".
26 #
27@@ -42,7 +42,7 @@ if [ -r $confdir/autofs ]; then
28 . $confdir/autofs
29 fi
30
31-function start() {
32+start() {
33 # Make sure autofs4 module is loaded
34 if ! grep -q autofs /proc/filesystems
35 then
36@@ -102,7 +102,7 @@ function start() {
37 return $RETVAL
38 }
39
40-function stop() {
41+stop() {
42 echo -n $"Stopping $prog: "
43 count=0
44 while [ -n "`pidof $prog`" -a $count -lt 15 ] ; do
45@@ -125,7 +125,7 @@ function stop() {
46 return $RETVAL
47 }
48
49-function restart() {
50+restart() {
51 status autofs > /dev/null 2>&1
52 if [ $? -eq 0 ]; then
53 stop
54@@ -143,7 +143,7 @@ function restart() {
55 start
56 }
57
58-function reload() {
59+reload() {
60 if [ ! -f /var/lock/subsys/autofs ]; then
61 echo $"$prog not running"
62 RETVAL=1
63@@ -161,7 +161,7 @@ function reload() {
64 return $RETVAL
65 }
66
67-function usage_message() {
68+usage_message() {
69 echo $"Usage: $0 {start|forcestart|stop|status|restart|force-reload|forcerestart|reload|condrestart|try-restart|usage}"
70 }
71
72diff --git a/samples/rc.autofs.in b/samples/rc.autofs.in
73index 487669f..e96cde1 100644
74--- a/samples/rc.autofs.in
75+++ b/samples/rc.autofs.in
76@@ -1,4 +1,4 @@
77-#!/bin/bash
78+#!/bin/sh
79 #
80 # rc file for automount using a Sun-style "master map".
81 #
82@@ -36,7 +36,7 @@ if [ -r $confdir/autofs ]; then
83 . $confdir/autofs
84 fi
85
86-function start() {
87+start() {
88 echo -n "Starting $prog: "
89
90 # Make sure autofs4 module is loaded
91@@ -85,7 +85,7 @@ function start() {
92 return $RETVAL
93 }
94
95-function stop() {
96+stop() {
97 echo -n $"Stopping $prog: "
98 count=0
99 while [ -n "`pidof $prog`" -a $count -lt 15 ] ; do
100@@ -102,7 +102,7 @@ function stop() {
101 return $RETVAL
102 }
103
104-function restart() {
105+restart() {
106 stop
107 while [ -n "`pidof $prog`" ] ; do
108 sleep 5
109@@ -110,7 +110,7 @@ function restart() {
110 start
111 }
112
113-function reload() {
114+reload() {
115 pid=`pidof $prog`
116 if [ -z $pid ]; then
117 echo $"$prog not running"
118--
1191.7.9.5
120
diff --git a/meta-networking/recipes-daemons/autofs/autofs-5.1.0/using-pkg-config-to-detect-libxml-2.0-and-krb5.patch b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/using-pkg-config-to-detect-libxml-2.0-and-krb5.patch
new file mode 100644
index 000000000..93b76bd66
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs-5.1.0/using-pkg-config-to-detect-libxml-2.0-and-krb5.patch
@@ -0,0 +1,39 @@
1using pkg-config to detect libxml-2.0 and krb5
2
3Upstream-status: Pending
4
5Signed-off-by: Roy Li <rongqing.li@windriver.com>
6---
7 configure.in | 16 ++++++++++++++--
8 2 files changed, 14 insertions(+), 2 deletions(-)
9
10diff --git a/configure.in b/configure.in
11index 392d122..a3028aa 100644
12--- a/configure.in
13+++ b/configure.in
14@@ -162,8 +162,20 @@ if test x$enable_sloppy_mount = xyes; then
15 fi
16
17 # LDAP SASL auth needs libxml and Kerberos
18-AF_CHECK_LIBXML()
19-AF_CHECK_KRB5()
20+PKG_CHECK_MODULES(XML, [libxml-2.0],HAVE_LIBXML=1,HAVE_LIBXML=0)
21+AC_SUBST([HAVE_LIBXML])
22+XML_FLAGS=$XML_CFLAGS
23+
24+PKG_CHECK_MODULES(KRB5, [krb5],HAVE_KRB5=1,HAVE_KRB5=0)
25+AC_SUBST([HAVE_KRB5])
26+if test "x$HAVE_KRB5" = "x1"; then
27+ SAVE_CFLAGS=$CFLAGS
28+ SAVE_LIBS=$LIBS
29+ CFLAGS="$CFLAGS $KRB5_FLAGS"
30+ LIBS="$LIBS $KRB5_LIBS"
31+
32+ AC_CHECK_FUNCS([krb5_principal_get_realm])
33+fi
34
35 AC_SEARCH_LIBS([versionsort],[])
36 if test "$ac_cv_search_versionsort" = "no"; then
37--
381.7.10.4
39
diff --git a/meta-networking/recipes-daemons/autofs/autofs_5.1.0.bb b/meta-networking/recipes-daemons/autofs/autofs_5.1.0.bb
new file mode 100644
index 000000000..13af2fe45
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs_5.1.0.bb
@@ -0,0 +1,71 @@
1SUMMARY = "Kernel based automounter for linux"
2SECTION = "base"
3LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
5
6DEPENDS += "libtirpc flex-native bison-native"
7
8inherit autotools-brokensep systemd
9
10SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.gz \
11 file://autofs-5.0.7-include-linux-nfs.h-directly-in-rpc_sub.patch \
12 file://no-bash.patch \
13 file://cross.patch \
14 file://libtirpc.patch \
15 file://libtirpc-name-clash-backout.patch \
16 file://autofs-5.0.7-do-not-check-for-modprobe.patch \
17 file://fix_disable_ldap.patch \
18 file://autofs-5.0.7-fix-lib-deps.patch \
19 file://add-the-needed-stdarg.h.patch \
20 file://using-pkg-config-to-detect-libxml-2.0-and-krb5.patch \
21 file://force-STRIP-to-emtpy.patch \
22 file://remove-bashism.patch \
23"
24
25SRC_URI[md5sum] = "b7724a9a55923f3c06933a8dfd1e79d3"
26SRC_URI[sha256sum] = "794a28d178d2b21a2380ee71cbdb3b15b4be47c06f3de255b8c5c4351f046b26"
27
28inherit update-rc.d pkgconfig
29
30INITSCRIPT_NAME = "autofs"
31INITSCRIPT_PARAMS = "defaults"
32
33# FIXME: modules/Makefile has crappy rules that don't obey LDFLAGS
34CFLAGS += "${LDFLAGS}"
35
36PACKAGECONFIG[systemd] = "--with-systemd=${systemd_unitdir}/system,--without-systemd,systemd"
37
38PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
39
40EXTRA_OEMAKE = "DONTSTRIP=1"
41EXTRA_OECONF += "--disable-mount-locking \
42 --enable-ignore-busy --with-openldap=no \
43 --with-sasl=no --with-libtirpc=yes \
44 --with-path=${STAGING_BINDIR_NATIVE} \
45"
46CACHED_CONFIGUREVARS = "ac_cv_path_RANLIB=${RANLIB} \
47 ac_cv_path_RPCGEN=rpcgen \
48"
49
50do_configure_prepend () {
51 sed -e "s:filagdir:flagdir:" -i configure.in
52 if [ ! -e acinclude.m4 ]; then
53 cp aclocal.m4 acinclude.m4
54 fi
55}
56
57do_install_append () {
58 if [ -d ${D}/run ]; then
59 rmdir ${D}/run
60 fi
61 if [ -d ${D}${localstatedir}/run ]; then
62 rmdir ${D}${localstatedir}/run
63 fi
64}
65
66INSANE_SKIP_${PN} = "dev-so"
67
68RPROVIDES_${PN} += "${PN}-systemd"
69RREPLACES_${PN} += "${PN}-systemd"
70RCONFLICTS_${PN} += "${PN}-systemd"
71SYSTEMD_SERVICE_${PN} = "autofs.service"