summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/autofs/autofs_5.1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-daemons/autofs/autofs_5.1.2.bb')
-rw-r--r--meta-networking/recipes-daemons/autofs/autofs_5.1.2.bb76
1 files changed, 76 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/autofs/autofs_5.1.2.bb b/meta-networking/recipes-daemons/autofs/autofs_5.1.2.bb
new file mode 100644
index 000000000..eea7c4b83
--- /dev/null
+++ b/meta-networking/recipes-daemons/autofs/autofs_5.1.2.bb
@@ -0,0 +1,76 @@
1SUMMARY = "Kernel based automounter for linux"
2SECTION = "utils"
3LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
5
6DEPENDS += "libtirpc flex-native bison-native e2fsprogs openssl libxml2 util-linux cyrus-sasl"
7
8CFLAGS += "-I${STAGING_INCDIR}/tirpc"
9
10inherit autotools-brokensep systemd update-rc.d pkgconfig
11
12SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.gz \
13 file://autofs-5.0.7-include-linux-nfs.h-directly-in-rpc_sub.patch \
14 file://no-bash.patch \
15 file://cross.patch \
16 file://libtirpc.patch \
17 file://autofs-5.0.7-do-not-check-for-modprobe.patch \
18 file://fix_disable_ldap.patch \
19 file://autofs-5.0.7-fix-lib-deps.patch \
20 file://add-the-needed-stdarg.h.patch \
21 file://using-pkg-config-to-detect-libxml-2.0-and-krb5.patch \
22 file://force-STRIP-to-emtpy.patch \
23 file://remove-bashism.patch \
24 file://fix-the-YACC-rule-to-fix-a-building-failure.patch \
25 file://0001-Define-__SWORD_TYPE-and-_PATH_NSSWITCH_CONF.patch \
26 file://0002-Replace-__S_IEXEC-with-S_IEXEC.patch \
27 file://autofs-5.1.2-libtirpc-as-need.patch \
28 file://pkgconfig-libnsl.patch \
29 "
30SRC_URI[md5sum] = "28cf88f99eff553a8500659ba5d45a76"
31SRC_URI[sha256sum] = "0d57e4138c2ec8058ca92164d035546f68ce4af93acb893369993d67c7056a10"
32
33INITSCRIPT_NAME = "autofs"
34INITSCRIPT_PARAMS = "defaults"
35
36# FIXME: modules/Makefile has crappy rules that don't obey LDFLAGS
37#CFLAGS += "${LDFLAGS}"
38
39PACKAGECONFIG[systemd] = "--with-systemd=${systemd_unitdir}/system,--without-systemd,systemd"
40
41PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
42
43EXTRA_OEMAKE = "DONTSTRIP=1"
44EXTRA_OECONF += "--disable-mount-locking \
45 --enable-ignore-busy --with-openldap=no \
46 --with-sasl=no --with-libtirpc \
47 --with-path=${STAGING_BINDIR_NATIVE} \
48"
49CACHED_CONFIGUREVARS = "ac_cv_path_RANLIB=${RANLIB} \
50 ac_cv_path_RPCGEN=rpcgen \
51"
52
53do_configure_prepend () {
54 sed -e "s:filagdir:flagdir:" -i ${S}/configure.in
55 if [ ! -e ${S}/acinclude.m4 ]; then
56 cp ${S}/aclocal.m4 ${S}/acinclude.m4
57 fi
58}
59
60do_install_append () {
61 if [ -d ${D}/run ]; then
62 rmdir ${D}/run
63 fi
64 if [ -d ${D}${localstatedir}/run ]; then
65 rmdir ${D}${localstatedir}/run
66 fi
67}
68SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"
69
70INSANE_SKIP_${PN} = "dev-so"
71
72RPROVIDES_${PN} += "${PN}-systemd"
73RREPLACES_${PN} += "${PN}-systemd"
74RCONFLICTS_${PN} += "${PN}-systemd"
75SYSTEMD_SERVICE_${PN} = "autofs.service"
76