summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity')
-rw-r--r--meta-networking/recipes-connectivity/samba/samba-4.4.2/10-use-only-libsystemd.patch81
-rw-r--r--meta-networking/recipes-connectivity/samba/samba_4.4.2.bb1
2 files changed, 82 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba-4.4.2/10-use-only-libsystemd.patch b/meta-networking/recipes-connectivity/samba/samba-4.4.2/10-use-only-libsystemd.patch
new file mode 100644
index 000000000..81621ff2a
--- /dev/null
+++ b/meta-networking/recipes-connectivity/samba/samba-4.4.2/10-use-only-libsystemd.patch
@@ -0,0 +1,81 @@
1diff -ur samba-4.4.2/lib/util/become_daemon.c samba-4.4.2/lib/util/become_daemon.c
2--- samba-4.4.2/lib/util/become_daemon.c 2016-05-08 18:33:24.000000000 +0200
3+++ samba-4.4.2/lib/util/become_daemon.c 2016-05-08 18:26:50.275177918 +0200
4@@ -24,7 +24,7 @@
5 #include "includes.h"
6 #include "system/filesys.h"
7 #include "system/locale.h"
8-#if HAVE_LIBSYSTEMD_DAEMON
9+#if HAVE_LIBSYSTEMD
10 #include <systemd/sd-daemon.h>
11 #endif
12 #include "lib/util/close_low_fd.h"
13@@ -69,9 +69,9 @@
14 if (do_fork) {
15 newpid = fork();
16 if (newpid) {
17-#if HAVE_LIBSYSTEMD_DAEMON
18+#if HAVE_LIBSYSTEMD
19 sd_notifyf(0, "READY=0\nSTATUS=Starting process...\nMAINPID=%lu", (unsigned long) newpid);
20-#endif /* HAVE_LIBSYSTEMD_DAEMON */
21+#endif /* HAVE_LIBSYSTEMD */
22 _exit(0);
23 }
24 }
25@@ -98,7 +98,7 @@
26
27 _PUBLIC_ void exit_daemon(const char *msg, int error)
28 {
29-#ifdef HAVE_LIBSYSTEMD_DAEMON
30+#ifdef HAVE_LIBSYSTEMD
31 if (msg == NULL) {
32 msg = strerror(error);
33 }
34@@ -117,7 +117,7 @@
35 if (name == NULL) {
36 name = "Samba";
37 }
38-#ifdef HAVE_LIBSYSTEMD_DAEMON
39+#ifdef HAVE_LIBSYSTEMD
40 sd_notifyf(0, "READY=1\nSTATUS=%s: ready to serve connections...", name);
41 #endif
42 DEBUG(0, ("STATUS=daemon '%s' finished starting up and ready to serve "
43@@ -129,7 +129,7 @@
44 if (name == NULL) {
45 name = "Samba";
46 }
47-#ifdef HAVE_LIBSYSTEMD_DAEMON
48+#ifdef HAVE_LIBSYSTEMD
49 sd_notifyf(0, "\nSTATUS=%s: %s", name, msg);
50 #endif
51 DEBUG(0, ("STATUS=daemon '%s' : %s", name, msg));
52diff -ur samba-4.4.2/lib/util/debug.c samba-4.4.2/lib/util/debug.c
53--- samba-4.4.2/lib/util/debug.c 2016-05-08 18:33:24.000000000 +0200
54+++ samba-4.4.2/lib/util/debug.c 2016-05-08 18:27:09.341481492 +0200
55@@ -102,7 +102,7 @@
56 .fd = 2 /* stderr by default */
57 };
58
59-#if defined(WITH_SYSLOG) || defined(HAVE_LIBSYSTEMD_JOURNAL)
60+#if defined(WITH_SYSLOG) || defined(HAVE_LIBSYSTEMD)
61 static int debug_level_to_priority(int level)
62 {
63 /*
64@@ -179,7 +179,7 @@
65 }
66 #endif /* WITH_SYSLOG */
67
68-#ifdef HAVE_LIBSYSTEMD_JOURNAL
69+#ifdef HAVE_LIBSYSTEMD
70 #include <systemd/sd-journal.h>
71 static void debug_systemd_log(int msg_level,
72 const char *msg, const char *msg_no_nl)
73@@ -251,7 +251,7 @@
74 },
75 #endif
76
77-#ifdef HAVE_LIBSYSTEMD_JOURNAL
78+#ifdef HAVE_LIBSYSTEMD
79 {
80 .name = "systemd",
81 .log = debug_systemd_log,
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.4.2.bb b/meta-networking/recipes-connectivity/samba/samba_4.4.2.bb
index 50c100e41..b7ee73075 100644
--- a/meta-networking/recipes-connectivity/samba/samba_4.4.2.bb
+++ b/meta-networking/recipes-connectivity/samba/samba_4.4.2.bb
@@ -13,6 +13,7 @@ ${SAMBA_MIRROR} http://www.mirrorservice.org/sites/ftp.samba.org \n \
13 13
14SRC_URI = "${SAMBA_MIRROR}/stable/samba-${PV}.tar.gz \ 14SRC_URI = "${SAMBA_MIRROR}/stable/samba-${PV}.tar.gz \
15 file://00-fix-typos-in-man-pages.patch \ 15 file://00-fix-typos-in-man-pages.patch \
16 file://10-use-only-libsystemd.patch \
16 file://16-do-not-check-xsltproc-manpages.patch \ 17 file://16-do-not-check-xsltproc-manpages.patch \
17 file://20-do-not-import-target-module-while-cross-compile.patch \ 18 file://20-do-not-import-target-module-while-cross-compile.patch \
18 file://21-add-config-option-without-valgrind.patch \ 19 file://21-add-config-option-without-valgrind.patch \