diff options
Diffstat (limited to 'meta-networking/recipes-connectivity/wolfssl')
-rw-r--r-- | meta-networking/recipes-connectivity/wolfssl/wolfssl/0001-Make-ByteReverseWords-available-for-big-and-little-e.patch | 32 | ||||
-rw-r--r-- | meta-networking/recipes-connectivity/wolfssl/wolfssl_4.5.0.bb (renamed from meta-networking/recipes-connectivity/wolfssl/wolfssl_4.4.0.bb) | 6 |
2 files changed, 36 insertions, 2 deletions
diff --git a/meta-networking/recipes-connectivity/wolfssl/wolfssl/0001-Make-ByteReverseWords-available-for-big-and-little-e.patch b/meta-networking/recipes-connectivity/wolfssl/wolfssl/0001-Make-ByteReverseWords-available-for-big-and-little-e.patch new file mode 100644 index 000000000..4676769a4 --- /dev/null +++ b/meta-networking/recipes-connectivity/wolfssl/wolfssl/0001-Make-ByteReverseWords-available-for-big-and-little-e.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From b90acc91d0cd276befe7f08f87ba2dc5ee7122ff Mon Sep 17 00:00:00 2001 | ||
2 | From: Tesfa Mael <tesfa@wolfssl.com> | ||
3 | Date: Wed, 26 Aug 2020 10:13:06 -0700 | ||
4 | Subject: [PATCH] Make ByteReverseWords available for big and little endian | ||
5 | |||
6 | --- | ||
7 | wolfcrypt/src/misc.c | 2 -- | ||
8 | 1 file changed, 2 deletions(-) | ||
9 | |||
10 | diff --git a/wolfcrypt/src/misc.c b/wolfcrypt/src/misc.c | ||
11 | index fe66ee0a1..23bfa1adc 100644 | ||
12 | --- a/wolfcrypt/src/misc.c | ||
13 | +++ b/wolfcrypt/src/misc.c | ||
14 | @@ -120,7 +120,6 @@ WC_STATIC WC_INLINE word32 ByteReverseWord32(word32 value) | ||
15 | return rotlFixed(value, 16U); | ||
16 | #endif | ||
17 | } | ||
18 | -#if defined(LITTLE_ENDIAN_ORDER) | ||
19 | /* This routine performs a byte swap of words array of a given count. */ | ||
20 | WC_STATIC WC_INLINE void ByteReverseWords(word32* out, const word32* in, | ||
21 | word32 byteCount) | ||
22 | @@ -131,7 +130,6 @@ WC_STATIC WC_INLINE void ByteReverseWords(word32* out, const word32* in, | ||
23 | out[i] = ByteReverseWord32(in[i]); | ||
24 | |||
25 | } | ||
26 | -#endif /* LITTLE_ENDIAN_ORDER */ | ||
27 | |||
28 | #if defined(WORD64_AVAILABLE) && !defined(WOLFSSL_NO_WORD64_OPS) | ||
29 | |||
30 | -- | ||
31 | 2.25.1 | ||
32 | |||
diff --git a/meta-networking/recipes-connectivity/wolfssl/wolfssl_4.4.0.bb b/meta-networking/recipes-connectivity/wolfssl/wolfssl_4.5.0.bb index db7b0d486..61cf1cc62 100644 --- a/meta-networking/recipes-connectivity/wolfssl/wolfssl_4.4.0.bb +++ b/meta-networking/recipes-connectivity/wolfssl/wolfssl_4.5.0.bb | |||
@@ -12,8 +12,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | |||
12 | PROVIDES += "cyassl" | 12 | PROVIDES += "cyassl" |
13 | RPROVIDES_${PN} = "cyassl" | 13 | RPROVIDES_${PN} = "cyassl" |
14 | 14 | ||
15 | SRC_URI = "git://github.com/wolfSSL/wolfssl.git;protocol=https" | 15 | SRC_URI = "git://github.com/wolfSSL/wolfssl.git;protocol=https \ |
16 | SRCREV = "e116c89a58af750421d82ece13f80516d2bde02e" | 16 | file://0001-Make-ByteReverseWords-available-for-big-and-little-e.patch \ |
17 | " | ||
18 | SRCREV = "0fa5af9929ce2ee99e8789996a3048f41a99830e" | ||
17 | S = "${WORKDIR}/git" | 19 | S = "${WORKDIR}/git" |
18 | 20 | ||
19 | inherit autotools | 21 | inherit autotools |