diff options
Diffstat (limited to 'meta-networking/recipes-connectivity/openthread/ot-br-posix/musl-fixes.patch')
-rw-r--r-- | meta-networking/recipes-connectivity/openthread/ot-br-posix/musl-fixes.patch | 26 |
1 files changed, 0 insertions, 26 deletions
diff --git a/meta-networking/recipes-connectivity/openthread/ot-br-posix/musl-fixes.patch b/meta-networking/recipes-connectivity/openthread/ot-br-posix/musl-fixes.patch deleted file mode 100644 index 279a60741..000000000 --- a/meta-networking/recipes-connectivity/openthread/ot-br-posix/musl-fixes.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | Musl fixes, which should be applied upstream too | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
5 | --- a/src/dbus/common/types.hpp | ||
6 | +++ b/src/dbus/common/types.hpp | ||
7 | @@ -715,7 +715,7 @@ struct TrelInfo | ||
8 | }; | ||
9 | |||
10 | bool mEnabled; ///< Whether TREL is enabled. | ||
11 | - u_int16_t mNumTrelPeers; ///< The number of TREL peers. | ||
12 | + uint16_t mNumTrelPeers; ///< The number of TREL peers. | ||
13 | TrelPacketCounters mTrelCounters; ///< The TREL counters. | ||
14 | }; | ||
15 | |||
16 | --- a/third_party/openthread/repo/src/posix/platform/CMakeLists.txt | ||
17 | +++ b/third_party/openthread/repo/src/posix/platform/CMakeLists.txt | ||
18 | @@ -172,7 +172,7 @@ target_link_libraries(openthread-posix | ||
19 | ) | ||
20 | |||
21 | option(OT_TARGET_OPENWRT "enable openthread posix for OpenWRT" OFF) | ||
22 | -if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux" AND NOT OT_TARGET_OPENWRT) | ||
23 | +if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux" AND NOT OT_TARGET_OPENWRT AND NOT OT_TARGET_MUSL) | ||
24 | target_compile_definitions(ot-posix-config | ||
25 | INTERFACE "OPENTHREAD_POSIX_CONFIG_NAT64_AIL_PREFIX_ENABLE=1" | ||
26 | ) | ||