summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/mosquitto/files/2894.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity/mosquitto/files/2894.patch')
-rw-r--r--meta-networking/recipes-connectivity/mosquitto/files/2894.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/mosquitto/files/2894.patch b/meta-networking/recipes-connectivity/mosquitto/files/2894.patch
new file mode 100644
index 000000000..3275e57e3
--- /dev/null
+++ b/meta-networking/recipes-connectivity/mosquitto/files/2894.patch
@@ -0,0 +1,23 @@
1From: Joachim Zobel <jz-2017@heute-morgen.de>
2Date: Wed, 13 Sep 2023 09:55:34 +0200
3Subject: [PATCH] Link correctly with shared websockets library if needed see:
4 https://github.com/eclipse/mosquitto/pull/2751
5
6Patch contributed by Joachim Zobel <jz-2017@heute-morgen.de> and Daniel Engberg <daniel.engberg.lists@pyret.net>
7---
8 src/CMakeLists.txt | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
12index 9380a04..dce8313 100644
13--- a/src/CMakeLists.txt
14+++ b/src/CMakeLists.txt
15@@ -200,7 +200,7 @@ if (WITH_WEBSOCKETS)
16 link_directories(${mosquitto_SOURCE_DIR})
17 endif (WIN32)
18 else (STATIC_WEBSOCKETS)
19- set (MOSQ_LIBS ${MOSQ_LIBS} websockets)
20+ set (MOSQ_LIBS ${MOSQ_LIBS} websockets_shared)
21 endif (STATIC_WEBSOCKETS)
22 endif (WITH_WEBSOCKETS)
23