diff options
Diffstat (limited to 'meta-networking/recipes-connectivity/mbedtls')
-rw-r--r-- | meta-networking/recipes-connectivity/mbedtls/mbedtls_1.3.10.bb | 37 |
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/mbedtls/mbedtls_1.3.10.bb b/meta-networking/recipes-connectivity/mbedtls/mbedtls_1.3.10.bb new file mode 100644 index 000000000..d5c7afe04 --- /dev/null +++ b/meta-networking/recipes-connectivity/mbedtls/mbedtls_1.3.10.bb | |||
@@ -0,0 +1,37 @@ | |||
1 | SUMMARY = "Lightweight crypto and SSL/TLS library" | ||
2 | DESCRIPTION = "mbedtls is a lean open source crypto library \ | ||
3 | for providing SSL and TLS support in your programs. It offers \ | ||
4 | an intuitive API and documented header files, so you can actually \ | ||
5 | understand what the code does. It features: \ | ||
6 | \ | ||
7 | - Symmetric algorithms, like AES, Blowfish, Triple-DES, DES, ARC4, \ | ||
8 | Camellia and XTEA \ | ||
9 | - Hash algorithms, like SHA-1, SHA-2, RIPEMD-160 and MD5 \ | ||
10 | - Entropy pool and random generators, like CTR-DRBG and HMAC-DRBG \ | ||
11 | - Public key algorithms, like RSA, Elliptic Curves, Diffie-Hellman, \ | ||
12 | ECDSA and ECDH \ | ||
13 | - SSL v3 and TLS 1.0, 1.1 and 1.2 \ | ||
14 | - Abstraction layers for ciphers, hashes, public key operations, \ | ||
15 | platform abstraction and threading \ | ||
16 | " | ||
17 | |||
18 | HOMEPAGE = "https://polarssl.org" | ||
19 | BUGTRACKER = "https://github.com/polarssl/polarssl/issues" | ||
20 | |||
21 | LICENSE = "GPLv2" | ||
22 | LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe" | ||
23 | |||
24 | SECTION = "libdevel" | ||
25 | |||
26 | SRC_URI = "https://tls.mbed.org/download/mbedtls-${PV}-gpl.tgz" | ||
27 | |||
28 | SRC_URI[md5sum] = "19ebbc96feceb430ad958dfe89cb633f" | ||
29 | SRC_URI[sha256sum] = "746fd88e0c6623691fc56c4eed52e40a57b2da0ac80f6dd8995094aa6adb407e" | ||
30 | |||
31 | DEPENDS = "openssl" | ||
32 | RDEPENDS_${PN} += "libcrypto" | ||
33 | PROVIDES += "polarssl" | ||
34 | RPROVIDES_${PN} = "polarssl" | ||
35 | EXTRA_OECMAKE = "-DUSE_SHARED_POLARSSL_LIBRARY=on -DLIB_INSTALL_DIR=${baselib}" | ||
36 | |||
37 | inherit cmake | ||