diff options
Diffstat (limited to 'meta-networking/recipes-connectivity/mbedtls/mbedtls_2.16.3.bb')
-rw-r--r-- | meta-networking/recipes-connectivity/mbedtls/mbedtls_2.16.3.bb | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.16.3.bb b/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.16.3.bb new file mode 100644 index 000000000..79d0dbeae --- /dev/null +++ b/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.16.3.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | SUMMARY = "Lightweight crypto and SSL/TLS library" | ||
2 | DESCRIPTION = "mbedtls is a lean open source crypto library \ | ||
3 | for providing SSL and TLS support in your programs. It offers \ | ||
4 | an intuitive API and documented header files, so you can actually \ | ||
5 | understand what the code does. It features: \ | ||
6 | \ | ||
7 | - Symmetric algorithms, like AES, Blowfish, Triple-DES, DES, ARC4, \ | ||
8 | Camellia and XTEA \ | ||
9 | - Hash algorithms, like SHA-1, SHA-2, RIPEMD-160 and MD5 \ | ||
10 | - Entropy pool and random generators, like CTR-DRBG and HMAC-DRBG \ | ||
11 | - Public key algorithms, like RSA, Elliptic Curves, Diffie-Hellman, \ | ||
12 | ECDSA and ECDH \ | ||
13 | - SSL v3 and TLS 1.0, 1.1 and 1.2 \ | ||
14 | - Abstraction layers for ciphers, hashes, public key operations, \ | ||
15 | platform abstraction and threading \ | ||
16 | " | ||
17 | |||
18 | HOMEPAGE = "https://tls.mbed.org/" | ||
19 | |||
20 | LICENSE = "Apache-2.0" | ||
21 | LIC_FILES_CHKSUM = "file://LICENSE;md5=302d50a6369f5f22efdb674db908167a" | ||
22 | |||
23 | SECTION = "libs" | ||
24 | |||
25 | SRC_URI = "https://tls.mbed.org/download/mbedtls-${PV}-apache.tgz" | ||
26 | SRC_URI[md5sum] = "90ce7c7a001d2514410280706b3ab1a7" | ||
27 | SRC_URI[sha256sum] = "ec1bee6d82090ed6ea2690784ea4b294ab576a65d428da9fe8750f932d2da661" | ||
28 | |||
29 | inherit cmake | ||
30 | |||
31 | PACKAGECONFIG ??= "shared-libs programs" | ||
32 | PACKAGECONFIG[shared-libs] = "-DUSE_SHARED_MBEDTLS_LIBRARY=ON,-USE_SHARED_MBEDTLS_LIBRARY=OFF" | ||
33 | PACKAGECONFIG[programs] = "-DENABLE_PROGRAMS=ON,-DENABLE_PROGRAMS=OFF" | ||
34 | |||
35 | EXTRA_OECMAKE = "-DENABLE_TESTING=OFF -DLIB_INSTALL_DIR:STRING=${libdir}" | ||
36 | |||
37 | PROVIDES += "polarssl" | ||
38 | RPROVIDES_${PN} = "polarssl" | ||
39 | |||
40 | PACKAGES =+ "${PN}-programs" | ||
41 | FILES_${PN}-programs = "${bindir}/" | ||