summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/lftp/lftp_4.7.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity/lftp/lftp_4.7.5.bb')
-rw-r--r--meta-networking/recipes-connectivity/lftp/lftp_4.7.5.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/lftp/lftp_4.7.5.bb b/meta-networking/recipes-connectivity/lftp/lftp_4.7.5.bb
new file mode 100644
index 000000000..8f88f9b10
--- /dev/null
+++ b/meta-networking/recipes-connectivity/lftp/lftp_4.7.5.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "LFTP is a sophisticated file transfer program with \
2 command line interface. It supports FTP, HTTP, \
3 FISH, SFTP, HTTPS and FTPS protocols"
4HOMEPAGE = "http://lftp.yar.ru/"
5SECTION = "console/network"
6LICENSE = "GPLv3"
7LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
8
9SRC_URI = "http://lftp.yar.ru/ftp/lftp-${PV}.tar.bz2 \
10 file://fix-gcc-6-conflicts-signbit.patch \
11 "
12SRC_URI[md5sum] = "868d621838d471ba681ca6004c1f9305"
13SRC_URI[sha256sum] = "90f3cbc827534c3b3a391a2dd8b39cc981ac4991fa24b6f90e2008ccc0a5207d"
14
15inherit autotools gettext pkgconfig
16
17acpaths = "-I ./m4"
18
19EXTRA_OECONF += "--with-modules"
20
21PACKAGECONFIG ??= "libidn openssl zlib gnutls readline expat"
22PACKAGECONFIG[libidn] = "--with-libidn, --without-libidn, libidn"
23PACKAGECONFIG[openssl] = "--with-openssl, --without-openssl, openssl"
24PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_INCDIR}/.., --without-zlib, zlib"
25PACKAGECONFIG[gnutls] = "--with-gnutls, --without-gnutls, gnutls"
26PACKAGECONFIG[readline] = "--with-readline=${STAGING_INCDIR}/.. --with-readline-inc=${STAGING_INCDIR} --with-readline-lib=-lreadline, --with-readline=no, readline"
27PACKAGECONFIG[expat] = "--with-expat=${STAGING_INCDIR}/.. --with-expat-inc=${STAGING_INCDIR} --with-expat-lib=-lexpat, , expat"
28
29FILES_${PN}-dbg += "${libdir}/lftp/${PV}/.debug"
30RDEPENDS_${PN} = "perl bash readline"