summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/kea/kea_1.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity/kea/kea_1.7.0.bb')
-rw-r--r--meta-networking/recipes-connectivity/kea/kea_1.7.0.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/kea/kea_1.7.0.bb b/meta-networking/recipes-connectivity/kea/kea_1.7.0.bb
new file mode 100644
index 000000000..3123099a7
--- /dev/null
+++ b/meta-networking/recipes-connectivity/kea/kea_1.7.0.bb
@@ -0,0 +1,61 @@
1SUMMARY = "ISC Kea DHCP Server"
2DESCRIPTION = "Kea is the next generation of DHCP software developed by ISC. It supports both DHCPv4 and DHCPv6 protocols along with their extensions, e.g. prefix delegation and dynamic updates to DNS."
3HOMEPAGE = "http://kea.isc.org"
4SECTION = "connectivity"
5LICENSE = "MPL-2.0 & Apache-2.0"
6LIC_FILES_CHKSUM = "file://COPYING;md5=0e5b01c848c7736a0c9e68f9c9cd0281"
7
8DEPENDS += "kea-native"
9
10SRC_URI = "\
11 http://ftp.isc.org/isc/kea/${PV}/${BP}.tar.gz \
12 file://0001-remove-AC_TRY_RUN.patch \
13 file://kea-dhcp4.service \
14 file://kea-dhcp6.service \
15 file://kea-dhcp-ddns.service \
16"
17SRC_URI[md5sum] = "c6406ac3d160161056d2fc36557ebd89"
18SRC_URI[sha256sum] = "173c8e893690a611bc1d1c6fbe54a5c20fcd54429399a8dc3a0d7d2eb01bf8cc"
19
20inherit autotools systemd
21
22SYSTEMD_SERVICE_${PN} = "kea-dhcp4.service kea-dhcp6.service kea-dhcp-ddns.service"
23SYSTEMD_AUTO_ENABLE = "disable"
24
25DEBUG_OPTIMIZATION_remove_mips = " -Og"
26DEBUG_OPTIMIZATION_append_mips = " -O"
27BUILD_OPTIMIZATION_remove_mips = " -Og"
28BUILD_OPTIMIZATION_append_mips = " -O"
29
30DEBUG_OPTIMIZATION_remove_mipsel = " -Og"
31DEBUG_OPTIMIZATION_append_mipsel = " -O"
32BUILD_OPTIMIZATION_remove_mipsel = " -Og"
33BUILD_OPTIMIZATION_append_mipsel = " -O"
34
35do_configure_prepend_class-target() {
36 mkdir -p ${B}/src/lib/log/compiler/
37 ln -sf ${STAGING_BINDIR_NATIVE}/kea-msg-compiler ${B}/src/lib/log/compiler/kea-msg-compiler
38}
39
40do_install_append_class-target() {
41 install -d ${D}${systemd_system_unitdir}
42 install -m 0644 ${WORKDIR}/kea-dhcp*service ${D}${systemd_system_unitdir}
43 sed -i -e 's,@SBINDIR@,${sbindir},g' -e 's,@BASE_BINDIR@,${base_bindir},g' \
44 -e 's,@LOCALSTATEDIR@,${localstatedir},g' -e 's,@SYSCONFDIR@,${sysconfdir},g' \
45 ${D}${systemd_system_unitdir}/kea-dhcp*service
46}
47
48do_install_append() {
49 rm -rf "${D}${localstatedir}"
50}
51
52PACKAGECONFIG ??= "openssl log4cplus boost"
53
54PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_TARGET}${prefix},,openssl,openssl"
55PACKAGECONFIG[log4cplus] = "--with-log4cplus=${STAGING_DIR_TARGET}${prefix},,log4cplus,log4cplus"
56PACKAGECONFIG[boost] = "--with-boost-libs=-lboost_system,,boost,boost"
57
58FILES_${PN}-staticdev += "${libdir}/kea/hooks/*.a ${libdir}/hooks/*.a"
59FILES_${PN} += "${libdir}/hooks/*.so"
60
61BBCLASSEXTEND += "native"