summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2')
-rw-r--r--meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/fix-disable-ipv6.patch60
-rw-r--r--meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/inetutils-1.8-0001-printf-parse-pull-in-features.h-for-__GLIBC__.patch29
-rw-r--r--meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/inetutils-1.8-0003-wchar.patch14
-rw-r--r--meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/inetutils-1.9-PATH_PROCNET_DEV.patch26
-rw-r--r--meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/rexec.xinetd.inetutils20
-rw-r--r--meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/rlogin.xinetd.inetutils23
-rw-r--r--meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/rsh.xinetd.inetutils21
-rw-r--r--meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/telnet.xinetd.inetutils13
-rw-r--r--meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/tftpd.xinetd.inetutils19
-rw-r--r--meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/version.patch17
10 files changed, 242 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/fix-disable-ipv6.patch b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/fix-disable-ipv6.patch
new file mode 100644
index 000000000..bd3ae476b
--- /dev/null
+++ b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/fix-disable-ipv6.patch
@@ -0,0 +1,60 @@
1Upstream: http://www.mail-archive.com/bug-inetutils@gnu.org/msg02103.html
2
3Upstream-Status: Pending
4
5diff -ur inetutils-1.8.orig/ping/ping_common.h inetutils-1.8/ping/ping_common.h
6--- inetutils-1.8.orig/ping/ping_common.h 2010-05-15 20:55:47.000000000 +0930
7+++ inetutils-1.8/ping/ping_common.h 2010-12-01 12:19:08.000000000 +1030
8@@ -17,10 +17,14 @@
9 You should have received a copy of the GNU General Public License
10 along with this program. If not, see `http://www.gnu.org/licenses/'. */
11
12+#include <config.h>
13+
14 #include <netinet/in_systm.h>
15 #include <netinet/in.h>
16 #include <netinet/ip.h>
17+#ifdef HAVE_IPV6
18 #include <netinet/icmp6.h>
19+#endif
20 #include <icmp.h>
21 #include <error.h>
22 #include <progname.h>
23@@ -66,13 +70,19 @@
24 (t).tv_usec = ((i)%PING_PRECISION)*(1000000/PING_PRECISION) ;\
25 } while (0)
26
27+#ifdef HAVE_IPV6
28 /* Not sure about this step*/
29 #define _PING_BUFLEN(p, USE_IPV6) ((USE_IPV6)? ((p)->ping_datalen + sizeof (struct icmp6_hdr)) : \
30 ((p)->ping_datalen + sizeof (icmphdr_t)))
31+#else
32+#define _PING_BUFLEN(p, USE_IPV6) ((p)->ping_datalen + sizeof (icmphdr_t))
33+#endif
34
35+#ifdef HAVE_IPV6
36 typedef int (*ping_efp6) (int code, void *closure, struct sockaddr_in6 * dest,
37 struct sockaddr_in6 * from, struct icmp6_hdr * icmp,
38 int datalen);
39+#endif
40
41 typedef int (*ping_efp) (int code,
42 void *closure,
43@@ -81,13 +91,17 @@
44 struct ip * ip, icmphdr_t * icmp, int datalen);
45
46 union event {
47+#ifdef HAVE_IPV6
48 ping_efp6 handler6;
49+#endif
50 ping_efp handler;
51 };
52
53 union ping_address {
54 struct sockaddr_in ping_sockaddr;
55+#ifdef HAVE_IPV6
56 struct sockaddr_in6 ping_sockaddr6;
57+#endif
58 };
59
60 typedef struct ping_data PING;
diff --git a/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/inetutils-1.8-0001-printf-parse-pull-in-features.h-for-__GLIBC__.patch b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/inetutils-1.8-0001-printf-parse-pull-in-features.h-for-__GLIBC__.patch
new file mode 100644
index 000000000..3da4e9f55
--- /dev/null
+++ b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/inetutils-1.8-0001-printf-parse-pull-in-features.h-for-__GLIBC__.patch
@@ -0,0 +1,29 @@
1From 552a7d64ad4a7188a9b7cd89933ae7caf7ebfe90 Mon Sep 17 00:00:00 2001
2From: Mike Frysinger <vapier at gentoo.org>
3Date: Thu, 18 Nov 2010 16:59:14 -0500
4Subject: [PATCH gnulib] printf-parse: pull in features.h for __GLIBC__
5
6Upstream-Status: Pending
7
8Signed-off-by: Mike Frysinger <vapier at gentoo.org>
9---
10 lib/printf-parse.h | 3 +++
11 1 files changed, 3 insertions(+), 0 deletions(-)
12
13diff --git a/lib/printf-parse.h b/lib/printf-parse.h
14index 67a4a2a..3bd6152 100644
15--- a/lib/printf-parse.h
16+++ b/lib/printf-parse.h
17@@ -25,6 +25,9 @@
18
19 #include "printf-args.h"
20
21+#ifdef HAVE_FEATURES_H
22+# include <features.h> /* for __GLIBC__ */
23+#endif
24
25 /* Flags */
26 #define FLAG_GROUP 1 /* ' flag */
27--
281.7.3.2
29
diff --git a/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/inetutils-1.8-0003-wchar.patch b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/inetutils-1.8-0003-wchar.patch
new file mode 100644
index 000000000..b13bb9229
--- /dev/null
+++ b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/inetutils-1.8-0003-wchar.patch
@@ -0,0 +1,14 @@
1Upstream-Status: Pending
2
3--- inetutils-1.8/lib/wchar.in.h
4+++ inetutils-1.8/lib/wchar.in.h
5@@ -70,6 +70,9 @@
6 /* The include_next requires a split double-inclusion guard. */
7 #if @HAVE_WCHAR_H@
8 # @INCLUDE_NEXT@ @NEXT_WCHAR_H@
9+#else
10+# include <stddef.h>
11+# define MB_CUR_MAX 1
12 #endif
13
14 #undef _GL_ALREADY_INCLUDING_WCHAR_H
diff --git a/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/inetutils-1.9-PATH_PROCNET_DEV.patch b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/inetutils-1.9-PATH_PROCNET_DEV.patch
new file mode 100644
index 000000000..2592989a9
--- /dev/null
+++ b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/inetutils-1.9-PATH_PROCNET_DEV.patch
@@ -0,0 +1,26 @@
1inetutils: define PATH_PROCNET_DEV if not already defined
2
3this prevents the following compilation error :
4system/linux.c:401:15: error: 'PATH_PROCNET_DEV' undeclared (first use in this function)
5
6this patch comes from :
7 http://repository.timesys.com/buildsources/i/inetutils/inetutils-1.9/
8
9Upstream-Status: Inappropriate [not author]
10
11Signed-of-by: Eric BĂ©nard <eric@eukrea.com>
12---
13diff -Naur inetutils-1.9.orig/ifconfig/system/linux.c inetutils-1.9/ifconfig/system/linux.c
14--- inetutils-1.9.orig/ifconfig/system/linux.c 2012-01-04 16:31:36.000000000 -0500
15+++ inetutils-1.9/ifconfig/system/linux.c 2012-01-04 16:40:53.000000000 -0500
16@@ -49,6 +49,10 @@
17 #include "../ifconfig.h"
18
19
20+#ifndef PATH_PROCNET_DEV
21+ #define PATH_PROCNET_DEV "/proc/net/dev"
22+#endif
23+
24 /* ARPHRD stuff. */
25
26 static void
diff --git a/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/rexec.xinetd.inetutils b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/rexec.xinetd.inetutils
new file mode 100644
index 000000000..80aed36ff
--- /dev/null
+++ b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/rexec.xinetd.inetutils
@@ -0,0 +1,20 @@
1# default: off
2# description:
3# Rexecd is the server for the rexec program. The server provides remote
4# execution facilities with authentication based on user names and
5# passwords.
6#
7service exec
8{
9 socket_type = stream
10 protocol = tcp
11 flags = NAMEINARGS
12 wait = no
13 user = root
14 group = root
15 log_on_success += USERID
16 log_on_failure += USERID
17 server = /usr/bin/tcpd
18 server_args = /usr/sbin/in.rexecd
19 disable = yes
20}
diff --git a/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/rlogin.xinetd.inetutils b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/rlogin.xinetd.inetutils
new file mode 100644
index 000000000..00dbf935b
--- /dev/null
+++ b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/rlogin.xinetd.inetutils
@@ -0,0 +1,23 @@
1# default: off
2# description:
3# Rlogind is a server for the rlogin program. The server provides remote
4# execution with authentication based on privileged port numbers from trusted
5# host
6#
7service login
8{
9 socket_type = stream
10 protocol = tcp
11 flags = NAMEINARGS
12 wait = no
13 user = root
14 group = root
15 log_on_success += USERID
16 log_on_failure += USERID
17 server = /usr/bin/tcpd
18 server_args = /usr/sbin/in.rlogind -a
19 disable = yes
20}
21
22
23
diff --git a/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/rsh.xinetd.inetutils b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/rsh.xinetd.inetutils
new file mode 100644
index 000000000..ad59b6207
--- /dev/null
+++ b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/rsh.xinetd.inetutils
@@ -0,0 +1,21 @@
1# default: off
2# description:
3# The rshd server is a server for the rcmd(3) routine and,
4# consequently, for the rsh(1) program. The server provides
5# remote execution facilities with authentication based on
6# privileged port numbers from trusted hosts.
7#
8service shell
9{
10 socket_type = stream
11 protocol = tcp
12 flags = NAMEINARGS
13 wait = no
14 user = root
15 group = root
16 log_on_success += USERID
17 log_on_failure += USERID
18 server = /usr/bin/tcpd
19 server_args = /usr/sbin/in.rshd -aL
20 disable = yes
21}
diff --git a/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/telnet.xinetd.inetutils b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/telnet.xinetd.inetutils
new file mode 100644
index 000000000..2a2a12e3a
--- /dev/null
+++ b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/telnet.xinetd.inetutils
@@ -0,0 +1,13 @@
1# default: on
2# description: The telnet server serves telnet sessions; it uses \
3# unencrypted username/password pairs for authentication.
4service telnet
5{
6 disable = no
7 flags = REUSE
8 socket_type = stream
9 wait = no
10 user = root
11 server = /usr/sbin/in.telnetd
12 log_on_failure += USERID
13}
diff --git a/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/tftpd.xinetd.inetutils b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/tftpd.xinetd.inetutils
new file mode 100644
index 000000000..f54916339
--- /dev/null
+++ b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/tftpd.xinetd.inetutils
@@ -0,0 +1,19 @@
1# default: off
2# description:
3# Tftpd is a server which supports the Internet Trivial File Transfer
4# Pro-tocol (RFC 783). The TFTP server operates at the port indicated
5# in the tftp service description; see services(5).
6#
7service tftp
8{
9 disable = yes
10 socket_type = dgram
11 protocol = udp
12 flags = IPv6
13 wait = yes
14 user = root
15 group = root
16 server = /usr/sbin/in.tftpd
17 server_args = /tftpboot
18}
19
diff --git a/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/version.patch b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/version.patch
new file mode 100644
index 000000000..1caa2d39d
--- /dev/null
+++ b/meta-networking/recipes-connectivity/inetutils/inetutils-1.9.2/version.patch
@@ -0,0 +1,17 @@
1Upstream-Status: Pending
2
3remove m4_esyscmd function
4
5Signed-off-by: Chunrong Guo <b40290@freescale.com>
6--- inetutils-1.9.1/configure.ac 2012-01-06 22:05:05.000000000 +0800
7+++ inetutils-1.9.1/configure.ac 2012-11-12 14:01:11.732957019 +0800
8@@ -20,8 +20,7 @@
9
10 AC_PREREQ(2.59)
11
12-AC_INIT([GNU inetutils],
13- m4_esyscmd([build-aux/git-version-gen .tarball-version 's/inetutils-/v/;s/_/./g']),
14+AC_INIT([GNU inetutils],[1.9.2],
15 [bug-inetutils@gnu.org])
16
17 AC_CONFIG_SRCDIR([src/inetd.c])