summaryrefslogtreecommitdiffstats
path: root/meta-multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'meta-multimedia')
-rw-r--r--meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth.inc4
-rw-r--r--meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth/0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch32
2 files changed, 24 insertions, 12 deletions
diff --git a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth.inc b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth.inc
index 73858b020..fcc9df8c3 100644
--- a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth.inc
+++ b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth.inc
@@ -5,8 +5,8 @@ LICENSE = "LGPL-2.1"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=fc178bcd425090939a8b634d1d6a9594" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=fc178bcd425090939a8b634d1d6a9594"
6 6
7SRC_URI = "git://github.com/FluidSynth/fluidsynth.git" 7SRC_URI = "git://github.com/FluidSynth/fluidsynth.git"
8SRCREV = "d9ad6a0725840388a48f45e38eda903a65ec1cf5" 8SRCREV = "19a20eb8526465fdf940b740b13462d71e190a1a"
9S = "${WORKDIR}/git" 9S = "${WORKDIR}/git"
10PV = "2.1.2" 10PV = "2.1.3"
11 11
12inherit cmake pkgconfig lib_package 12inherit cmake pkgconfig lib_package
diff --git a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth/0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth/0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch
index 44612275c..cc73bdb1d 100644
--- a/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth/0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch
+++ b/meta-multimedia/recipes-multimedia/fluidsynth/fluidsynth/0001-Do-not-build-gentables-helper-we-have-to-use-native-.patch
@@ -10,28 +10,40 @@ Upstream-Status: Inappropriate [embedded specific]
10 10
11Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> 11Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
12--- 12---
13 src/CMakeLists.txt | 11 ----------- 13 src/CMakeLists.txt | 23 +----------------------
14 1 file changed, 11 deletions(-) 14 1 file changed, 1 insertion(+), 22 deletions(-)
15 15
16diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt 16diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
17index a0ba53d1..1c626717 100644 17index 356bb734..58ff7635 100644
18--- a/src/CMakeLists.txt 18--- a/src/CMakeLists.txt
19+++ b/src/CMakeLists.txt 19+++ b/src/CMakeLists.txt
20@@ -359,14 +359,3 @@ else ( MACOSX_FRAMEWORK ) 20@@ -399,25 +399,4 @@ else ( MACOSX_FRAMEWORK )
21 )
22 install ( FILES ${public_main_HEADER} DESTINATION ${INCLUDE_INSTALL_DIR} ) 21 install ( FILES ${public_main_HEADER} DESTINATION ${INCLUDE_INSTALL_DIR} )
23 endif ( MACOSX_FRAMEWORK ) 22 endif ( MACOSX_FRAMEWORK )
24- 23
25-# ******* Auto Generated Lookup Tables ****** 24-# ******* Auto Generated Lookup Tables ******
26- 25-
27-include(ExternalProject) 26-include(ExternalProject)
27-
28-set (GENTAB_SDIR ${CMAKE_CURRENT_SOURCE_DIR}/gentables)
29-set (GENTAB_BDIR ${CMAKE_CURRENT_BINARY_DIR}/gentables)
30-
31-# Use external project to ensure that cmake uses the host compiler when building make_tables.exe
32-# To fix cross-compiling fluidsynth from Win32 to ARM (using vcpkg), we need to pass the current generator
33-# on to the external project, otherwise (for some unknown reason) the target compiler will be used rather
34-# than the host compiler.
28-ExternalProject_Add(gentables 35-ExternalProject_Add(gentables
29- DOWNLOAD_COMMAND "" 36- DOWNLOAD_COMMAND ""
30- SOURCE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/gentables 37- SOURCE_DIR ${GENTAB_SDIR}
31- BINARY_DIR ${CMAKE_CURRENT_BINARY_DIR}/gentables 38- BINARY_DIR ${GENTAB_BDIR}
32- INSTALL_COMMAND ${CMAKE_CURRENT_BINARY_DIR}/gentables/make_tables.exe "${CMAKE_BINARY_DIR}/" 39- CONFIGURE_COMMAND
40- "${CMAKE_COMMAND}" -DCMAKE_VERBOSE_MAKEFILE=${CMAKE_VERBOSE_MAKEFILE} -G "${CMAKE_GENERATOR}" -B "${GENTAB_BDIR}" "${GENTAB_SDIR}"
41- BUILD_COMMAND
42- "${CMAKE_COMMAND}" --build "${GENTAB_BDIR}"
43- INSTALL_COMMAND ${GENTAB_BDIR}/make_tables.exe "${CMAKE_BINARY_DIR}/"
33-) 44-)
34-add_dependencies(libfluidsynth-OBJ gentables) 45-add_dependencies(libfluidsynth-OBJ gentables)
46+
35-- 47--
362.14.5 482.21.1
37 49