diff options
Diffstat (limited to 'meta-multimedia/recipes-multimedia')
-rw-r--r-- | meta-multimedia/recipes-multimedia/minidlna/minidlna.inc | 2 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/minidlna/minidlna/0001-Mark-setjmp_buffer-extern-declaration.patch | 29 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/minidlna/minidlna/0001-configure-Check-for-clock_gettime-seprately-from-__N.patch | 19 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/minidlna/minidlna/0001-configure.ac-drop-non-standard-checks.patch | 37 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/minidlna/minidlna_1.3.0.bb (renamed from meta-multimedia/recipes-multimedia/minidlna/minidlna_1.2.1.bb) | 2 |
5 files changed, 46 insertions, 43 deletions
diff --git a/meta-multimedia/recipes-multimedia/minidlna/minidlna.inc b/meta-multimedia/recipes-multimedia/minidlna/minidlna.inc index da2607fcf..7f916b2be 100644 --- a/meta-multimedia/recipes-multimedia/minidlna/minidlna.inc +++ b/meta-multimedia/recipes-multimedia/minidlna/minidlna.inc | |||
@@ -13,7 +13,7 @@ SRC_URI = "git://git.code.sf.net/p/minidlna/git;branch=master;module=git \ | |||
13 | file://minidlna.service \ | 13 | file://minidlna.service \ |
14 | file://0001-Update-Gettext-version.patch \ | 14 | file://0001-Update-Gettext-version.patch \ |
15 | file://0001-configure-Check-for-clock_gettime-seprately-from-__N.patch \ | 15 | file://0001-configure-Check-for-clock_gettime-seprately-from-__N.patch \ |
16 | file://0001-Mark-setjmp_buffer-extern-declaration.patch \ | 16 | file://0001-configure.ac-drop-non-standard-checks.patch \ |
17 | " | 17 | " |
18 | 18 | ||
19 | S = "${WORKDIR}/git" | 19 | S = "${WORKDIR}/git" |
diff --git a/meta-multimedia/recipes-multimedia/minidlna/minidlna/0001-Mark-setjmp_buffer-extern-declaration.patch b/meta-multimedia/recipes-multimedia/minidlna/minidlna/0001-Mark-setjmp_buffer-extern-declaration.patch deleted file mode 100644 index 0a1e800c8..000000000 --- a/meta-multimedia/recipes-multimedia/minidlna/minidlna/0001-Mark-setjmp_buffer-extern-declaration.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | From 1c6028f5f8bbfd3fd7327a43e1bb762c2c166167 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 12 Aug 2020 18:10:54 -0700 | ||
4 | Subject: [PATCH] Mark setjmp_buffer extern declaration | ||
5 | |||
6 | Fixes build with -fno-common | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | metadata.c | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/metadata.c b/metadata.c | ||
15 | index 8a10c77..c114091 100644 | ||
16 | --- a/metadata.c | ||
17 | +++ b/metadata.c | ||
18 | @@ -484,7 +484,7 @@ GetAudioMetadata(const char *path, const char *name) | ||
19 | } | ||
20 | |||
21 | /* For libjpeg error handling */ | ||
22 | -jmp_buf setjmp_buffer; | ||
23 | +extern jmp_buf setjmp_buffer; | ||
24 | static void | ||
25 | libjpeg_error_handler(j_common_ptr cinfo) | ||
26 | { | ||
27 | -- | ||
28 | 2.28.0 | ||
29 | |||
diff --git a/meta-multimedia/recipes-multimedia/minidlna/minidlna/0001-configure-Check-for-clock_gettime-seprately-from-__N.patch b/meta-multimedia/recipes-multimedia/minidlna/minidlna/0001-configure-Check-for-clock_gettime-seprately-from-__N.patch index 24a307db1..dd29797a6 100644 --- a/meta-multimedia/recipes-multimedia/minidlna/minidlna/0001-configure-Check-for-clock_gettime-seprately-from-__N.patch +++ b/meta-multimedia/recipes-multimedia/minidlna/minidlna/0001-configure-Check-for-clock_gettime-seprately-from-__N.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From 1118b1912916924bbfa3fd4dced9dfed01fbf0e0 Mon Sep 17 00:00:00 2001 | 1 | From 93e7e25a10c890b8c8cd06cbfd78175c30999d31 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Mon, 9 Mar 2020 09:44:33 -0700 | 3 | Date: Mon, 9 Mar 2020 09:44:33 -0700 |
4 | Subject: [PATCH] configure: Check for clock_gettime seprately from | 4 | Subject: [PATCH] configure: Check for clock_gettime seprately from |
@@ -9,13 +9,16 @@ since direct use of __NR_clock_gettime is not time64-safe | |||
9 | 9 | ||
10 | Upstream-Status: Pending | 10 | Upstream-Status: Pending |
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
12 | |||
12 | --- | 13 | --- |
13 | configure.ac | 10 +++++++--- | 14 | configure.ac | 4 ++++ |
14 | 1 file changed, 7 insertions(+), 3 deletions(-) | 15 | 1 file changed, 4 insertions(+) |
15 | 16 | ||
17 | diff --git a/configure.ac b/configure.ac | ||
18 | index 3d218ea..aa7dd1c 100644 | ||
16 | --- a/configure.ac | 19 | --- a/configure.ac |
17 | +++ b/configure.ac | 20 | +++ b/configure.ac |
18 | @@ -125,6 +125,10 @@ case $host in | 21 | @@ -127,6 +127,10 @@ case $host in |
19 | esac | 22 | esac |
20 | 23 | ||
21 | AC_CHECK_HEADERS(syscall.h sys/syscall.h mach/mach_time.h) | 24 | AC_CHECK_HEADERS(syscall.h sys/syscall.h mach/mach_time.h) |
@@ -26,11 +29,3 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
26 | AC_MSG_CHECKING([for __NR_clock_gettime syscall]) | 29 | AC_MSG_CHECKING([for __NR_clock_gettime syscall]) |
27 | AC_COMPILE_IFELSE( | 30 | AC_COMPILE_IFELSE( |
28 | [AC_LANG_PROGRAM( | 31 | [AC_LANG_PROGRAM( |
29 | @@ -143,7 +147,6 @@ AC_COMPILE_IFELSE( | ||
30 | ], | ||
31 | [ | ||
32 | AC_MSG_RESULT([no]) | ||
33 | - AC_SEARCH_LIBS([clock_gettime], [rt], [AC_DEFINE([HAVE_CLOCK_GETTIME], [1], [use clock_gettime])],) | ||
34 | ]) | ||
35 | |||
36 | AC_CHECK_HEADER(linux/netlink.h, | ||
diff --git a/meta-multimedia/recipes-multimedia/minidlna/minidlna/0001-configure.ac-drop-non-standard-checks.patch b/meta-multimedia/recipes-multimedia/minidlna/minidlna/0001-configure.ac-drop-non-standard-checks.patch new file mode 100644 index 000000000..93334b7da --- /dev/null +++ b/meta-multimedia/recipes-multimedia/minidlna/minidlna/0001-configure.ac-drop-non-standard-checks.patch | |||
@@ -0,0 +1,37 @@ | |||
1 | From 83425344b2d7339e8f5b0ad230c51278d330d613 Mon Sep 17 00:00:00 2001 | ||
2 | From: Alexander Kanavin <alex@linutronix.de> | ||
3 | Date: Sat, 22 Jan 2022 11:41:50 +0100 | ||
4 | Subject: [PATCH] configure.ac: drop non-standard checks | ||
5 | |||
6 | Not sure what upstream is trying to do here but it does not work | ||
7 | with the latest autoconf. | ||
8 | |||
9 | Upstream-Status: Inactive-Upstream | ||
10 | Signed-off-by: Alexander Kanavin <alex@linutronix.de> | ||
11 | --- | ||
12 | configure.ac | 5 ----- | ||
13 | 1 file changed, 5 deletions(-) | ||
14 | |||
15 | diff --git a/configure.ac b/configure.ac | ||
16 | index aa7dd1c..858db52 100644 | ||
17 | --- a/configure.ac | ||
18 | +++ b/configure.ac | ||
19 | @@ -418,7 +418,6 @@ for dir in "" /usr/local $SEARCH_DIR; do | ||
20 | AC_CHECK_LIB([id3tag -lz], [id3_file_open], [LIBID3TAG_LIBS="-lid3tag -lz"], [unset ac_cv_lib_id3tag_id3_file_open; LDFLAGS="$LDFLAGS_SAVE"; continue]) | ||
21 | break | ||
22 | done | ||
23 | -test x"$ac_cv_lib_id3tag__lz___id3_file_open" = x"yes" || AC_MSG_ERROR([Could not find libid3tag]) | ||
24 | AC_SUBST(LIBID3TAG_LIBS) | ||
25 | |||
26 | LDFLAGS_SAVE="$LDFLAGS" | ||
27 | @@ -444,10 +443,6 @@ for dir in "" /usr/local $SEARCH_DIR; do | ||
28 | [unset ac_cv_lib_avformat_av_open_input_file; unset ac_cv_lib_avformat_avformat_open_input; LDFLAGS="$LDFLAGS_SAVE"; continue])]) | ||
29 | break | ||
30 | done | ||
31 | -if test x"$ac_cv_lib_avformat__lavcodec__lavutil__lz___av_open_input_file" != x"yes" && | ||
32 | - test x"$ac_cv_lib_avformat__lavcodec__lavutil__lz___avformat_open_input" != x"yes"; then | ||
33 | - AC_MSG_ERROR([Could not find libavformat - part of ffmpeg]) | ||
34 | -fi | ||
35 | AC_SUBST(LIBAVFORMAT_LIBS) | ||
36 | |||
37 | AC_CHECK_LIB(pthread, pthread_create) | ||
diff --git a/meta-multimedia/recipes-multimedia/minidlna/minidlna_1.2.1.bb b/meta-multimedia/recipes-multimedia/minidlna/minidlna_1.3.0.bb index 999d85ce7..4238918c9 100644 --- a/meta-multimedia/recipes-multimedia/minidlna/minidlna_1.2.1.bb +++ b/meta-multimedia/recipes-multimedia/minidlna/minidlna_1.3.0.bb | |||
@@ -1,4 +1,4 @@ | |||
1 | require ${BPN}.inc | 1 | require ${BPN}.inc |
2 | 2 | ||
3 | SRCREV = "c760a338e07ebd11d62fef701e3de824a91f8625" | 3 | SRCREV = "109d63cb11ac207c18a784556834eb054b34b00b" |
4 | LIC_FILES_CHKSUM = "file://LICENCE.miniupnpd;md5=b0dabf9d8e0f871554e309d62ead8d2b" | 4 | LIC_FILES_CHKSUM = "file://LICENCE.miniupnpd;md5=b0dabf9d8e0f871554e309d62ead8d2b" |