diff options
Diffstat (limited to 'meta-multimedia/recipes-multimedia')
-rw-r--r-- | meta-multimedia/recipes-multimedia/faac/faac_1.28.bb | 5 | ||||
-rw-r--r-- | meta-multimedia/recipes-multimedia/faac/files/address-gcc-6-narrowing-errors.patch | 47 |
2 files changed, 50 insertions, 2 deletions
diff --git a/meta-multimedia/recipes-multimedia/faac/faac_1.28.bb b/meta-multimedia/recipes-multimedia/faac/faac_1.28.bb index d96c1a401..2f048af0e 100644 --- a/meta-multimedia/recipes-multimedia/faac/faac_1.28.bb +++ b/meta-multimedia/recipes-multimedia/faac/faac_1.28.bb | |||
@@ -7,7 +7,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \ | |||
7 | inherit autotools-brokensep | 7 | inherit autotools-brokensep |
8 | 8 | ||
9 | SRC_URI = "${SOURCEFORGE_MIRROR}/faac/${BP}.tar.gz \ | 9 | SRC_URI = "${SOURCEFORGE_MIRROR}/faac/${BP}.tar.gz \ |
10 | file://build-fix.patch" | 10 | file://build-fix.patch \ |
11 | file://address-gcc-6-narrowing-errors.patch \ | ||
12 | " | ||
11 | 13 | ||
12 | SRC_URI[md5sum] = "80763728d392c7d789cde25614c878f6" | 14 | SRC_URI[md5sum] = "80763728d392c7d789cde25614c878f6" |
13 | SRC_URI[sha256sum] = "c5141199f4cfb17d749c36ba8cfe4b25f838da67c22f0fec40228b6b9c3d19df" | 15 | SRC_URI[sha256sum] = "c5141199f4cfb17d749c36ba8cfe4b25f838da67c22f0fec40228b6b9c3d19df" |
@@ -18,4 +20,3 @@ FILES_${PN} = " ${bindir}/faac " | |||
18 | FILES_lib${PN} = " ${libdir}/libfaac.so.*" | 20 | FILES_lib${PN} = " ${libdir}/libfaac.so.*" |
19 | FILES_lib${PN}-dev = "${includedir}/faac.h ${includedir}/faaccfg.h ${libdir}/libfaac.so ${libdir}/libfaac.la" | 21 | FILES_lib${PN}-dev = "${includedir}/faac.h ${includedir}/faaccfg.h ${libdir}/libfaac.so ${libdir}/libfaac.la" |
20 | FILES_lib${PN}-staticdev = "${libdir}/libfaac.a" | 22 | FILES_lib${PN}-staticdev = "${libdir}/libfaac.a" |
21 | |||
diff --git a/meta-multimedia/recipes-multimedia/faac/files/address-gcc-6-narrowing-errors.patch b/meta-multimedia/recipes-multimedia/faac/files/address-gcc-6-narrowing-errors.patch new file mode 100644 index 000000000..92fdd9bab --- /dev/null +++ b/meta-multimedia/recipes-multimedia/faac/files/address-gcc-6-narrowing-errors.patch | |||
@@ -0,0 +1,47 @@ | |||
1 | --- faac-1.28/common/mp4v2/atom_standard.cpp.orig 2016-06-16 07:59:21.657040761 -0400 | ||
2 | +++ faac-1.28/common/mp4v2/atom_standard.cpp 2016-06-16 08:01:50.613036724 -0400 | ||
3 | @@ -22,15 +22,15 @@ | ||
4 | #include "mp4common.h" | ||
5 | #include "atoms.h" | ||
6 | |||
7 | -static const char name[5]={0251,'n', 'a', 'm', '\0'}; | ||
8 | -static const char art[5]={0251,'A', 'R', 'T', '\0'}; | ||
9 | -static const char wrt[5]={0251,'w', 'r', 't', '\0'}; | ||
10 | -static const char alb[5]={0251,'a', 'l', 'b', '\0'}; | ||
11 | -static const char day[5]={0251,'d', 'a', 'y', '\0'}; | ||
12 | -static const char too[5]={0251,'t', 'o', 'o', '\0'}; | ||
13 | -static const char cmt[5]={0251,'c', 'm', 't', '\0'}; | ||
14 | -static const char gen[5]={0251,'g', 'e', 'n', '\0'}; | ||
15 | -static const char grp[5]={0251,'g', 'r', 'p', '\0'}; | ||
16 | +static const char name[5]={(char)0251,'n', 'a', 'm', '\0'}; | ||
17 | +static const char art[5]={(char)0251,'A', 'R', 'T', '\0'}; | ||
18 | +static const char wrt[5]={(char)0251,'w', 'r', 't', '\0'}; | ||
19 | +static const char alb[5]={(char)0251,'a', 'l', 'b', '\0'}; | ||
20 | +static const char day[5]={(char)0251,'d', 'a', 'y', '\0'}; | ||
21 | +static const char too[5]={(char)0251,'t', 'o', 'o', '\0'}; | ||
22 | +static const char cmt[5]={(char)0251,'c', 'm', 't', '\0'}; | ||
23 | +static const char gen[5]={(char)0251,'g', 'e', 'n', '\0'}; | ||
24 | +static const char grp[5]={(char)0251,'g', 'r', 'p', '\0'}; | ||
25 | |||
26 | MP4StandardAtom::MP4StandardAtom (const char *type) : MP4Atom(type) | ||
27 | { | ||
28 | --- faac-1.28/common/mp4v2/mp4atom.cpp.orig 2016-06-16 08:03:07.777034633 -0400 | ||
29 | +++ faac-1.28/common/mp4v2/mp4atom.cpp 2016-06-16 08:03:54.629033363 -0400 | ||
30 | @@ -264,11 +264,11 @@ | ||
31 | } | ||
32 | break; | ||
33 | case 0251: | ||
34 | - static const char name[5]={0251,'n', 'a', 'm', '\0'}; | ||
35 | - static const char cmt[5]={0251,'c', 'm', 't', '\0'}; | ||
36 | - static const char cpy[5]={0251,'c', 'p', 'y', '\0'}; | ||
37 | - static const char des[5]={0251,'d', 'e', 's','\0'}; | ||
38 | - static const char prd[5]={0251, 'p', 'r', 'd', '\0'}; | ||
39 | + static const char name[5]={(char)0251,'n', 'a', 'm', '\0'}; | ||
40 | + static const char cmt[5]={(char)0251,'c', 'm', 't', '\0'}; | ||
41 | + static const char cpy[5]={(char)0251,'c', 'p', 'y', '\0'}; | ||
42 | + static const char des[5]={(char)0251,'d', 'e', 's','\0'}; | ||
43 | + static const char prd[5]={(char)0251, 'p', 'r', 'd', '\0'}; | ||
44 | if (ATOMID(type) == ATOMID(name) || | ||
45 | ATOMID(type) == ATOMID(cmt) || | ||
46 | ATOMID(type) == ATOMID(cpy) || | ||
47 | |||