summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-multimedia/gstreamer-1.0
diff options
context:
space:
mode:
Diffstat (limited to 'meta-multimedia/recipes-multimedia/gstreamer-1.0')
-rw-r--r--meta-multimedia/recipes-multimedia/gstreamer-1.0/gst-shark_0.2.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/gstreamer-1.0/gst-shark_0.2.1.bb b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gst-shark_0.2.1.bb
new file mode 100644
index 000000000..5409f3204
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gst-shark_0.2.1.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Gst-Shark Tracers"
2DESCRIPTION = "Benchmarks and profiling tools for GStreamer"
3HOMEPAGE = "https://developer.ridgerun.com/wiki/index.php?title=GstShark"
4SECTION = "multimedia"
5LICENSE = "GPLv2+"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=e1caa368743492879002ad032445fa97"
8
9DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad "
10
11SRCBRANCH ?= "master"
12
13SRCREV_base = "a60b3996fe3376d42334fc89014e9d6f6af62899"
14SRCREV_common = "b64f03f6090245624608beb5d2fff335e23a01c0"
15
16SRC_URI = " \
17 git://github.com/RidgeRun/gst-shark.git;protocol=https;branch=${SRCBRANCH};name=base \
18 git://anongit.freedesktop.org/git/gstreamer/common.git;protocol=https;destsuffix=git/common;name=common; \
19 "
20
21S = "${WORKDIR}/git"
22
23PACKAGECONFIG_CONFARGS = " \
24 --disable-graphviz \
25 --enable-gtk-doc=no \
26"
27
28FILES_${PN} += "\
29 ${libdir}/gstreamer-1.0/libgstsharktracers.so \
30 ${libdir}/gstreamer-1.0/libgstsharktracers.la \
31"
32
33inherit autotools gettext
34
35do_configure() {
36 ${S}/autogen.sh --noconfigure
37 oe_runconf
38}