summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins.inc')
-rw-r--r--meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins.inc29
1 files changed, 0 insertions, 29 deletions
diff --git a/meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins.inc b/meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins.inc
deleted file mode 100644
index 6e163a8c4..000000000
--- a/meta-multimedia/recipes-multimedia/gstreamer-0.10/gst-plugins.inc
+++ /dev/null
@@ -1,29 +0,0 @@
1SUMMARY = "Plugins for the GStreamer multimedia framework"
2HOMEPAGE = "http://gstreamer.freedesktop.org/"
3BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer"
4SECTION = "multimedia"
5DEPENDS = "gstreamer"
6
7# gobject-introspection to get --disable-introspection into UNKNOWN_CONFIGURE_WHITELIST
8inherit autotools pkgconfig gobject-introspection
9
10SRC_URI = "http://gstreamer.freedesktop.org/src/${BPN}/${BPN}-${PV}.tar.bz2"
11
12GSTREAMER_DEBUG ?= "--disable-debug"
13EXTRA_OECONF = "--disable-valgrind ${GSTREAMER_DEBUG} --disable-examples --disable-introspection"
14
15acpaths = "-I ${S}/common/m4 -I ${S}/m4"
16
17LIBV = "0.10"
18require recipes-multimedia/gstreamer/gst-plugins-package.inc
19
20PACKAGES_DYNAMIC += "^${PN}-.*"
21
22# apply gstreamer hack after Makefile.in.in in source is replaced by our version from
23# ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in, but before configure is executed
24# http://lists.linuxtogo.org/pipermail/openembedded-core/2012-November/032233.html
25oe_runconf_prepend() {
26 if [ -e ${S}/po/Makefile.in.in ]; then
27 sed -i -e "1a\\" -e 'GETTEXT_PACKAGE = @GETTEXT_PACKAGE@' ${S}/po/Makefile.in.in
28 fi
29}