summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-mkv/libebml/libebml/override-uname.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-multimedia/recipes-mkv/libebml/libebml/override-uname.patch')
-rw-r--r--meta-multimedia/recipes-mkv/libebml/libebml/override-uname.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-mkv/libebml/libebml/override-uname.patch b/meta-multimedia/recipes-mkv/libebml/libebml/override-uname.patch
new file mode 100644
index 000000000..57eb3450d
--- /dev/null
+++ b/meta-multimedia/recipes-mkv/libebml/libebml/override-uname.patch
@@ -0,0 +1,42 @@
1Allow override of the 'uname -s' for cross-compilation
2
3Signed-off-by: Christopher Larson <chris_larson@mentor.com>
4Upstream-Status: Pending
5
6diff --git a/make/linux/Makefile b/make/linux/Makefile
7index a2ac13e..4188bee 100644
8--- a/make/linux/Makefile
9+++ b/make/linux/Makefile
10@@ -9,9 +9,11 @@
11 # 'make DEBUG=yes'.
12 #
13
14+TARGET_OS ?= $(shell uname -s)
15+
16 # Paths
17 # BeOS wants the libs and headers in /boot/home/config
18-ifeq (BeOS,$(shell uname -s))
19+ifeq (BeOS,$(TARGET_OS))
20 prefix=/boot/home/config
21 else
22 prefix=/usr/local
23@@ -66,7 +68,7 @@ COMPILEFLAGS=$(WARNINGFLAGS) $(CXXFLAGS) $(CPPFLAGS) $(DEBUGFLAGS) $(INCLUDE)
24 DEPENDFLAGS = $(CXXFLAGS) $(INCLUDE)
25 LINKFLAGS=$(LDFLAGS)
26
27-ifeq (Darwin,$(shell uname -s))
28+ifeq (Darwin,$(TARGET_OS))
29 all: staticlib
30 else
31 all: staticlib sharedlib
32@@ -116,7 +118,7 @@ depend:
33 $(CXX) $(DEPENDFLAGS) -MM -MT $$o $$i >> .depend ; \
34 done
35
36-ifeq (Darwin,$(shell uname -s))
37+ifeq (Darwin,$(TARGET_OS))
38 install: install_staticlib install_headers
39 else
40 install: install_staticlib install_sharedlib install_headers
41--
422.8.0