summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-mkv/libebml/libebml/ldflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-multimedia/recipes-mkv/libebml/libebml/ldflags.patch')
-rw-r--r--meta-multimedia/recipes-mkv/libebml/libebml/ldflags.patch57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-mkv/libebml/libebml/ldflags.patch b/meta-multimedia/recipes-mkv/libebml/libebml/ldflags.patch
new file mode 100644
index 000000000..a01c7544b
--- /dev/null
+++ b/meta-multimedia/recipes-mkv/libebml/libebml/ldflags.patch
@@ -0,0 +1,57 @@
1Use LD and obey LDFLAGS
2
3Signed-off-by: Christopher Larson <chris_larson@mentor.com>
4Upstream-Status: Pending
5
6diff --git a/make/linux/Makefile b/make/linux/Makefile
7index 391b6e3..a2ac13e 100644
8--- a/make/linux/Makefile
9+++ b/make/linux/Makefile
10@@ -64,6 +64,7 @@ objects_so:=$(patsubst %$(EXTENSION),%.lo,$(sources))
11 WARNINGFLAGS=-Wall -Wextra -Wno-unknown-pragmas -ansi -fno-gnu-keywords -Wshadow
12 COMPILEFLAGS=$(WARNINGFLAGS) $(CXXFLAGS) $(CPPFLAGS) $(DEBUGFLAGS) $(INCLUDE)
13 DEPENDFLAGS = $(CXXFLAGS) $(INCLUDE)
14+LINKFLAGS=$(LDFLAGS)
15
16 ifeq (Darwin,$(shell uname -s))
17 all: staticlib
18@@ -91,7 +92,7 @@ $(LIBRARY): $(objects)
19 $(RANLIB) $@
20
21 $(LIBRARY_SO): $(objects_so)
22- $(CXX) -shared -Wl,-soname,$(LIBRARY_SO_VER) -o $(LIBRARY_SO_VER) $(objects_so)
23+ $(LD) $(LINKFLAGS) -shared -Wl,-soname,$(LIBRARY_SO_VER) -o $(LIBRARY_SO_VER) $(objects_so)
24 rm -f $(LIBRARY_SO)
25 ln -s $(LIBRARY_SO_VER) $(LIBRARY_SO)
26
27diff --git a/make/mingw32/Makefile b/make/mingw32/Makefile
28index e5986ef..6ca16aa 100644
29--- a/make/mingw32/Makefile
30+++ b/make/mingw32/Makefile
31@@ -18,6 +18,7 @@ DEBUGFLAGS=-g -DDEBUG
32 endif
33 CROSS =
34 CXX = $(CROSS)g++
35+LD = $(CXX)
36 CC = $(CROSS)gcc
37 WINDRES = $(CROSS)windres
38 RANLIB = $(CROSS)ranlib
39@@ -33,6 +34,7 @@ LIBS = libebml.a
40 endif
41 INCS = -I"$(shell pwd)/../.."
42 COMPILEFLAGS = $(DEBUGFLAGS) $(INCS) $(DLLFLAGS) $(CXXFLAGS)
43+LINKFLAGS = $(LDFLAGS)
44
45 .PHONY: all all-before all-after clean clean-custom
46
47@@ -54,7 +56,7 @@ libebml.a: $(OBJ)
48 $(RANLIB) $@
49
50 libebml.dll: $(OBJ)
51- $(CXX) -shared -Wl,--export-all -Wl,--out-implib=$@.a -o $@ $(OBJ)
52+ $(LD) $(LINKFLAGS) -shared -Wl,--export-all -Wl,--out-implib=$@.a -o $@ $(OBJ)
53
54 depend:
55 @echo Calculating dependecies:
56--
572.8.0