summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-mediacenter/kodi/kodi-addon-pvr-hts_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-multimedia/recipes-mediacenter/kodi/kodi-addon-pvr-hts_git.bb')
-rw-r--r--meta-multimedia/recipes-mediacenter/kodi/kodi-addon-pvr-hts_git.bb57
1 files changed, 0 insertions, 57 deletions
diff --git a/meta-multimedia/recipes-mediacenter/kodi/kodi-addon-pvr-hts_git.bb b/meta-multimedia/recipes-mediacenter/kodi/kodi-addon-pvr-hts_git.bb
deleted file mode 100644
index 7cafebfa2..000000000
--- a/meta-multimedia/recipes-mediacenter/kodi/kodi-addon-pvr-hts_git.bb
+++ /dev/null
@@ -1,57 +0,0 @@
1SUMMARY = "Kodi Media Center PVR plugins"
2
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://src/client.cpp;md5=c8f6b73c5bc1048a3d6506700a7a91d2"
5
6DEPENDS = " \
7 zip-native \
8 p8platform \
9 kodi-platform \
10 "
11
12SRCREV_pvrhts = "7f75b70527922aef953123ff97ebaa22d9fb7cb4"
13
14SRCREV_FORMAT = "pvrhts"
15
16PV = "2.2.13+gitr${SRCPV}"
17SRC_URI = "git://github.com/kodi-pvr/pvr.hts.git;branch=Jarvis;destsuffix=pvr.hts;name=pvrhts \
18 file://0001-Update-to-p8-platform.patch \
19 "
20
21inherit cmake pkgconfig gettext
22
23S = "${WORKDIR}/pvr.hts"
24
25EXTRA_OECMAKE = " \
26 -DADDONS_TO_BUILD=pvr.hts \
27 -DADDON_SRC_PREFIX=${WORKDIR}/git \
28 -DCMAKE_BUILD_TYPE=Debug \
29 -DCMAKE_INSTALL_PREFIX=${datadir}/kodi/addons \
30 -DCMAKE_MODULE_PATH=${STAGING_DIR_HOST}${libdir}/kodi \
31 -DCMAKE_PREFIX_PATH=${STAGING_DIR_HOST}${prefix} \
32 -DPACKAGE_ZIP=1 \
33 "
34
35do_compile_prepend() {
36 sed -i -e 's:I/usr/include:I${STAGING_INCDIR}:g' \
37 -e 's:-pipe:${HOST_CC_ARCH} ${TOOLCHAIN_OPTIONS} -pipe:g' \
38 ${B}/CMakeFiles/*/flags.make
39 sed -i -e 's:-pipe:${HOST_CC_ARCH} ${TOOLCHAIN_OPTIONS} -pipe:g'\
40 ${B}/CMakeFiles/*/link.txt
41}
42
43# Make zip package for manual installation
44do_install_append() {
45 install -d ${D}${datadir}/kodi/addons/packages/
46 ( cd ${D}${datadir}/kodi/addons
47 zip -r ${D}${datadir}/kodi/addons/packages/pvr.hts-${PV}.zip pvr.hts -x '*.debug*' )
48}
49
50# Doesn't get added automagically, dlopen()?
51RDEPENDS_${PN} = "libkodiplatform"
52
53INSANE_SKIP_${PN} = "dev-so"
54FILES_${PN} += "${datadir}/kodi"
55FILES_${PN}-dbg += "${datadir}/kodi/addons/*/.debug/"
56
57PNBLACKLIST[kodi-addon-pvr-hts] ?= "Depends on blacklisted kodi - the recipe will be removed on 2017-09-01 unless the issue is fixed"