summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-dvb/tvheadend
diff options
context:
space:
mode:
Diffstat (limited to 'meta-multimedia/recipes-dvb/tvheadend')
-rw-r--r--meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Fix-checks-for-sse2-mmx.patch40
-rw-r--r--meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Makefile-Ignore-warning-about-wrong-includes.patch31
-rw-r--r--meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-disable-varargs-warning-on-clang.patch32
-rw-r--r--meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-dvr-Use-labs-instead-of-abs.patch37
-rw-r--r--meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-hdhomerun-Override-forced-overrdiing-og-CC-STRIP-and.patch40
-rw-r--r--meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb43
6 files changed, 0 insertions, 223 deletions
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Fix-checks-for-sse2-mmx.patch b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Fix-checks-for-sse2-mmx.patch
deleted file mode 100644
index 3283a5b6a..000000000
--- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Fix-checks-for-sse2-mmx.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From f0dab6d6fe4b0aae4394eee93be86e9747c6ed5c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 22 Nov 2016 05:07:38 +0000
4Subject: [PATCH] Fix checks for sse2/mmx
5
6Just checking for cmdline options is not enough
7its better to check for builtin defines to be
8sure, clang does not error out on sse2 options on
9arm e.g. and it ends up doing SSE2 stuff for arm
10which is not desired
11
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 configure | 10 ++++++++--
15 1 file changed, 8 insertions(+), 2 deletions(-)
16
17diff --git a/configure b/configure
18index 47d2cf2..4be000c 100755
19--- a/configure
20+++ b/configure
21@@ -118,8 +118,14 @@ fi
22 # Valiate compiler
23 check_cc || die 'No C compiler found'
24 check_cc_header execinfo
25-check_cc_option mmx
26-check_cc_option sse2
27+check_cc_snippet mmx '#ifndef __MMX__
28+error "MMX not supported"
29+#endif
30+'
31+check_cc_snippet sse2 '#ifndef __SSE2__
32+error "SSE2 not supported"
33+#endif
34+'
35
36 if check_cc '
37 #if !defined(__clang__)
38--
391.9.1
40
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Makefile-Ignore-warning-about-wrong-includes.patch b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Makefile-Ignore-warning-about-wrong-includes.patch
deleted file mode 100644
index 248a5e6a8..000000000
--- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-Makefile-Ignore-warning-about-wrong-includes.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1From 7d672305c7ad2f716dfe1c487b525a1a92954d4a Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 22 Nov 2016 06:22:36 +0000
4Subject: [PATCH] Makefile: Ignore warning about wrong includes
5
6It happens on musl especially
7usr/include/sys/poll.h:1:2: error: redirecting incorrect #include <sys/poll.h> to <poll.h> [-Werror,-W#warnings]
8| #warning redirecting incorrect #include <sys/poll.h> to <poll.h>
9| ^
10| In file included from src/avahi.c:48:
11
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 Makefile | 1 +
15 1 file changed, 1 insertion(+)
16
17diff --git a/Makefile b/Makefile
18index f41ef1a..cc7b249 100644
19--- a/Makefile
20+++ b/Makefile
21@@ -54,6 +54,7 @@ CFLAGS += -Wno-microsoft -Qunused-arguments -Wno-unused-function
22 CFLAGS += -Wno-unused-value -Wno-tautological-constant-out-of-range-compare
23 CFLAGS += -Wno-parentheses-equality -Wno-incompatible-pointer-types
24 CFLAGS += -Wno-error=varargs
25+CFLAGS += -Wno-error=\#warnings
26 endif
27
28 ifeq ($(CONFIG_LIBFFMPEG_STATIC),yes)
29--
301.8.3.1
31
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-disable-varargs-warning-on-clang.patch b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-disable-varargs-warning-on-clang.patch
deleted file mode 100644
index a4c4c4d0f..000000000
--- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-disable-varargs-warning-on-clang.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From 906d95695af95970bf551ea55b6c3e70332c6b97 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 22 Nov 2016 05:22:32 +0000
4Subject: [PATCH] disable varargs warning on clang
5
6The issue is that 'len' is an unsigned char and we violate the promotion rules
7for passing the value to va_start.
8
9passing an object that undergoes defau
10lt argument promotion to 'va_start' has undefined behavior [-Wvarargs]
11| va_start(ap, len);
12
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 Makefile | 1 +
16 1 file changed, 1 insertion(+)
17
18diff --git a/Makefile b/Makefile
19index 8c5e380..f41ef1a 100644
20--- a/Makefile
21+++ b/Makefile
22@@ -53,6 +53,7 @@ ifeq ($(COMPILER), clang)
23 CFLAGS += -Wno-microsoft -Qunused-arguments -Wno-unused-function
24 CFLAGS += -Wno-unused-value -Wno-tautological-constant-out-of-range-compare
25 CFLAGS += -Wno-parentheses-equality -Wno-incompatible-pointer-types
26+CFLAGS += -Wno-error=varargs
27 endif
28
29 ifeq ($(CONFIG_LIBFFMPEG_STATIC),yes)
30--
311.9.1
32
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-dvr-Use-labs-instead-of-abs.patch b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-dvr-Use-labs-instead-of-abs.patch
deleted file mode 100644
index ea34cdb62..000000000
--- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-dvr-Use-labs-instead-of-abs.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1From a715671eadcbf989fdaf05f62e71b93ac1749615 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 22 Nov 2016 06:08:31 +0000
4Subject: [PATCH] dvr: Use labs() instead of abs()
5
6Makes clang happy
7
8dvr/dvr_db.c:853:10: error: absolute value function
9'abs' given an argument of type 'long' but has parameter of type 'int' which may cause truncation of value [-Werror,-Wabsolute-value]
10if ((abs(de->de_start - e->start) < 600) && (abs(de->de_stop - e->stop) < 600)) {
11
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 src/dvr/dvr_db.c | 4 ++--
15 1 file changed, 2 insertions(+), 2 deletions(-)
16
17diff --git a/src/dvr/dvr_db.c b/src/dvr/dvr_db.c
18index 165caa6..5656569 100644
19--- a/src/dvr/dvr_db.c
20+++ b/src/dvr/dvr_db.c
21@@ -414,11 +414,11 @@ dvr_entry_fuzzy_match(dvr_entry_t *de, epg_broadcast_t *e)
22 /* Wrong length (+/-20%) */
23 t1 = de->de_stop - de->de_start;
24 t2 = e->stop - e->start;
25- if ( abs(t2 - t1) > (t1 / 5) )
26+ if ( labs(t2 - t1) > (t1 / 5) )
27 return 0;
28
29 /* Outside of window */
30- if (abs(e->start - de->de_start) > de->de_config->dvr_update_window)
31+ if (labs(e->start - de->de_start) > de->de_config->dvr_update_window)
32 return 0;
33
34 /* Title match (or contains?) */
35--
361.9.1
37
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-hdhomerun-Override-forced-overrdiing-og-CC-STRIP-and.patch b/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-hdhomerun-Override-forced-overrdiing-og-CC-STRIP-and.patch
deleted file mode 100644
index 484e723d9..000000000
--- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend/0001-hdhomerun-Override-forced-overrdiing-og-CC-STRIP-and.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From c3767e189e90965407937b6178adbbd8cdafe31d Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 22 Nov 2016 05:59:10 +0000
4Subject: [PATCH] hdhomerun: Override forced overrdiing og CC/STRIP and CFLAGS
5
6This is required for cross compiling otherwise it ends up
7using build host gcc
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 Makefile.hdhomerun | 6 ++++--
12 1 file changed, 4 insertions(+), 2 deletions(-)
13
14diff --git a/Makefile.hdhomerun b/Makefile.hdhomerun
15index 943ffec..8bd14ff 100644
16--- a/Makefile.hdhomerun
17+++ b/Makefile.hdhomerun
18@@ -18,8 +18,8 @@
19
20 include $(dir $(lastword $(MAKEFILE_LIST))).config.mk
21
22-unexport CFLAGS
23-unexport LDFLAGS
24+#unexport CFLAGS
25+#unexport LDFLAGS
26
27 define DOWNLOAD
28 @mkdir -p $(LIBHDHRDIR)/build
29@@ -75,6 +75,8 @@ $(LIBHDHRDIR)/$(LIBHDHR)/.tvh_download:
30 $(call DOWNLOAD,$(LIBHDHR_URL),$(LIBHDHRDIR)/$(LIBHDHR_TB),$(LIBHDHR_SHA1))
31 $(call UNTAR,$(LIBHDHR_TB),z)
32 ln -sf libhdhomerun $(LIBHDHRDIR)/$(LIBHDHR)
33+ @sed -i -e "s/CC.*:=/CC ?=/" $(LIBHDHRDIR)/$(LIBHDHR)/Makefile
34+ @sed -i -e "s/STRIP.*:=/STRIP ?=/" $(LIBHDHRDIR)/$(LIBHDHR)/Makefile
35 @touch $@
36
37 $(LIBHDHRDIR)/$(LIBHDHR)/.tvh_build: \
38--
391.9.1
40
diff --git a/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb b/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb
deleted file mode 100644
index 3b73549d2..000000000
--- a/meta-multimedia/recipes-dvb/tvheadend/tvheadend_git.bb
+++ /dev/null
@@ -1,43 +0,0 @@
1SUMMARY = "Tvheadend TV streaming server"
2HOMEPAGE = "https://www.lonelycoder.com/redmine/projects/tvheadend"
3
4DEPENDS = "avahi zlib openssl python-native dvb-apps"
5
6LICENSE = "GPLv3+"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=9cae5acac2e9ee2fc3aec01ac88ce5db"
8
9SRC_URI = "git://github.com/tvheadend/tvheadend.git;branch=release/4.0 \
10 file://0001-Fix-checks-for-sse2-mmx.patch \
11 file://0001-disable-varargs-warning-on-clang.patch \
12 file://0001-hdhomerun-Override-forced-overrdiing-og-CC-STRIP-and.patch \
13 file://0001-dvr-Use-labs-instead-of-abs.patch \
14 file://0001-Makefile-Ignore-warning-about-wrong-includes.patch \
15"
16SRCREV = "64fec8120158de585e18be705055259484518d94"
17PV = "4.0.9+git${SRCREV}"
18
19S = "${WORKDIR}/git"
20
21PACKAGECONFIG ?= ""
22PACKAGECONFIG[uriparser] = "--enable-uriparser,--disable-uriparser,uriparser"
23
24do_configure() {
25 ./configure ${PACKAGECONFIG_CONFARGS} \
26 --prefix=${prefix} \
27 --libdir=${libdir} \
28 --bindir=${bindir} \
29 --datadir=${datadir} \
30 --arch=${TARGET_ARCH} \
31 --disable-dvbscan \
32 --disable-bundle
33}
34
35do_install() {
36 oe_runmake install DESTDIR=${D}
37}
38
39FILES_${PN} += "${datadir}/${BPN}"
40
41RDEPENDS_${PN} += "libdvben50221 libucsi libdvbapi"
42
43PNBLACKLIST[tvheadend] ?= "Depends on blacklisted dvb-apps - the recipe will be removed on 2017-09-01 unless the issue is fixed"