summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-dvb/dvb-apps
diff options
context:
space:
mode:
Diffstat (limited to 'meta-multimedia/recipes-dvb/dvb-apps')
-rw-r--r--meta-multimedia/recipes-dvb/dvb-apps/dvb-apps_1.1.1.bb26
1 files changed, 22 insertions, 4 deletions
diff --git a/meta-multimedia/recipes-dvb/dvb-apps/dvb-apps_1.1.1.bb b/meta-multimedia/recipes-dvb/dvb-apps/dvb-apps_1.1.1.bb
index d9ee4391c..0b4b72dda 100644
--- a/meta-multimedia/recipes-dvb/dvb-apps/dvb-apps_1.1.1.bb
+++ b/meta-multimedia/recipes-dvb/dvb-apps/dvb-apps_1.1.1.bb
@@ -4,20 +4,38 @@ SUMMARY = "Linux DVB API applications and utilities"
4LICENSE = "GPLv2" 4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" 5LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
6 6
7SRC_URI = "hg://linuxtv.org/hg;module=dvb-apps;protocol=http" 7DEPENDS = "v4l-utils-native"
8SRCREV = "3fc7dfa68484" 8
9SRC_URI = " \
10 hg://linuxtv.org/hg;module=dvb-apps;protocol=http;name=apps \
11 git://linuxtv.org/git/dtv-scan-tables.git;protocol=http;destsuffix=dvb-apps/initial-scan-tables;name=scantables \
12 "
13SRCREV_apps = "3d43b280298c"
14SRCREV_scantables = "ceb11833b35f05813b1f0397a60e0f3b99430aab"
15SRCREV_FORMAT = "apps_scantables"
9 16
10S = "${WORKDIR}/${BPN}" 17S = "${WORKDIR}/${BPN}"
11 18
19TARGET_CC_ARCH += "${LDFLAGS}"
20EXTRA_OEMAKE = "VERSION_FILE='${STAGING_INCDIR}/linux/dvb/version.h'"
21
12do_configure() { 22do_configure() {
13 sed -i -e s:/usr/include:${STAGING_INCDIR}:g util/av7110_loadkeys/generate-keynames.sh 23 sed -i -e s:/usr/include:${STAGING_INCDIR}:g util/av7110_loadkeys/generate-keynames.sh
14} 24}
15 25
26do_compile_append() {
27# dvb-apps only support DVBAPI v3, so generate them from the DVBAPI v5 downloaded files
28 make -C initial-scan-tables clean
29 make -C initial-scan-tables dvbv3
30}
31
16do_install() { 32do_install() {
17 make DESTDIR=${D} install 33 make DESTDIR=${D} install
34# dvb-apps only support DVBAPI v3, so only install the generated DVBAPI v3 files
35 make -C initial-scan-tables DATADIR=${D}/${datadir} DVBV3DIR=dvb install_v3
36
18 install -d ${D}/${bindir} 37 install -d ${D}/${bindir}
19 install -d ${D}/${docdir}/dvb-apps 38 install -d ${D}/${docdir}/dvb-apps
20 install -d ${D}/${docdir}/dvb-apps/scan
21 install -d ${D}/${docdir}/dvb-apps/szap 39 install -d ${D}/${docdir}/dvb-apps/szap
22 chmod a+rx ${D}/${libdir}/*.so* 40 chmod a+rx ${D}/${libdir}/*.so*
23 41
@@ -89,7 +107,7 @@ FILES_dvbnet-dbg = "${bindir}/.debug/dvbnet"
89 107
90FILES_dvb-scan = "${bindir}/*scan " 108FILES_dvb-scan = "${bindir}/*scan "
91FILES_dvb-scan-dbg = "${bindir}/.debug/*scan" 109FILES_dvb-scan-dbg = "${bindir}/.debug/*scan"
92FILES_dvb-scan-data = "${docdir}/dvb-apps/scan" 110FILES_dvb-scan-data = "${datadir}/dvb"
93 111
94FILES_dvb-azap = "${bindir}/azap" 112FILES_dvb-azap = "${bindir}/azap"
95FILES_dvb-azap-dbg = "${bindir}/.debug/azap" 113FILES_dvb-azap-dbg = "${bindir}/.debug/azap"