summaryrefslogtreecommitdiffstats
path: root/meta-initramfs
diff options
context:
space:
mode:
Diffstat (limited to 'meta-initramfs')
-rw-r--r--meta-initramfs/recipes-kernel/linux/linux-yocto-tiny-kexecboot/revert-check-console.patch47
-rw-r--r--meta-initramfs/recipes-kernel/linux/linux-yocto-tiny-kexecboot_4.4.bb29
2 files changed, 0 insertions, 76 deletions
diff --git a/meta-initramfs/recipes-kernel/linux/linux-yocto-tiny-kexecboot/revert-check-console.patch b/meta-initramfs/recipes-kernel/linux/linux-yocto-tiny-kexecboot/revert-check-console.patch
deleted file mode 100644
index 5e5e8d9f9..000000000
--- a/meta-initramfs/recipes-kernel/linux/linux-yocto-tiny-kexecboot/revert-check-console.patch
+++ /dev/null
@@ -1,47 +0,0 @@
1From a74e0bf51adcc867b73fc44050eb9bde985c9cba Mon Sep 17 00:00:00 2001
2From: Andrea Adami <andrea.adami@gmail.com>
3Date: Sun, 28 Feb 2016 01:09:19 +0100
4Subject: [PATCH] main.c: revert check on console device
5
6Fix kernel panic because of the missing /dev/console.
7
8Revert Yocto-specific : "check console device file on fs when booting".
9
10The initramfs used in this kernel needs to be of the smallest possible
11size so we save a few kb by deploying an empty /dev which is populated
12after boot by the init (kexecboot checks and recreates the devices
13with or without devtmpfs).
14
15Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
16---
17 init/main.c | 7 -------
18 1 file changed, 7 deletions(-)
19
20diff --git a/init/main.c b/init/main.c
21index d191d2a..9e64d70 100644
22--- a/init/main.c
23+++ b/init/main.c
24@@ -976,7 +976,6 @@ static int __ref kernel_init(void *unused)
25
26 static noinline void __init kernel_init_freeable(void)
27 {
28- struct stat console_stat;
29 /*
30 * Wait until kthreadd is all set-up.
31 */
32@@ -1008,12 +1007,6 @@ static noinline void __init kernel_init_freeable(void)
33
34 do_basic_setup();
35
36- /* Use /dev/console to infer if the rootfs is setup properly */
37- if (sys_newlstat((char __user *) "/dev/console", (struct stat __user *) &console_stat)
38- || !S_ISCHR(console_stat.st_mode)) {
39- panic("/dev/console is missing or not a character device!\nPlease ensure your rootfs is properly configured\n");
40- }
41-
42 /* Open the /dev/console on the rootfs, this should never fail */
43 if (sys_open((const char __user *) "/dev/console", O_RDWR, 0) < 0)
44 pr_err("Warning: unable to open an initial console.\n");
45--
461.9.1
47
diff --git a/meta-initramfs/recipes-kernel/linux/linux-yocto-tiny-kexecboot_4.4.bb b/meta-initramfs/recipes-kernel/linux/linux-yocto-tiny-kexecboot_4.4.bb
deleted file mode 100644
index 66e0e53a1..000000000
--- a/meta-initramfs/recipes-kernel/linux/linux-yocto-tiny-kexecboot_4.4.bb
+++ /dev/null
@@ -1,29 +0,0 @@
1require recipes-kernel/linux/linux-yocto-tiny_${PV}.bb
2SUMMARY = "Yocto tiny kernel embedding a minimalistic kexecboot initramfs"
3
4SRC_URI += "file://revert-check-console.patch"
5
6PACKAGES = ""
7PROVIDES = ""
8
9KERNEL_IMAGE_BASE_NAME = "${KERNEL_IMAGETYPE}-yocto-tiny-kexecboot-${PV}-${MACHINE}"
10KERNEL_IMAGE_SYMLINK_NAME = "${KERNEL_IMAGETYPE}-yocto-tiny-kexecboot-${MACHINE}"
11
12INITRAMFS_IMAGE = "initramfs-kexecboot-klibc-image"
13INITRAMFS_TASK = "${INITRAMFS_IMAGE}:do_image_complete"
14
15# disable unneeded tasks
16do_shared_workdir[noexec] = "1"
17do_install[noexec] = "1"
18do_package[noexec] = "1"
19do_package_qa[noexec] = "1"
20do_packagedata[noexec] = "1"
21do_package_deb[noexec] = "1"
22do_package_ipk[noexec] = "1"
23do_package_rpm[noexec] = "1"
24do_package_tar[noexec] = "1"
25do_package_write_deb[noexec] = "1"
26do_package_write_ipk[noexec] = "1"
27do_package_write_rpm[noexec] = "1"
28do_package_write_tar[noexec] = "1"
29do_populate_sysroot[noexec] = "1"