summaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-kernel/linux/linux-kexecboot_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-initramfs/recipes-kernel/linux/linux-kexecboot_git.bb')
-rw-r--r--meta-initramfs/recipes-kernel/linux/linux-kexecboot_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-kernel/linux/linux-kexecboot_git.bb b/meta-initramfs/recipes-kernel/linux/linux-kexecboot_git.bb
new file mode 100644
index 000000000..b1fc75bb9
--- /dev/null
+++ b/meta-initramfs/recipes-kernel/linux/linux-kexecboot_git.bb
@@ -0,0 +1,23 @@
1require linux-kexecboot.inc
2
3PR = "${INC_PR}.1"
4
5KERNEL_RELEASE = "3.2.0-rc7"
6OLD_KERNEL_RELEASE = "3.1.99"
7PV = "${OLD_KERNEL_RELEASE}+${KERNEL_RELEASE}+gitr${SRCPV}"
8
9SRCREV = "371de6e4e0042adf4f9b54c414154f57414ddd37"
10
11CMDLINE_DEBUG = "debug"
12
13S = "${WORKDIR}/git"
14SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;protocol=git;branch=master"
15
16do_configure_prepend() {
17#otherwise it gets extra '+' "2.6.37+"
18#because:
19#$ scripts/setlocalversion . => +
20#$ make kernelversion => 2.6.37
21#$ make kernelrelease => 2.6.37+
22 rm -rf ${S}/.git
23}