summaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc/kexec-x32.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc/kexec-x32.patch')
-rw-r--r--meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc/kexec-x32.patch46
1 files changed, 26 insertions, 20 deletions
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc/kexec-x32.patch b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc/kexec-x32.patch
index 26d18eb6f..3c2594a5d 100644
--- a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc/kexec-x32.patch
+++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc/kexec-x32.patch
@@ -1,4 +1,10 @@
1x86_64: Add support to build kexec-tools with x32 ABI 1From fd40eee42273220fb0050fe10744b10067adc0a7 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?An=C3=ADbal=20Lim=C3=B3n?= <anibal.limon@linux.intel.com>
3Date: Fri, 31 Aug 2018 17:31:50 +0200
4Subject: [PATCH] x86_64: Add support to build kexec-tools with x32 ABI
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
2 8
3Summary of changes, 9Summary of changes,
4 10
@@ -21,11 +27,11 @@ Signed-off-by: Mariano Lopez <mariano.lopez@linux.intel.com>
21 purgatory/arch/x86_64/Makefile | 4 +++- 27 purgatory/arch/x86_64/Makefile | 4 +++-
22 4 files changed, 20 insertions(+), 1 deletion(-) 28 4 files changed, 20 insertions(+), 1 deletion(-)
23 29
24Index: kexec-tools-2.0.10/configure.ac 30diff --git a/configure.ac b/configure.ac
25=================================================================== 31index e05d601..c428146 100644
26--- kexec-tools-2.0.10.orig/configure.ac 32--- a/configure.ac
27+++ kexec-tools-2.0.10/configure.ac 33+++ b/configure.ac
28@@ -56,6 +56,15 @@ case $target_cpu in 34@@ -54,6 +54,15 @@ case $target_cpu in
29 ;; 35 ;;
30 ia64|x86_64|alpha|m68k ) 36 ia64|x86_64|alpha|m68k )
31 ARCH="$target_cpu" 37 ARCH="$target_cpu"
@@ -41,11 +47,11 @@ Index: kexec-tools-2.0.10/configure.ac
41 ;; 47 ;;
42 * ) 48 * )
43 AC_MSG_ERROR([unsupported architecture $target_cpu]) 49 AC_MSG_ERROR([unsupported architecture $target_cpu])
44Index: kexec-tools-2.0.10/kexec/arch/x86_64/kexec-elf-rel-x86_64.c 50diff --git a/kexec/arch/x86_64/kexec-elf-rel-x86_64.c b/kexec/arch/x86_64/kexec-elf-rel-x86_64.c
45=================================================================== 51index 761a4ed..1c0e3f8 100644
46--- kexec-tools-2.0.10.orig/kexec/arch/x86_64/kexec-elf-rel-x86_64.c 52--- a/kexec/arch/x86_64/kexec-elf-rel-x86_64.c
47+++ kexec-tools-2.0.10/kexec/arch/x86_64/kexec-elf-rel-x86_64.c 53+++ b/kexec/arch/x86_64/kexec-elf-rel-x86_64.c
48@@ -8,7 +8,11 @@ int machine_verify_elf_rel(struct mem_eh 54@@ -8,7 +8,11 @@ int machine_verify_elf_rel(struct mem_ehdr *ehdr)
49 if (ehdr->ei_data != ELFDATA2LSB) { 55 if (ehdr->ei_data != ELFDATA2LSB) {
50 return 0; 56 return 0;
51 } 57 }
@@ -57,10 +63,10 @@ Index: kexec-tools-2.0.10/kexec/arch/x86_64/kexec-elf-rel-x86_64.c
57 return 0; 63 return 0;
58 } 64 }
59 if (ehdr->e_machine != EM_X86_64) { 65 if (ehdr->e_machine != EM_X86_64) {
60Index: kexec-tools-2.0.10/kexec/kexec-syscall.h 66diff --git a/kexec/kexec-syscall.h b/kexec/kexec-syscall.h
61=================================================================== 67index 2a3794d..3e67078 100644
62--- kexec-tools-2.0.10.orig/kexec/kexec-syscall.h 68--- a/kexec/kexec-syscall.h
63+++ kexec-tools-2.0.10/kexec/kexec-syscall.h 69+++ b/kexec/kexec-syscall.h
64@@ -31,8 +31,12 @@ 70@@ -31,8 +31,12 @@
65 #define __NR_kexec_load 268 71 #define __NR_kexec_load 268
66 #endif 72 #endif
@@ -74,11 +80,11 @@ Index: kexec-tools-2.0.10/kexec/kexec-syscall.h
74 #ifdef __s390x__ 80 #ifdef __s390x__
75 #define __NR_kexec_load 277 81 #define __NR_kexec_load 277
76 #endif 82 #endif
77Index: kexec-tools-2.0.10/purgatory/arch/x86_64/Makefile 83diff --git a/purgatory/arch/x86_64/Makefile b/purgatory/arch/x86_64/Makefile
78=================================================================== 84index 7300937..4af11e4 100644
79--- kexec-tools-2.0.10.orig/purgatory/arch/x86_64/Makefile 85--- a/purgatory/arch/x86_64/Makefile
80+++ kexec-tools-2.0.10/purgatory/arch/x86_64/Makefile 86+++ b/purgatory/arch/x86_64/Makefile
81@@ -23,4 +23,6 @@ x86_64_PURGATORY_SRCS += purgatory/arch/ 87@@ -23,4 +23,6 @@ x86_64_PURGATORY_SRCS += purgatory/arch/i386/console-x86.c
82 x86_64_PURGATORY_SRCS += purgatory/arch/i386/vga.c 88 x86_64_PURGATORY_SRCS += purgatory/arch/i386/vga.c
83 x86_64_PURGATORY_SRCS += purgatory/arch/i386/pic.c 89 x86_64_PURGATORY_SRCS += purgatory/arch/i386/pic.c
84 90