summaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc/0011-purgatory-Makefile-adapt-to-klcc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc/0011-purgatory-Makefile-adapt-to-klcc.patch')
-rw-r--r--meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc/0011-purgatory-Makefile-adapt-to-klcc.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc/0011-purgatory-Makefile-adapt-to-klcc.patch b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc/0011-purgatory-Makefile-adapt-to-klcc.patch
new file mode 100644
index 000000000..0ae2be77d
--- /dev/null
+++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc/0011-purgatory-Makefile-adapt-to-klcc.patch
@@ -0,0 +1,43 @@
1From fa3844ce6ce95f2db142b6c77f077b3e704d4f6f Mon Sep 17 00:00:00 2001
2From: Andrea Adami <andrea.adami@gmail.com>
3Date: Tue, 17 Apr 2018 19:12:14 +0200
4Subject: [PATCH] purgatory Makefile: adapt to klcc
5
6Upstream-Status: Inappropriate [klibc specific]
7Signed-off-by: Andrea Adami <andrea.adami@gmail.com>
8
9---
10 purgatory/Makefile | 9 +++++----
11 1 file changed, 5 insertions(+), 4 deletions(-)
12
13diff --git a/purgatory/Makefile b/purgatory/Makefile
14index 49ce80a..da36075 100644
15--- a/purgatory/Makefile
16+++ b/purgatory/Makefile
17@@ -47,7 +47,7 @@ purgatory/sha256.o: $(srcdir)/util_lib/sha256.c
18 $(PURGATORY): CC=$(TARGET_CC)
19 $(PURGATORY): CFLAGS+=$(PURGATORY_EXTRA_CFLAGS) \
20 $($(ARCH)_PURGATORY_EXTRA_CFLAGS) \
21- -Os -fno-builtin -ffreestanding \
22+ -Os -fno-builtin -ffreestanding -nostdinc \
23 -fno-zero-initialized-in-bss \
24 -fno-PIC -fno-PIE -fno-stack-protector
25
26@@ -59,13 +59,14 @@ $(PURGATORY): CPPFLAGS=$($(ARCH)_PURGATORY_EXTRA_CFLAGS) \
27 -Iinclude \
28 -I$(shell $(CC) -print-file-name=include)
29 $(PURGATORY): LDFLAGS=$($(ARCH)_PURGATORY_EXTRA_CFLAGS)\
30- -Wl,--no-undefined -nostartfiles -nostdlib \
31+ --no-undefined -nostartfiles -nostdlib \
32 -nodefaultlibs -e purgatory_start -r \
33- -Wl,-Map=$(PURGATORY_MAP)
34+ -Map=$(PURGATORY_MAP)
35
36 $(PURGATORY): $(PURGATORY_OBJS)
37 $(MKDIR) -p $(@D)
38- $(CC) $(CFLAGS) $(LDFLAGS) -o $@.sym $^
39+# $(CC) $(CFLAGS) -o $@.sym $^
40+ $(LD) $(LDFLAGS) -o $@.sym $^
41 # $(LD) $(LDFLAGS) $(EXTRA_LDFLAGS) --no-undefined -e purgatory_start -r -o $@ $(PURGATORY_OBJS) $(UTIL_LIB)
42 $(STRIP) --strip-debug -o $@ $@.sym
43