diff options
Diffstat (limited to 'meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/fix-out-of-tree-build.patch')
-rw-r--r-- | meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/fix-out-of-tree-build.patch | 54 |
1 files changed, 54 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/fix-out-of-tree-build.patch b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/fix-out-of-tree-build.patch new file mode 100644 index 000000000..ccbb24d0d --- /dev/null +++ b/meta-initramfs/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/fix-out-of-tree-build.patch | |||
@@ -0,0 +1,54 @@ | |||
1 | From 37737527725e465833be649101c4a6f8352c5d5e Mon Sep 17 00:00:00 2001 | ||
2 | From: Tyler Hall <tylerwhall@gmail.com> | ||
3 | Date: Tue, 7 Feb 2012 18:50:05 -0500 | ||
4 | Subject: Fix out-of-tree build | ||
5 | |||
6 | Use automatic variables for prerequisites when copying man pages and | ||
7 | include a makefile relative to $(srcdir). | ||
8 | |||
9 | Backported to 2.0.2-klibc | ||
10 | |||
11 | Signed-off-by: Tyler Hall <tylerwhall@gmail.com> | ||
12 | Signed-off-by: Simon Horman <horms@verge.net.au> | ||
13 | |||
14 | diff --git a/kdump/Makefile b/kdump/Makefile | ||
15 | index 1e2b72c..5dfa928 100644 | ||
16 | --- a/kdump/Makefile | ||
17 | +++ b/kdump/Makefile | ||
18 | @@ -22,7 +22,7 @@ $(KDUMP): $(KDUMP_OBJS) | ||
19 | |||
20 | $(KDUMP_MANPAGE): kdump/kdump.8 | ||
21 | $(MKDIR) -p $(MANDIR)/man8 | ||
22 | - cp kdump/kdump.8 $(KDUMP_MANPAGE) | ||
23 | + cp $^ $(KDUMP_MANPAGE) | ||
24 | echo:: | ||
25 | @echo "KDUMP_SRCS $(KDUMP_SRCS)" | ||
26 | @echo "KDUMP_DEPS $(KDUMP_DEPS)" | ||
27 | diff --git a/kexec/Makefile b/kexec/Makefile | ||
28 | index 2137cab..8c815b5 100644 | ||
29 | --- a/kexec/Makefile | ||
30 | +++ b/kexec/Makefile | ||
31 | @@ -82,7 +82,7 @@ $(KEXEC): CPPFLAGS+=-I$(srcdir)/kexec/arch/$(ARCH)/include | ||
32 | |||
33 | $(KEXEC_MANPAGE): kexec/kexec.8 | ||
34 | @$(MKDIR) -p $(MANDIR)/man8 | ||
35 | - cp kexec/kexec.8 $(KEXEC_MANPAGE) | ||
36 | + cp $^ $(KEXEC_MANPAGE) | ||
37 | echo:: | ||
38 | @echo "KEXEC_SRCS $(KEXEC_SRCS)" | ||
39 | @echo "KEXEC_DEPS $(KEXEC_DEPS)" | ||
40 | diff --git a/kexec/arch/ppc/Makefile b/kexec/arch/ppc/Makefile | ||
41 | index 3dba7cf..41242a5 100644 | ||
42 | --- a/kexec/arch/ppc/Makefile | ||
43 | +++ b/kexec/arch/ppc/Makefile | ||
44 | @@ -1,7 +1,7 @@ | ||
45 | # | ||
46 | # kexec ppc (linux booting linux) | ||
47 | # | ||
48 | -include kexec/arch/ppc/libfdt/Makefile.libfdt | ||
49 | +include $(srcdir)/kexec/arch/ppc/libfdt/Makefile.libfdt | ||
50 | |||
51 | ppc_KEXEC_SRCS = kexec/arch/ppc/kexec-ppc.c | ||
52 | ppc_KEXEC_SRCS += kexec/arch/ppc/kexec-elf-ppc.c | ||
53 | |||
54 | |||