diff options
Diffstat (limited to 'meta-initramfs/recipes-devtools')
-rw-r--r-- | meta-initramfs/recipes-devtools/klibc/klibc-2.0.4/0001-Kbuild.klibc-Use-print-libgcc-file-name-instead-of-p.patch | 30 | ||||
-rw-r--r-- | meta-initramfs/recipes-devtools/klibc/klibc.inc | 5 |
2 files changed, 35 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-devtools/klibc/klibc-2.0.4/0001-Kbuild.klibc-Use-print-libgcc-file-name-instead-of-p.patch b/meta-initramfs/recipes-devtools/klibc/klibc-2.0.4/0001-Kbuild.klibc-Use-print-libgcc-file-name-instead-of-p.patch new file mode 100644 index 000000000..41cc14275 --- /dev/null +++ b/meta-initramfs/recipes-devtools/klibc/klibc-2.0.4/0001-Kbuild.klibc-Use-print-libgcc-file-name-instead-of-p.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From f66edde8a704131d98e8783ea8d4c848e8119b20 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 26 Jul 2017 16:13:16 -0700 | ||
4 | Subject: [PATCH 1/3] Kbuild.klibc: Use -print-libgcc-file-name instead of | ||
5 | --print-libgcc | ||
6 | |||
7 | -print-libgcc-file-name works with clang and gcc unlike --print-libgcc | ||
8 | which is gcc specific | ||
9 | |||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | scripts/Kbuild.klibc | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/scripts/Kbuild.klibc b/scripts/Kbuild.klibc | ||
16 | index f500d535..101f86f5 100644 | ||
17 | --- a/scripts/Kbuild.klibc | ||
18 | +++ b/scripts/Kbuild.klibc | ||
19 | @@ -128,7 +128,7 @@ KLIBCCFLAGS += $(KLIBCCPPFLAGS) $(KLIBCREQFLAGS) $(KLIBCARCHREQFLAGS) \ | ||
20 | KLIBCAFLAGS += -D__ASSEMBLY__ $(KLIBCCFLAGS) | ||
21 | KLIBCSTRIPFLAGS += --strip-all -R .comment -R .note | ||
22 | |||
23 | -KLIBCLIBGCC_DEF := $(shell $(KLIBCCC) $(KLIBCCFLAGS) --print-libgcc) | ||
24 | +KLIBCLIBGCC_DEF := $(shell $(KLIBCCC) $(KLIBCCFLAGS) -print-libgcc-file-name) | ||
25 | KLIBCLIBGCC ?= $(KLIBCLIBGCC_DEF) | ||
26 | KLIBCCRT0 := $(KLIBCOBJ)/arch/$(KLIBCARCHDIR)/crt0.o | ||
27 | KLIBCLIBC := $(KLIBCOBJ)/libc.a | ||
28 | -- | ||
29 | 2.13.3 | ||
30 | |||
diff --git a/meta-initramfs/recipes-devtools/klibc/klibc.inc b/meta-initramfs/recipes-devtools/klibc/klibc.inc index cd3f39808..45dc6baef 100644 --- a/meta-initramfs/recipes-devtools/klibc/klibc.inc +++ b/meta-initramfs/recipes-devtools/klibc/klibc.inc | |||
@@ -17,6 +17,7 @@ SRC_URI = "git://git.kernel.org/pub/scm/libs/klibc/klibc.git \ | |||
17 | file://0001-include-linux-sysinfo.h-directly.patch \ | 17 | file://0001-include-linux-sysinfo.h-directly.patch \ |
18 | file://0001-mkfifo-Implement-mkfifo.patch \ | 18 | file://0001-mkfifo-Implement-mkfifo.patch \ |
19 | file://0001-always-use-bfd-linker.patch \ | 19 | file://0001-always-use-bfd-linker.patch \ |
20 | file://0001-Kbuild.klibc-Use-print-libgcc-file-name-instead-of-p.patch \ | ||
20 | " | 21 | " |
21 | 22 | ||
22 | ARMPATCHES ?= "" | 23 | ARMPATCHES ?= "" |
@@ -48,6 +49,10 @@ do_configure () { | |||
48 | ln -sf "${STAGING_DIR_TARGET}${exec_prefix}" linux | 49 | ln -sf "${STAGING_DIR_TARGET}${exec_prefix}" linux |
49 | } | 50 | } |
50 | 51 | ||
52 | do_configure_prepend_toolchain-clang() { | ||
53 | sed -i -e 's#$(KLIBCROSS)gcc#$(KLIBCROSS)clang#g' ${S}/Makefile | ||
54 | } | ||
55 | |||
51 | INHIBIT_PACKAGE_STRIP = "1" | 56 | INHIBIT_PACKAGE_STRIP = "1" |
52 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | 57 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" |
53 | INSANE_SKIP_${PN} = "already-stripped" | 58 | INSANE_SKIP_${PN} = "already-stripped" |