summaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-devtools/grubby/grubby
diff options
context:
space:
mode:
Diffstat (limited to 'meta-initramfs/recipes-devtools/grubby/grubby')
-rw-r--r--meta-initramfs/recipes-devtools/grubby/grubby/0001-Add-another-variable-LIBS-to-provides-libraries-from.patch26
-rw-r--r--meta-initramfs/recipes-devtools/grubby/grubby/0002-include-paths.h-for-_PATH_MOUNTED.patch25
2 files changed, 51 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-devtools/grubby/grubby/0001-Add-another-variable-LIBS-to-provides-libraries-from.patch b/meta-initramfs/recipes-devtools/grubby/grubby/0001-Add-another-variable-LIBS-to-provides-libraries-from.patch
new file mode 100644
index 000000000..1b1a993a0
--- /dev/null
+++ b/meta-initramfs/recipes-devtools/grubby/grubby/0001-Add-another-variable-LIBS-to-provides-libraries-from.patch
@@ -0,0 +1,26 @@
1From 22afaa21b4b258082be591e54c99e1ba6fbd7748 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 15 Jul 2017 10:19:22 -0700
4Subject: [PATCH 1/2] Add another variable LIBS to provides libraries from env
5
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7---
8 Makefile | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/Makefile b/Makefile
12index ac14404..92a8e73 100644
13--- a/Makefile
14+++ b/Makefile
15@@ -27,7 +27,7 @@ RPM_OPT_FLAGS ?= -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector
16 CFLAGS += $(RPM_OPT_FLAGS) -std=gnu99 -Wall -Werror -Wno-error=unused-function -Wno-unused-function -ggdb
17 LDFLAGS :=
18
19-grubby_LIBS = -lblkid -lpopt
20+grubby_LIBS = -lblkid -lpopt ${LIBS}
21
22 all: grubby
23
24--
252.13.3
26
diff --git a/meta-initramfs/recipes-devtools/grubby/grubby/0002-include-paths.h-for-_PATH_MOUNTED.patch b/meta-initramfs/recipes-devtools/grubby/grubby/0002-include-paths.h-for-_PATH_MOUNTED.patch
new file mode 100644
index 000000000..de8133a3a
--- /dev/null
+++ b/meta-initramfs/recipes-devtools/grubby/grubby/0002-include-paths.h-for-_PATH_MOUNTED.patch
@@ -0,0 +1,25 @@
1From 8f844ac7f44b8dc428d06cd6958c5f32d383d01c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 15 Jul 2017 10:19:50 -0700
4Subject: [PATCH 2/2] include paths.h for _PATH_MOUNTED
5
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7---
8 grubby.c | 1 +
9 1 file changed, 1 insertion(+)
10
11diff --git a/grubby.c b/grubby.c
12index 47a1a15..59f74a9 100644
13--- a/grubby.c
14+++ b/grubby.c
15@@ -34,6 +34,7 @@
16 #include <libgen.h>
17 #include <execinfo.h>
18 #include <signal.h>
19+#include <paths.h>
20 #include <blkid/blkid.h>
21
22 #include "log.h"
23--
242.13.3
25