summaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-initramfs/recipes-devtools/dracut/dracut_git.bb')
-rw-r--r--meta-initramfs/recipes-devtools/dracut/dracut_git.bb19
1 files changed, 13 insertions, 6 deletions
diff --git a/meta-initramfs/recipes-devtools/dracut/dracut_git.bb b/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
index b91f3fae2..09c86d0b7 100644
--- a/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
+++ b/meta-initramfs/recipes-devtools/dracut/dracut_git.bb
@@ -5,13 +5,18 @@ LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6 6
7PE = "1" 7PE = "1"
8PV = "044+git${SRCREV}" 8PV = "045+git${SRCREV}"
9 9
10# v044 tag 10# v045 tag
11SRCREV = "1bc3e733f96033a508841e97fe08da7a12851782" 11SRCREV = "39c9b67f86145953aa30def9d77c68597a4ccfe8"
12SRC_URI = "git://git.kernel.org/pub/scm/boot/dracut/dracut.git;protocol=http" 12SRC_URI = "git://git.kernel.org/pub/scm/boot/dracut/dracut.git;protocol=http \
13 file://0001-util.h-include-sys-reg.h-when-libc-glibc.patch \
14 "
13 15
14inherit bash-completion 16DEPENDS += "kmod"
17DEPENDS_append_libc-musl = " fts"
18
19inherit bash-completion pkgconfig
15 20
16S = "${WORKDIR}/git" 21S = "${WORKDIR}/git"
17 22
@@ -30,7 +35,9 @@ EXTRA_OECONF = "--prefix=${prefix} \
30PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" 35PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
31PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,,systemd" 36PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_unitdir}/system/,,,systemd"
32 37
33EXTRA_OEMAKE += 'libdir=${prefix}/lib' 38EXTRA_OEMAKE += 'libdir=${prefix}/lib LDLIBS="${LDLIBS}"'
39
40LDLIBS_append_libc-musl = " -lfts"
34 41
35do_configure() { 42do_configure() {
36 ./configure ${EXTRA_OECONF} 43 ./configure ${EXTRA_OECONF}