diff options
Diffstat (limited to 'meta-initramfs/recipes-bsp')
-rw-r--r-- | meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb | 6 | ||||
-rw-r--r-- | meta-initramfs/recipes-bsp/kexecboot/kexecboot.inc | 14 |
2 files changed, 10 insertions, 10 deletions
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb index 6f70edd09..0b305f085 100644 --- a/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb +++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot-cfg_0.1.bb | |||
@@ -50,9 +50,9 @@ APPEND=${CMDLINE} ${CMDLINE_DEBUG} | |||
50 | } | 50 | } |
51 | 51 | ||
52 | do_install () { | 52 | do_install () { |
53 | install -d ${D}/boot | 53 | install -d ${D}/boot |
54 | install -m 0644 boot.cfg ${D}/boot/boot.cfg | 54 | install -m 0644 boot.cfg ${D}/boot/boot.cfg |
55 | install -m 0644 icon.xpm ${D}/boot/icon.xpm | 55 | install -m 0644 icon.xpm ${D}/boot/icon.xpm |
56 | } | 56 | } |
57 | 57 | ||
58 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 58 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot.inc b/meta-initramfs/recipes-bsp/kexecboot/kexecboot.inc index 2a53f96ac..b06293cc1 100644 --- a/meta-initramfs/recipes-bsp/kexecboot/kexecboot.inc +++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot.inc | |||
@@ -38,12 +38,12 @@ inherit autotools | |||
38 | EXTRA_OECONF = "--enable-delay=2 --enable-evdev-rate=1000,250" | 38 | EXTRA_OECONF = "--enable-delay=2 --enable-evdev-rate=1000,250" |
39 | 39 | ||
40 | do_install () { | 40 | do_install () { |
41 | install -d ${D}${bindir} | 41 | install -d ${D}${bindir} |
42 | install -m 0755 kexecboot ${D}${bindir}/ | 42 | install -m 0755 kexecboot ${D}${bindir}/ |
43 | install -d ${D}/proc | 43 | install -d ${D}/proc |
44 | install -d ${D}/mnt | 44 | install -d ${D}/mnt |
45 | install -d ${D}/dev | 45 | install -d ${D}/dev |
46 | install -d ${D}/sys | 46 | install -d ${D}/sys |
47 | } | 47 | } |
48 | 48 | ||
49 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 49 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
@@ -51,5 +51,5 @@ PACKAGE_ARCH = "${MACHINE_ARCH}" | |||
51 | FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev /sys" | 51 | FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev /sys" |
52 | 52 | ||
53 | pkg_postinst_${PN} () { | 53 | pkg_postinst_${PN} () { |
54 | ln -sf ${bindir}/kexecboot $D/init | 54 | ln -sf ${bindir}/kexecboot $D/init |
55 | } | 55 | } |