summaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0005-Use-LC_MESSAGES-for-address-localization-when-LC_ADD.patch33
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0006-Dont-add-usr-lib-to-LDFLAGS-when-linking-libphonenum.patch36
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server_3.32.4.bb3
3 files changed, 72 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0005-Use-LC_MESSAGES-for-address-localization-when-LC_ADD.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0005-Use-LC_MESSAGES-for-address-localization-when-LC_ADD.patch
new file mode 100644
index 000000000..55ab5a7fc
--- /dev/null
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server/0005-Use-LC_MESSAGES-for-address-localization-when-LC_ADD.patch
@@ -0,0 +1,33 @@
1From 95425206e7317e59b7ca06d7f838ad357cdd200c Mon Sep 17 00:00:00 2001
2From: Piotr Tworek <tworaz@tworaz.net>
3Date: Wed, 14 Aug 2019 00:31:54 +0200
4Subject: [PATCH 5/7] Use LC_MESSAGES for address localization when LC_ADDRESS
5 is not available.
6
7Musl does not define LC_ADDRESS unfortunately.
8
9Upstream-Status: Inappropriate [musl specific]
10
11Signed-off-by: Piotr Tworek <tworaz@tworaz.net>
12---
13 src/addressbook/libebook-contacts/e-phone-number-private.cpp | 4 ++++
14 1 file changed, 4 insertions(+)
15
16diff --git a/src/addressbook/libebook-contacts/e-phone-number-private.cpp b/src/addressbook/libebook-contacts/e-phone-number-private.cpp
17index 4c5aebb..9abcebd 100644
18--- a/src/addressbook/libebook-contacts/e-phone-number-private.cpp
19+++ b/src/addressbook/libebook-contacts/e-phone-number-private.cpp
20@@ -36,6 +36,10 @@
21 #include <phonenumbers/logger.h>
22 #include <phonenumbers/phonenumberutil.h>
23
24+#ifndef LC_ADDRESS
25+#define LC_ADDRESS LC_MESSAGES
26+#endif
27+
28 using i18n::phonenumbers::PhoneNumber;
29 using i18n::phonenumbers::PhoneNumberUtil;
30
31--
322.21.0
33
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0006-Dont-add-usr-lib-to-LDFLAGS-when-linking-libphonenum.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0006-Dont-add-usr-lib-to-LDFLAGS-when-linking-libphonenum.patch
new file mode 100644
index 000000000..c0c1427fd
--- /dev/null
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server/0006-Dont-add-usr-lib-to-LDFLAGS-when-linking-libphonenum.patch
@@ -0,0 +1,36 @@
1From fb9164bbca5b425f1cf1bb3cac51d06afe81938a Mon Sep 17 00:00:00 2001
2From: Piotr Tworek <tworaz@tworaz.net>
3Date: Wed, 14 Aug 2019 00:47:59 +0200
4Subject: [PATCH 6/7] Dont add /usr/lib to LDFLAGS when linking libphonenumber.
5
6This will refer to host lib dir which is not what we want.
7
8Upstream-Status: Inappropriate [configuration]
9
10Signed-off-by: Piotr Tworek <tworaz@tworaz.net>
11---
12 cmake/modules/FindPhonenumber.cmake | 6 ++----
13 1 file changed, 2 insertions(+), 4 deletions(-)
14
15diff --git a/cmake/modules/FindPhonenumber.cmake b/cmake/modules/FindPhonenumber.cmake
16index 04d1056..70c0c41 100644
17--- a/cmake/modules/FindPhonenumber.cmake
18+++ b/cmake/modules/FindPhonenumber.cmake
19@@ -37,12 +37,10 @@ string(TOUPPER "${WITH_PHONENUMBER}" optupper)
20 if(("${optupper}" STREQUAL "ON") OR ("${substr}" STREQUAL "${CMAKE_BINARY_DIR}"))
21 set(WITH_PHONENUMBER "ON")
22 set(PHONENUMBER_INCLUDE_DIRS "${INCLUDE_INSTALL_DIR}")
23- set(PHONENUMBER_LIB_DIRS ${LIB_INSTALL_DIR})
24- set(PHONENUMBER_LDFLAGS -L${PHONENUMBER_LIB_DIRS} ${PHONENUMBER_LDFLAGS})
25+ set(PHONENUMBER_LDFLAGS ${PHONENUMBER_LDFLAGS})
26 else(("${optupper}" STREQUAL "ON") OR ("${substr}" STREQUAL "${CMAKE_BINARY_DIR}"))
27 set(PHONENUMBER_INCLUDE_DIRS "${WITH_PHONENUMBER}/include")
28- set(PHONENUMBER_LIB_DIRS ${WITH_PHONENUMBER}/lib${LIB_SUFFIX})
29- set(PHONENUMBER_LDFLAGS -L${PHONENUMBER_LIB_DIRS} ${PHONENUMBER_LDFLAGS})
30+ set(PHONENUMBER_LDFLAGS ${PHONENUMBER_LDFLAGS})
31 endif(("${optupper}" STREQUAL "ON") OR ("${substr}" STREQUAL "${CMAKE_BINARY_DIR}"))
32
33 unset(bindirlen)
34--
352.21.0
36
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server_3.32.4.bb b/meta-gnome/recipes-gnome/eds/evolution-data-server_3.32.4.bb
index 4f1adb530..8d6c3aded 100644
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server_3.32.4.bb
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server_3.32.4.bb
@@ -21,6 +21,8 @@ SRC_URI = "${GNOME_MIRROR}/${GNOMEBN}/${@gnome_verdir("${PV}")}/${GNOMEBN}-${PV}
21 file://0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch \ 21 file://0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch \
22 file://0003-contact-Replace-the-Novell-sample-contact-with-somet.patch \ 22 file://0003-contact-Replace-the-Novell-sample-contact-with-somet.patch \
23 file://0004-Add-native-suffix-to-exacutables-produced-and-run-du.patch \ 23 file://0004-Add-native-suffix-to-exacutables-produced-and-run-du.patch \
24 file://0005-Use-LC_MESSAGES-for-address-localization-when-LC_ADD.patch \
25 file://0006-Dont-add-usr-lib-to-LDFLAGS-when-linking-libphonenum.patch \
24 file://0007-Modify-gobject-intrispection-support-to-work-with-OE.patch \ 26 file://0007-Modify-gobject-intrispection-support-to-work-with-OE.patch \
25 file://iconv-detect.h \ 27 file://iconv-detect.h \
26 " 28 "
@@ -42,6 +44,7 @@ PACKAGECONFIG[oauth2] = "-DENABLE_OAUTH2=ON,-DENABLE_OAUTH2=OFF,json-glib webkit
42PACKAGECONFIG[mitkrb5] = "-DWITH_KRB5=ON,-DWITH_KRB5=OFF,krb5" 44PACKAGECONFIG[mitkrb5] = "-DWITH_KRB5=ON,-DWITH_KRB5=OFF,krb5"
43PACKAGECONFIG[goa] = "-DENABLE_GOA=ON,-DENABLE_GOA=OFF,gnome-online-accounts" 45PACKAGECONFIG[goa] = "-DENABLE_GOA=ON,-DENABLE_GOA=OFF,gnome-online-accounts"
44PACKAGECONFIG[weather] = "-DENABLE_WEATHER=ON,-DENABLE_WEATHER=OFF,libgweather" 46PACKAGECONFIG[weather] = "-DENABLE_WEATHER=ON,-DENABLE_WEATHER=OFF,libgweather"
47PACKAGECONFIG[phonenumber] = "-DWITH_PHONENUMBER=ON,-DWITH_PHONENUMBER=OFF,libphonenumber"
45PACKAGECONFIG[introspection] = "-DENABLE_INTROSPECTION=ON,-DENABLE_INTROSPECTION=OFF" 48PACKAGECONFIG[introspection] = "-DENABLE_INTROSPECTION=ON,-DENABLE_INTROSPECTION=OFF"
46PACKAGECONFIG[vala] = "-DENABLE_VALA_BINDINGS=ON -DVAPIGEN=${STAGING_BINDIR_NATIVE}/vapigen,-DENABLE_VALA_BINDINGS=OFF" 49PACKAGECONFIG[vala] = "-DENABLE_VALA_BINDINGS=ON -DVAPIGEN=${STAGING_BINDIR_NATIVE}/vapigen,-DENABLE_VALA_BINDINGS=OFF"
47 50