diff options
Diffstat (limited to 'meta-gnome')
5 files changed, 20 insertions, 244 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0001-bluetooth-input-Fix-compile-errors.patch b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0001-bluetooth-input-Fix-compile-errors.patch deleted file mode 100644 index 0b0cf8b6e..000000000 --- a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0001-bluetooth-input-Fix-compile-errors.patch +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | From e3c789d6dca9a8a99b60b86e28d8119c55253c13 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 15 May 2013 08:37:03 -0700 | ||
4 | Subject: [PATCH] bluetooth-input: Fix compile errors | ||
5 | |||
6 | XID is unsigned long type so %d will error out with -Wformat | ||
7 | where format warnings are being treated at errors | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | |||
11 | Upstream-Status: Unknown | ||
12 | --- | ||
13 | wizard/bluetooth-input.c | 4 ++-- | ||
14 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/wizard/bluetooth-input.c b/wizard/bluetooth-input.c | ||
17 | index b3fbdaf..d17e67c 100644 | ||
18 | --- a/wizard/bluetooth-input.c | ||
19 | +++ b/wizard/bluetooth-input.c | ||
20 | @@ -190,12 +190,12 @@ bluetooth_input_check_for_devices (BluetoothInput *input) | ||
21 | if (bluetooth_input_device_get_type (&device_info[i], &is_mouse, &is_keyboard) == FALSE) | ||
22 | continue; | ||
23 | if (is_mouse != FALSE) { | ||
24 | - g_message ("has mouse: %s (id = %d)", device_info[i].name, device_info[i].id); | ||
25 | + g_message ("has mouse: %s (id = %lu)", device_info[i].name, device_info[i].id); | ||
26 | has_mouse = TRUE; | ||
27 | //break; | ||
28 | } | ||
29 | if (is_keyboard != FALSE) { | ||
30 | - g_message ("has keyboard: %s (id = %d)", device_info[i].name, device_info[i].id); | ||
31 | + g_message ("has keyboard: %s (id = %lu)", device_info[i].name, device_info[i].id); | ||
32 | has_keyboard = TRUE; | ||
33 | //break; | ||
34 | } | ||
35 | -- | ||
36 | 1.7.9.5 | ||
37 | |||
diff --git a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0002-bluetooth-client-use-valid-interface-names.patch b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0002-bluetooth-client-use-valid-interface-names.patch deleted file mode 100644 index 99049a0ca..000000000 --- a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0002-bluetooth-client-use-valid-interface-names.patch +++ /dev/null | |||
@@ -1,122 +0,0 @@ | |||
1 | From 1555f85b222db0d536efe277d31b57b2a8b938f4 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com> | ||
3 | Date: Thu, 12 Feb 2015 01:19:41 +0100 | ||
4 | Subject: [PATCH] bluetooth-client: use valid interface names | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | Upstream-Status: Inappropriate[version unmaintained upstream] | ||
10 | |||
11 | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> | ||
12 | --- | ||
13 | lib/bluetooth-client.c | 12 ++++++------ | ||
14 | lib/bluetooth-client.xml | 6 +++--- | ||
15 | lib/test-agent.c | 2 +- | ||
16 | 3 files changed, 10 insertions(+), 10 deletions(-) | ||
17 | |||
18 | diff --git a/lib/bluetooth-client.c b/lib/bluetooth-client.c | ||
19 | index d62d56d..02e194c 100644 | ||
20 | --- a/lib/bluetooth-client.c | ||
21 | +++ b/lib/bluetooth-client.c | ||
22 | @@ -721,7 +721,7 @@ static void add_device(DBusGProxy *adapter, GtkTreeIter *parent, | ||
23 | BLUEZ_DEVICE_INTERFACE, path); | ||
24 | |||
25 | if (device != NULL) | ||
26 | - device_get_properties(device, &hash, NULL); | ||
27 | + org_bluez_device_get_properties(device, &hash, NULL); | ||
28 | } else | ||
29 | device = NULL; | ||
30 | |||
31 | @@ -945,7 +945,7 @@ static void adapter_added(DBusGProxy *manager, | ||
32 | adapter = dbus_g_proxy_new_from_proxy(manager, | ||
33 | BLUEZ_ADAPTER_INTERFACE, path); | ||
34 | |||
35 | - adapter_get_properties(adapter, &hash, NULL); | ||
36 | + org_bluez_adapter_get_properties(adapter, &hash, NULL); | ||
37 | if (hash != NULL) { | ||
38 | value = g_hash_table_lookup(hash, "Address"); | ||
39 | address = value ? g_value_get_string(value) : NULL; | ||
40 | @@ -1178,7 +1178,7 @@ static void bluetooth_client_init(BluetoothClient *client) | ||
41 | dbus_g_proxy_connect_signal(priv->manager, "DefaultAdapterChanged", | ||
42 | G_CALLBACK(default_adapter_changed), client, NULL); | ||
43 | |||
44 | - manager_list_adapters(priv->manager, &array, NULL); | ||
45 | + org_bluez_manager_list_adapters(priv->manager, &array, NULL); | ||
46 | if (array != NULL) { | ||
47 | int i; | ||
48 | |||
49 | @@ -1189,7 +1189,7 @@ static void bluetooth_client_init(BluetoothClient *client) | ||
50 | } | ||
51 | } | ||
52 | |||
53 | - manager_default_adapter(priv->manager, &default_path, NULL); | ||
54 | + org_bluez_manager_default_adapter(priv->manager, &default_path, NULL); | ||
55 | if (default_path != NULL) { | ||
56 | default_adapter_changed(priv->manager, default_path, client); | ||
57 | g_free(default_path); | ||
58 | @@ -1541,7 +1541,7 @@ gboolean bluetooth_client_start_discovery(BluetoothClient *client) | ||
59 | if (adapter == NULL) | ||
60 | return FALSE; | ||
61 | |||
62 | - adapter_start_discovery(adapter, NULL); | ||
63 | + org_bluez_adapter_start_discovery(adapter, NULL); | ||
64 | |||
65 | g_object_unref(adapter); | ||
66 | |||
67 | @@ -1568,7 +1568,7 @@ gboolean bluetooth_client_stop_discovery(BluetoothClient *client) | ||
68 | if (adapter == NULL) | ||
69 | return FALSE; | ||
70 | |||
71 | - adapter_stop_discovery(adapter, NULL); | ||
72 | + org_bluez_adapter_stop_discovery(adapter, NULL); | ||
73 | |||
74 | g_object_unref(adapter); | ||
75 | |||
76 | diff --git a/lib/bluetooth-client.xml b/lib/bluetooth-client.xml | ||
77 | index 2326277..38c7fb0 100644 | ||
78 | --- a/lib/bluetooth-client.xml | ||
79 | +++ b/lib/bluetooth-client.xml | ||
80 | @@ -1,7 +1,7 @@ | ||
81 | <?xml version="1.0" encoding="UTF-8" ?> | ||
82 | |||
83 | <node name="/"> | ||
84 | - <interface name="manager"> | ||
85 | + <interface name="org.bluez.manager"> | ||
86 | <method name="DefaultAdapter"> | ||
87 | <arg type="o" direction="out"/> | ||
88 | </method> | ||
89 | @@ -16,7 +16,7 @@ | ||
90 | </method> | ||
91 | </interface> | ||
92 | |||
93 | - <interface name="adapter"> | ||
94 | + <interface name="org.bluez.adapter"> | ||
95 | <method name="GetProperties"> | ||
96 | <arg type="a{sv}" direction="out"/> | ||
97 | </method> | ||
98 | @@ -44,7 +44,7 @@ | ||
99 | </method> | ||
100 | </interface> | ||
101 | |||
102 | - <interface name="device"> | ||
103 | + <interface name="org.bluez.device"> | ||
104 | <method name="GetProperties"> | ||
105 | <arg type="a{sv}" direction="out"/> | ||
106 | </method> | ||
107 | diff --git a/lib/test-agent.c b/lib/test-agent.c | ||
108 | index 8d60da6..83464eb 100644 | ||
109 | --- a/lib/test-agent.c | ||
110 | +++ b/lib/test-agent.c | ||
111 | @@ -40,7 +40,7 @@ static gboolean agent_pincode(DBusGMethodInvocation *context, | ||
112 | GValue *value; | ||
113 | const gchar *address, *name; | ||
114 | |||
115 | - device_get_properties(device, &hash, NULL); | ||
116 | + org_bluez_device_get_properties(device, &hash, NULL); | ||
117 | |||
118 | if (hash != NULL) { | ||
119 | value = g_hash_table_lookup(hash, "Address"); | ||
120 | -- | ||
121 | 1.9.3 | ||
122 | |||
diff --git a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0003-Fix-build-with-libnotify-0.7.0.patch b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0003-Fix-build-with-libnotify-0.7.0.patch deleted file mode 100644 index 118ef93e3..000000000 --- a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth/0003-Fix-build-with-libnotify-0.7.0.patch +++ /dev/null | |||
@@ -1,47 +0,0 @@ | |||
1 | From 08a5b66d709781c0c596108278979a11b26331d5 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com> | ||
3 | Date: Sun, 30 Aug 2015 12:14:53 +0200 | ||
4 | Subject: [PATCH] Fix build with libnotify >= 0.7.0 | ||
5 | MIME-Version: 1.0 | ||
6 | Content-Type: text/plain; charset=UTF-8 | ||
7 | Content-Transfer-Encoding: 8bit | ||
8 | |||
9 | Upstream-Status: Backport [1] | ||
10 | |||
11 | [1] https://github.com/GNOME/gnome-bluetooth/commit/9f256799cc6b8367b2466f35b82f1d07076a950e | ||
12 | |||
13 | Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> | ||
14 | --- | ||
15 | applet/notify.c | 2 +- | ||
16 | configure.ac | 2 +- | ||
17 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
18 | |||
19 | diff --git a/applet/notify.c b/applet/notify.c | ||
20 | index d2a4f51..cb01dfc 100644 | ||
21 | --- a/applet/notify.c | ||
22 | +++ b/applet/notify.c | ||
23 | @@ -71,7 +71,7 @@ void show_notification(const gchar *summary, const gchar *message, | ||
24 | notify_notification_close(notify, NULL); | ||
25 | } | ||
26 | |||
27 | - notify = notify_notification_new(summary, message, icon_name, NULL); | ||
28 | + notify = notify_notification_new(summary, message, icon_name); | ||
29 | |||
30 | notify_notification_set_timeout(notify, timeout); | ||
31 | |||
32 | diff --git a/configure.ac b/configure.ac | ||
33 | index 8bbce4e..98ec86e 100644 | ||
34 | --- a/configure.ac | ||
35 | +++ b/configure.ac | ||
36 | @@ -71,7 +71,7 @@ AM_CONDITIONAL([ICON_UPDATE], [test -n "$UPDATE_ICON_CACHE"]) | ||
37 | GTK_REQUIRED=2.19.1 | ||
38 | GLIB_REQUIRED=2.25.7 | ||
39 | DBUS_GLIB_REQUIRED=0.74 | ||
40 | -NOTIFY_REQUIRED=0.4.3 | ||
41 | +NOTIFY_REQUIRED=0.7.0 | ||
42 | NAUTILUS_SENDTO_REQUIRED=2.31.7 | ||
43 | |||
44 | dnl Requires for the properties window | ||
45 | -- | ||
46 | 2.1.0 | ||
47 | |||
diff --git a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_2.32.0.bb b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_2.32.0.bb deleted file mode 100644 index f2128d8c3..000000000 --- a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_2.32.0.bb +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | SUMMARY = "GNOME bluetooth manager" | ||
2 | LICENSE = "GPLv2 & LGPLv2.1" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \ | ||
4 | file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \ | ||
5 | " | ||
6 | |||
7 | PR = "r1" | ||
8 | |||
9 | SECTION = "x11/gnome" | ||
10 | DEPENDS = "obexd gnome-doc-utils-native gnome-doc-utils gconf gtk+ dbus-glib libunique libnotify libgnome-keyring virtual/libx11 libxi intltool-native" | ||
11 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','bluez5','bluez5','bluez4',d)}" | ||
12 | |||
13 | inherit gnomebase gtk-icon-cache | ||
14 | |||
15 | SRC_URI += " \ | ||
16 | file://0001-bluetooth-input-Fix-compile-errors.patch \ | ||
17 | file://0002-bluetooth-client-use-valid-interface-names.patch \ | ||
18 | file://0003-Fix-build-with-libnotify-0.7.0.patch \ | ||
19 | " | ||
20 | SRC_URI[archive.md5sum] = "f129686fe46c4c98eb70a0cc85d59cae" | ||
21 | SRC_URI[archive.sha256sum] = "57b1f06c96a1b85e1c19ff919d708cc38e95edae658881ed99968c325839a973" | ||
22 | GNOME_COMPRESS_TYPE="bz2" | ||
23 | |||
24 | # No 'nautilus-sendto' recipe in meta-gnome yet | ||
25 | EXTRA_OECONF += "--enable-nautilus-sendto=no" | ||
26 | |||
27 | # No native docbook XSL stylesheets recipe in OE yet | ||
28 | do_configure_prepend() { | ||
29 | sed -i s/help// ${S}/Makefile.am | ||
30 | } | ||
31 | |||
32 | do_configure_append() { | ||
33 | sed -i 's,func_fatal_error "error: cannot install,echo "bogus message about,' ${HOST_SYS}-libtool | ||
34 | } | ||
35 | |||
36 | RRECOMMENDS_${PN} += "obexd obex-data-server" | ||
37 | |||
38 | FILES_${PN}-dbg += "${libdir}/gnome-bluetooth/plugins/.debug/" | ||
diff --git a/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_3.18.2.bb b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_3.18.2.bb new file mode 100644 index 000000000..77e9a15f8 --- /dev/null +++ b/meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_3.18.2.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | SUMMARY = "GNOME bluetooth manager" | ||
2 | LICENSE = "GPLv2 & LGPLv2.1" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \ | ||
4 | file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \ | ||
5 | " | ||
6 | |||
7 | SECTION = "x11/gnome" | ||
8 | |||
9 | # systemd is needed because it has a necessary version of libudev | ||
10 | # Effectively this means that systemd must be in DISTRO_FEATURES | ||
11 | DEPENDS = "systemd gtk+3 libnotify libcanberra" | ||
12 | DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','bluez5','bluez5','bluez4',d)}" | ||
13 | |||
14 | inherit gnomebase gtk-icon-cache distro_features_check | ||
15 | REQUIRED_DISTRO_FEATURES = "systemd" | ||
16 | |||
17 | SRC_URI[archive.md5sum] = "75d09c924468ec0c687f9ab3acf7f113" | ||
18 | SRC_URI[archive.sha256sum] = "d8df073c331df0f97261869fb77ffcdbf4e3e4eaf460d3c3ed2b16e03d9c5398" | ||
19 | |||
20 | FILES_${PN}-dbg += "${libdir}/gnome-bluetooth/plugins/.debug/" | ||